View Issue Details

IDProjectCategoryView StatusLast Update
0005624Kali Linux[All Projects] New Tool Requestspublic2019-08-15 13:48
ReporternethunterAssigned Torhertzog 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version2019.2 
Target VersionFixed in Version 
Summary0005624: Can't install PowerShell on Kali 2019.2
DescriptionHi, I have Kali Linux 2019.2 64-bit on VMware and Windows 10 Host. I am trying to install PowerShell. Here are my errors...I've tried aptitude and synaptic. Neither worked. Can anyone take a look and fix this? Please reply. Thanks

*UPDATE*
I tried installing clean on VMware. I thought I had it figured out but didn't. See if this info helps...I entered "echo "deb [arch=amd64] https://packages.microsoft.com/repos/microsoft-debian-stretch-prod stretch main" > /etc/apt/sources.list.d/powershell.list apt update" on the first install with the errors. So I tried 2 separate:
 "echo "deb [arch=amd64] https://packages.microsoft.com/repos/microsoft-debian-stretch-prod stretch main" > /etc/apt/sources.list.d/powershell.list"

And
"apt update". (2 separate not one together.) I still get the error below after "apt install -y powershell". Any ideas???
Full message:

root@kali:~# apt -y install powershell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
powershell : Depends: libicu57 but it is not installable
E: Unable to correct problems, you have held broken packages.

SECOND ERROR:

I tried "sudo aptitude -y install powershell." Got a huge error:

The following NEW packages will be installed:
liblttng-ust-ctl4{a} liblttng-ust0{a} powershell{b}
0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 58.1 MB of archives. After unpacking 159 MB will be used.
The following packages have unmet dependencies:
powershell : Depends: libicu57 which is a virtual package and is not provided by any available package

The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) powershell [Not Installed]



No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
W: Target DEP-11-icons-small (main/dep11/icons-48x48.tar) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/microsoft.list:1 and /etc/apt/sources.list.d/powershell.list:1

And:

root@kali:~# pwsh
bash: pwsh: command not found

Relationships

duplicate of 0005290 assignedrhertzog Adding Powershell Core to be in the main installation of Kali Linux 

Activities

crash

2019-08-09 13:49

reporter   ~0010846

Hi nethunter,

Download the lib from: http://ftp.us.debian.org/debian/pool/main/i/icu/libicu57_57.1-9_amd64.deb
#dpkg -i libicu57_57.1-9_amd64.deb

Try to install the powershell again.

Looks like there is something broken to download the right pkg.
I just reproduced the issue and its working fine now.

nethunter

2019-08-09 21:31

reporter   ~0010849

The libicu57 worked. I have PowerShell now. Thanks for the help!

rhertzog

2019-08-15 13:48

administrator   ~0010880

Request to add powershell in Kali is already filed in 0005290.

Issue History

Date Modified Username Field Change
2019-08-08 21:26 nethunter New Issue
2019-08-09 13:49 crash Note Added: 0010846
2019-08-09 21:31 nethunter Note Added: 0010849
2019-08-15 13:48 rhertzog Assigned To => rhertzog
2019-08-15 13:48 rhertzog Status new => closed
2019-08-15 13:48 rhertzog Resolution open => duplicate
2019-08-15 13:48 rhertzog Note Added: 0010880
2019-08-15 13:48 rhertzog Relationship added duplicate of 0005290