View Issue Details

IDProjectCategoryView StatusLast Update
0005644Kali Linux[All Projects] Kali Package Bugpublic2019-08-23 12:58
Reporterfl0Assigned Torhertzog 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.2 
Target VersionFixed in Version2019.3 
Summary0005644: Kernel 5.2.9-1kali1 config CONFIG_INTEL_IOMMU_DEFAULT_ON=y
DescriptionOn some computer (e.g.: a Thinkpad T550 with HD Graphics 5500) the new kernel configuration 'CONFIG_INTEL_IOMMU_DEFAULT_ON=y' causes a boot loop:

Aug 20 15:10:09 kali kernel: [ 54.026542] i915 0000:00:02.0: Resetting rcs0 for no progress on rcs0
Aug 20 15:10:09 kali kernel: [ 54.734420] dmar_fault: 1765455 callbacks suppressed
Aug 20 15:10:09 kali kernel: [ 54.734421] DMAR: DRHD: handling fault status reg 3
Aug 20 15:10:09 kali kernel: [ 54.735349] DMAR: [DMA Write] Request device [00:02.0] fault addr ffff44713000 [fault reason 23] Unknown
Aug 20 15:10:09 kali kernel: [ 54.736327] DMAR: DRHD: handling fault status reg 3
Aug 20 15:10:09 kali kernel: [ 54.737594] DMAR: [DMA Write] Request device [00:02.0] fault addr ffff44bd8000 [fault reason 23] Unknown
Aug 20 15:10:09 kali kernel: [ 54.738639] DMAR: DRHD: handling fault status reg 3
Aug 20 15:10:09 kali kernel: [ 54.739793] DMAR: [DMA Write] Request device [00:02.0] fault addr ffff451a1000 [fault reason 23] Unknown
Aug 20 15:10:09 kali kernel: [ 54.740934] DMAR: DRHD: handling fault status reg 3
Aug 20 15:10:14 kali kernel: [ 59.738420] dmar_fault: 4082819 callbacks suppressed
...
Aug 20 15:10:27 kali org.gnome.Shell.desktop[1066]: i965: Failed to submit batchbuffer: Input/output error
Steps To ReproduceUpdate to the latest kernel
Additional InformationThe 5.2.5 Kali dev kernel was not affected.

A workaround: add intel_iommu=off to /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=off"

Activities

rhertzog

2019-08-20 14:00

administrator   ~0010909

That option has been enabled in response to this bug report:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=934309

I'm not sure that disabling it is better.

Do you happen to know if there's an upstream fix already? Or at least a corresponding bug report? Because reporting the bug to Kali will not help to get it fixed where it matters.

How did you find out the relationship between that option and the failure that you encountered?

fl0

2019-08-20 14:13

reporter   ~0010910

I was not aware of the debian bug #934309.

The config change is on the Deban side, sorry.

For my T550 laptop it solved the issue.

I search about my 'DMAR: DRHD: handling fault' error and found that is related to intel iommu:

https://bbs.archlinux.org/viewtopic.php?id=230362

rhertzog

2019-08-21 10:04

administrator   ~0010912

We have released an updated kernel that disables that option for now... but it's a short term fix. On the Debian side, they do not want to revert that setting apparently. They are looking for other quirks to fix it.

Apparently, the better work-around is to use "intel_iommu=igfx_off" on the kernel parameters at boot time. I'm not sure if that can be configured by default in the kernel.

Someone else reported a similar problem in Debian and upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=111451

rhertzog

2019-08-21 10:20

administrator   ~0010913

Bug in Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=935270

fl0

2019-08-21 16:25

reporter   ~0010914

Strange, still have the bug with 5.2.0-kali2-amd64.
I see the commit but CONFIG_INTEL_IOMMU_DEFAULT_ON is y again:

root@kali:~# grep -i 'intel_iommu_def' /boot/config-5.2.0-kali2-amd64
CONFIG_INTEL_IOMMU_DEFAULT_ON=y
root@kali:~# uname -a
Linux kali 5.2.0-kali2-amd64 0000001 SMP Debian 5.2.9-1kali2 (2019-08-20) x86_64 GNU/Linux

rhertzog

2019-08-22 09:09

administrator   ~0010915

Can you try with Debian's kernel linux-image-5.2.0-2-amd64 in version 5.2.9-2 which is in Debian unstable?

Does that kernel work for you?

rhertzog

2019-08-22 09:39

administrator   ~0010916

@fl0 I also wanted to know if booting with "intel_iommu=igfx_off" was sufficient to fix your issue. Or do you really need "intel_iommu=off" ?

If you can reply quickly, it would be appreciated, as we want to fix that kernel issue for the 2019.3 release that we are currently working on. TIA.

rhertzog

2019-08-22 10:09

administrator   ~0010917

Note that the updated Debian kernel has intel_iommu enabled but with a new option where it disables iommu for the Intel GPU on the root bus only (see https://salsa.debian.org/kernel-team/linux/commit/154cf246f657fc7d077a9bc0aa31ca4d32cfdeaf).

fl0

2019-08-22 10:56

reporter   ~0010919

"intel_iommu=igfx_off" fix the issue.

But i have to add it manually to /boot/default/grub with 5.2.0-kali2-amd64.

fl0

2019-08-22 11:28

reporter   ~0010920

Ok, I've tried kernel linux-image-5.2.0-2-amd64 from Debian unstable: issue resolved, no need to manually edit /boot/default.grub.

fl0

2019-08-22 12:24

reporter   ~0010922

/etc/default/grub not /boot/default.grub

rhertzog

2019-08-23 08:56

administrator   ~0010927

The kernel 5.2.9-2kali1 now in kali-rolling should thus fix your issues.

fl0

2019-08-23 11:44

reporter   ~0010928

Yes fixed !

rhertzog

2019-08-23 12:58

administrator   ~0010929

Thanks for the confirmation, closing.

Issue History

Date Modified Username Field Change
2019-08-20 13:45 fl0 New Issue
2019-08-20 14:00 rhertzog Note Added: 0010909
2019-08-20 14:13 fl0 Note Added: 0010910
2019-08-21 10:04 rhertzog Note Added: 0010912
2019-08-21 10:04 rhertzog Assigned To => rhertzog
2019-08-21 10:04 rhertzog Status new => assigned
2019-08-21 10:20 rhertzog Note Added: 0010913
2019-08-21 16:25 fl0 Note Added: 0010914
2019-08-22 09:09 rhertzog Note Added: 0010915
2019-08-22 09:39 rhertzog Note Added: 0010916
2019-08-22 10:09 rhertzog Note Added: 0010917
2019-08-22 10:56 fl0 Note Added: 0010919
2019-08-22 11:28 fl0 Note Added: 0010920
2019-08-22 12:24 fl0 Note Added: 0010922
2019-08-23 08:56 rhertzog Note Added: 0010927
2019-08-23 11:44 fl0 Note Added: 0010928
2019-08-23 12:58 rhertzog Status assigned => resolved
2019-08-23 12:58 rhertzog Resolution open => fixed
2019-08-23 12:58 rhertzog Fixed in Version => 2019.3
2019-08-23 12:58 rhertzog Note Added: 0010929