View Issue Details

IDProjectCategoryView StatusLast Update
0005673Kali Linux[All Projects] General Bugpublic2019-09-12 07:24
ReportereDog Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.3 
Target VersionFixed in Version 
Summary0005673: virtualbox amd64 image failed to import
DescriptionWhen I try to import .ova image - import process failed at the end with message:

Failed to import appliance /home/edog/dl/iso/kali/kali-linux-2019.3-vbox-amd64.ova.

Digest mismatch (VERR_NOT_EQUAL):
Attribute 'SHA1' on 'Kali-Linux-2019.3-vbox-amd64-disk002.vmdk' does not match ('fc7445ed4aafee99ee9c3930afe2201f33f407ed' vs. '83fa54d0d1356d68f1269e2963ecd302f04754c2').

Result Code:
VBOX_E_FILE_ERROR (0x80BB0004)
Component:
ApplianceWrap
Interface:
IAppliance {86a98347-7619-41aa-aece-b21ac5c1a7e6}
Steps To ReproduceIn virtualbox:
File -> Import Appliance... -> Select .ova image to import -> Import -> Waiting importing porcess -> at 99% fail message appears
Additional Informationdebian amd64, virtualbox 6.0.10-dfsg-5

Activities

eDog

2019-09-04 11:43

reporter   ~0010958

sha256sum is ok

$ sha256sum kali-linux-2019.3-vbox-amd64.ova
5c63cdaa16511e5a0e376136252d405c1f50675428d0f76fb11457aa7e944873 kali-linux-2019.3-vbox-amd64.ova

up4k

2019-09-08 07:02

reporter   ~0011065

Same issue but another sha1sum of VMDK image and another error in VirtualBox.
IDK may be in my case VBox don't check sums.

$ sha256sum kali-linux-2019.3-vbox-amd64.ova
5c63cdaa16511e5a0e376136252d405c1f50675428d0f76fb11457aa7e944873 kali-linux-2019.3-vbox-amd64.ova
$ tar -xvf kali-linux-2019.3-vbox-amd64.ova
Kali-Linux-2019.3-vbox-amd64.ovf
Kali-Linux-2019.3-vbox-amd64-disk002.vmdk
Kali-Linux-2019.3-vbox-amd64.mf
$ sha1sum -c Kali-Linux-2019.3-vbox-amd64.mf
Kali-Linux-2019.3-vbox-amd64.ovf: OK
Kali-Linux-2019.3-vbox-amd64-disk002.vmdk: FAILED
sha1sum: WARNING: 1 computed checksum did NOT match
$ grep vmdk Kali-Linux-2019.3-vbox-amd64.mf
SHA1 (Kali-Linux-2019.3-vbox-amd64-disk002.vmdk) = fc7445ed4aafee99ee9c3930afe2201f33f407ed
$ sha1sum --tag Kali-Linux-2019.3-vbox-amd64-disk002.vmdk
SHA1 (Kali-Linux-2019.3-vbox-amd64-disk002.vmdk) = 9c4436ee744878175043f740742b9638aa69163b

$ tail -1 VBoxSVC.log
00:12:05.219642 createImport ERROR [COM]: aRC=VBOX_E_FILE_ERROR (0x80bb0004) aIID={ad47ad09-787b-44ab-b343-a082a3f2dfb1} aComponent={MediumWrap} aText={Could not create the imported medium 'D:\VBox\Kali-Linux-2019.3-vbox-amd64\Kali-Linux-2019.3-vbox-amd64-disk002.vmdk' (VERR_VD_VMDK_INVALID_FORMAT)}, preserve=false aResultDetail=-3244

eDog

2019-09-11 22:06

reporter   ~0011076

On download page presents a new one image 'Kali-Linux-2019.3a-vbox-amd64.ova' which is ok.
The issue is solved.

rhertzog

2019-09-12 07:24

administrator   ~0011079

Indeed, we released an updated image. Closing the ticket.

Issue History

Date Modified Username Field Change
2019-09-04 11:40 eDog New Issue
2019-09-04 11:43 eDog Note Added: 0010958
2019-09-08 07:02 up4k Note Added: 0011065
2019-09-11 22:06 eDog Note Added: 0011076
2019-09-12 07:24 rhertzog Assigned To => rhertzog
2019-09-12 07:24 rhertzog Status new => resolved
2019-09-12 07:24 rhertzog Resolution open => fixed
2019-09-12 07:24 rhertzog Note Added: 0011079