View Issue Details

IDProjectCategoryView StatusLast Update
0005707Kali Linux[All Projects] General Bugpublic2019-09-20 05:13
Reporterx00syn4ps3 Assigned To 
PriorityhighSeveritycrashReproducibilityrandom
Status newResolutionopen 
Product Version2019.3 
Target VersionFixed in Version 
Summary0005707: 64-bit ARM 2019.3a crashing during apt upgrade on Pi 4
DescriptionI have tried searching to find any other posted issues regarding what I have experienced but haven't found any thus far. I recently downloaded the new 2019.3a x64 ARM download to run on my 4GB Pi 4. Everything boots up fine, but during the apt upgrade process, I start getting all these dpkg errors towards the end of the process and apt just quits.
First time around I went to type in "reboot" to try again, but was greeted with a "bash: reboot command not recognized". I exited out of the terminal and then the whole X screen closes out and gives errors related to X-org and what not not working, and it just loops through that. Worst part is I unplugged my Pi and went to flash a fresh image onto the SD card, and the card is permanently locked in "Read-Only" mode!!! The crash ruined one of my cards so I went out and bought a new one, and the same issue happened again. Except when the dpkg errors popped up I straight unplugged it and managed to save my SD.
The second time this happened I was on my PC and my Pi automatically locked and I ran over to unlock it so that the upgrade could continue, and soon after the crash and errors happened. Is this happening because of the Pi screen locking or is it a software issue???
My other Pi 4 running the 32-bit Kali 2019.3 has had no issues what-so-ever...

***UPDATE 9.19.2019 - 32-BIT ARM version also crashing after first boot on Pi 4 during apt upgrade***
Steps To ReproduceDownloaded and flashed fresh 32-bit image of 2019.3a, and during "apt update && apt upgrade" after first boot, it crashed again during a ruby package upgrade (see pic).
Additional InformationI thought the first time this happened for my 64-bit version was because I walked away and the pi auto-locked. I disabled that and it still happens. Side note: I've ran this on two separate Pi 4's with two different SD cards.

Activities

x00syn4ps3

2019-09-20 01:00

reporter  

kali-error (4).jpg (1,661,917 bytes)

Issue History

Date Modified Username Field Change
2019-09-20 00:51 x00syn4ps3 New Issue
2019-09-20 01:00 x00syn4ps3 File Added: kali-error (4).jpg