View Issue Details

IDProjectCategoryView StatusLast Update
0005727Kali Linux[All Projects] General Bugpublic2019-10-12 15:37
Reporterj_jitoAssigned Torhertzog 
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.3 
Target VersionFixed in Version 
Summary0005727: Gnome Shell crashes after "libgnome-desktop-3-18" installation
DescriptionAfter upgrading my kali packages, like I usually do every Saturday, everything went well, till I reboot, and BOOOOOOOOOOOOOM!!!!!!!!!!!

Gnome crash and doesn't start, no login screen, only black screen with curser.

After I switch to another VT, here is what I found in /var/log/messages/ in the screenshoot "asset2" below
Steps To Reproduceapt update && apt full-upgrade

The following NEW packages will be installed:
  gir1.2-handy-0.0 libgnome-desktop-3-18 libhandy-0.0-0
The following packages will be upgraded:
  cheese eog evince evince-common gdm3 gir1.2-freedesktop gir1.2-gdm-1.0 gir1.2-glib-2.0 gir1.2-gnomedesktop-3.0 gir1.2-poppler-0.18 gir1.2-totem-1.0 gjs gnome-boxes gnome-font-viewer gnome-keyring gnome-keyring-pkcs11 gnome-screenshot gnome-software gnome-tweaks libevdocument3-4 libevview3-3 libgdm1 libgnome-desktop-3-dev libnautilus-extension1a libpam-gnome-keyring libtotem0 nautilus totem totem-plugins
Need to get 121 MB of archives.
After this operation, 19,1 MB of additional disk space will be used.


The upgrading packages require the installation of "libgnome-desktop-3-18" and this one breaks gnome after reboot
Additional InformationAs kali admins suggested for a temporary fix, until the release of a permanent fix from Gnome, here is what you can do:

- systemctl set-default multi-user.target (work in text mode)
OR
- apt install lightdm (lightdm instead of gdm3)

Relationships

related to 0005726 resolvedrhertzog black screen at login prompt and no alternate VTs 

Activities

j_jito

2019-10-06 09:52

reporter   ~0011158

Here is the logs screenshot

j_jito

2019-10-06 09:54

reporter   ~0011159

#screenshot

asset2.JPG (672,236 bytes)

morepoints

2019-10-06 16:09

reporter   ~0011160

I am also having this issue and was able to narrow it down to the gir1.2-gnomedesktop-3.0 package.

j_jito

2019-10-06 17:09

reporter   ~0011161

If you upgrade gir1.2-gnomedesktop-3.0, it will automatically install libgnome-desktop-3-18
In any case, libgnome-desktop-3-18 is causing black screen issues and breaks gnome shell

fl0

2019-10-06 18:14

reporter   ~0011162

Yes it is caused by gir1.2-gnomedesktop-3.0 version 3.34.0-2, i downgrade it to 3.30.2.1-2 .

The bug on Debian side: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=941782 .

j_jito

2019-10-06 18:31

reporter   ~0011163

Ok, after reading more about the bug, it only affects gnome-shell <= 3.34.
Kali need to release the latest gnome-shell in order to fix this

Gnome has fixed the issue one month ago, because at kali, we're still using gnome-shell 3.30.2

rhertzog

2019-10-06 19:52

administrator   ~0011164

We have downgraded the gnome-desktop3 source package in kali-rolling for now as switching to the new gnome-shell 3.34 requires some preliminary work to update our kali menu patch (in gnome-shell-extensions).

If you have already upgraded to the broken version, run this command in a root command line:
# apt install gir1.2-gnomedesktop-3.0/kali-rolling
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '3.30.2.1-2' (kali-rolling [amd64]) for 'gir1.2-gnomedesktop-3.0'
The following packages will be DOWNGRADED:
  gir1.2-gnomedesktop-3.0
[...]

j_jito

2019-10-06 20:32

reporter   ~0011166

After downgrading gnome-desktop3-data (apt install gnome-desktop3-data/kali-rolling), this is what I get after upgrading:

apt update && apt full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
Use 'apt autoremove' to remove it.
The following packages will be REMOVED:
  evince folder-color gnome-core gnome-sushi nautilus nautilus-share totem-plugins
The following NEW packages will be installed:
  gir1.2-handy-0.0 libhandy-0.0-0
The following packages have been kept back:
  cheese eog gir1.2-totem-1.0 gnome-font-viewer gnome-software libtotem0 totem
The following packages will be upgraded:
  evince-common gdm3 gir1.2-freedesktop gir1.2-gdm-1.0 gir1.2-glib-2.0 gir1.2-ibus-1.0 gnome-boxes gnome-keyring gnome-keyring-pkcs11gnome-screenshot gnome-tweaks libevdocument3-4 libevview3-3 libgmime-3.0-0 libnautilus-extension1a libpam-gnome-keyring
Need to get 121 MB of archives.
After this operation, 14,5 MB of additional disk space will be used.

The good thing, libgnome-desktop-3-18 won't be installed, but I'll loose important packages like Nautilus (File Manager) and Evince (PDF Reader) and other gnome apps won't be updated!

j_jito

2019-10-07 15:39

reporter   ~0011168

I can confirm rhertzog solution is working

I just did a full-upgrade this morning, and everything worked well.

gir1.2-gnomedesktop-3.0 nor libgnome-desktop-3-18 won't be installed, anymore.

Thank you guys

j_jito

2019-10-09 18:35

reporter   ~0011180

Debian unstable has release patch for those packages
libgnome-desktop-3-18 = 3.34.1-1
gnome-desktop3-data = 3.34.1-1

I have installed them, and indeed no more crash or black login screen.

Kali admins can push them into kali-rolling repo, so it can fix other issues like Nautilus or gnome-sushi removal

rhertzog

2019-10-10 11:40

administrator   ~0011182

We completed the transition to Gnome 3.34. Should be fixed in kali-rolling now.

Issue History

Date Modified Username Field Change
2019-10-06 09:50 j_jito New Issue
2019-10-06 09:52 j_jito Note Added: 0011158
2019-10-06 09:54 j_jito File Added: asset2.JPG
2019-10-06 09:54 j_jito Note Added: 0011159
2019-10-06 16:09 morepoints Note Added: 0011160
2019-10-06 17:09 j_jito Note Added: 0011161
2019-10-06 18:14 fl0 Note Added: 0011162
2019-10-06 18:31 j_jito Note Added: 0011163
2019-10-06 19:52 rhertzog Note Added: 0011164
2019-10-06 20:13 rhertzog Assigned To => rhertzog
2019-10-06 20:13 rhertzog Status new => assigned
2019-10-06 20:32 j_jito Note Added: 0011166
2019-10-07 10:16 sbrun Relationship added related to 0005726
2019-10-07 15:39 j_jito Note Added: 0011168
2019-10-09 18:35 j_jito Note Added: 0011180
2019-10-10 11:40 rhertzog Status assigned => resolved
2019-10-10 11:40 rhertzog Resolution open => fixed
2019-10-10 11:40 rhertzog Note Added: 0011182