View Issue Details

IDProjectCategoryView StatusLast Update
0005731Kali Linux[All Projects] Kali Package Bugpublic2019-10-17 20:32
Reporterngocbinh Assigned Torhertzog  
PrioritynormalSeveritycrashReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target VersionFixed in Version 
Summary0005731: Missing folder application
DescriptionAfter update kali to the lastest release with this command "apt update && apt -y full-upgrade".
i have missing folder app, see picture for more information.

root@Kali:~# uname -a
Linux Kali 5.2.0-kali3-amd64 0000001 SMP Debian 5.2.17-1kali1 (2019-09-27) x86_64 GNU/Linux
root@Kali:~# lsb_release -a
No LSB modules are available.
Distributor ID: Kali
Description: Kali GNU/Linux Rolling
Release: 2019.4
Codename: kali-rolling
Additional InformationWhen choose to Places, at top left, it will change to vscode
But i still can choose file (picture 2)

Activities

ngocbinh

2019-10-08 09:11

reporter  

Screenshot from 2019-10-08 16-08-39.png (813,477 bytes)

ngocbinh

2019-10-08 09:28

reporter   ~0011169

update for more information

root@Kali:~# apt-get update
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release
Hit:3 http://packages.microsoft.com/repos/vscode stable InRelease
Hit:5 http://ftp.yzu.edu.tw/Linux/kali kali-rolling InRelease
Reading package lists... Done
root@Kali:~# apt-get upgrade -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  eog gir1.2-totem-1.0 gnome-font-viewer gnome-software libomp-dev libtotem0 totem totem-plugins
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
root@Kali:~# apt-get install eog gir1.2-totem-1.0 gnome-font-viewer gnome-software libomp-dev libtotem0 totem totem-plugins
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 eog : Depends: libgnome-desktop-3-18 (>= 3.17.92) but it is not installable
 gnome-font-viewer : Depends: libgnome-desktop-3-18 (>= 3.17.92) but it is not installable
 gnome-software : Depends: libgnome-desktop-3-18 (>= 3.18.0) but it is not installable
 libtotem0 : Depends: libgnome-desktop-3-18 (>= 3.17.92) but it is not installable
E: Unable to correct problems, you have held broken packages.
root@Kali:~# apt-get install libgnome-desktop-3-18
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libgnome-desktop-3-18 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libgnome-desktop-3-18' has no installation candidate

LTech

2019-10-08 14:23

reporter   ~0011170

The application in question is "Nautilus" and I'm experiencing the same issue on both a VM installation and bare-metal of 2019.4. Can't install Nautilus due to dependency for libgnome-desktop-3-18, as noted above.

martinzirkle

2019-10-08 18:00

reporter   ~0011171

Same issue here. Downloaded Nemo to fix at the moment.

matthews

2019-10-09 06:03

reporter   ~0011176

Same issue

rhertzog

2019-10-10 11:47

administrator   ~0011187

We completed the transition to Gnome 3.34. Should be fixed in kali-rolling now.

ngocbinh

2019-10-14 04:19

reporter   ~0011191

yes, right now i can download libgnome-desktop-3-18, but the folder application still missing

rhertzog

2019-10-14 08:29

administrator   ~0011192

If the application has been deinstalled, try "apt install nautilus" to install it back. Please ask for help on forums or IRC, not on the bug tracker.

Issue History

Date Modified Username Field Change
2019-10-08 09:11 ngocbinh New Issue
2019-10-08 09:11 ngocbinh File Added: Screenshot from 2019-10-08 16-08-39.png
2019-10-08 09:11 ngocbinh File Added: Screenshot from 2019-10-08 16-10-42.png
2019-10-08 09:28 ngocbinh Note Added: 0011169
2019-10-08 14:23 LTech Note Added: 0011170
2019-10-08 18:00 martinzirkle Note Added: 0011171
2019-10-09 06:03 matthews Note Added: 0011176
2019-10-10 11:47 rhertzog Assigned To => rhertzog
2019-10-10 11:47 rhertzog Status new => resolved
2019-10-10 11:47 rhertzog Resolution open => fixed
2019-10-10 11:47 rhertzog Note Added: 0011187
2019-10-14 04:19 ngocbinh Status resolved => feedback
2019-10-14 04:19 ngocbinh Resolution fixed => reopened
2019-10-14 04:19 ngocbinh Note Added: 0011191
2019-10-14 08:29 rhertzog Status feedback => resolved
2019-10-14 08:29 rhertzog Resolution reopened => fixed
2019-10-14 08:29 rhertzog Note Added: 0011192