View Issue Details

IDProjectCategoryView StatusLast Update
0005810Kali Linux[All Projects] General Bugpublic2020-03-09 15:23
Reportercohst Assigned Torhertzog  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0005810: Login with non-root user leads to login loop
DescriptionI have a non-root user cohst which has sudo permission on Kali Linux which I use for work. Since the todays update 24-11-2019 a Login on VMware console (kali Standard Login prompt) leads to a Login loop with this user, means the Login starts and then Comes back to Login screen. Login with root user works normal.

From SSH or RDP the Login works normal.

Systeminformation:

cohst@kali-linux:~$ uname -a
Linux kali-linux 5.3.0-kali2-686-pae 0000001 SMP Debian 5.3.9-3kali1 (2019-11-20) i686 GNU/Linux
cohst@kali-linux:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Kali
Description: Kali GNU/Linux Rolling
Release: 2019.4
Codename: kali-rolling
cohst@kali-linux:~$

Please have a look at this Problem.

Activities

cohst

2019-11-25 19:48

reporter   ~0011347

I have forgotten the Messages from root Shell with journalctl -f | less. Sorry.

root@kali-linux:/home/cohst# journalctl -f | less
-- Logs begin at Mon 2019-11-25 20:14:11 CET. --
Nov 25 20:17:46 kali-linux rtkit-daemon[451]: Supervising 2 threads of 1 processes of 2 users.
Nov 25 20:17:46 kali-linux systemd[1127]: Started D-Bus User Message Bus.
Nov 25 20:17:46 kali-linux pulseaudio[1140]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.187" (uid=1000 pid=1140 comm="/usr/bin/pulseaudio --daemonize=no ") interface="org.freedesktop.DBus.ObjectManager" member="GetManagedObjects" error name="(unset)" requested_reply="0" destination="org.bluez" (bus)
Nov 25 20:17:46 kali-linux systemd[1127]: Started Sound Service.
Nov 25 20:17:46 kali-linux systemd[1127]: Reached target Main User Target.
Nov 25 20:17:46 kali-linux systemd[1127]: Startup finished in 2.851s.
Nov 25 20:18:10 kali-linux sudo[1160]: pam_unix(sudo:auth): Couldn't open /etc/securetty: No such file or directory
Nov 25 20:18:18 kali-linux sudo[1160]: pam_unix(sudo:auth): Couldn't open /etc/securetty: No such file or directory
Nov 25 20:18:18 kali-linux sudo[1160]: cohst : TTY=pts/0 ; PWD=/home/cohst ; USER=root ; COMMAND=/bin/bash
Nov 25 20:18:18 kali-linux sudo[1160]: pam_unix(sudo:session): session opened for user root by cohst(uid=0)
Nov 25 20:18:41 kali-linux gdm-password][1172]: pam_unix(gdm-password:auth): Couldn't open /etc/securetty: No such file or directory
Nov 25 20:18:50 kali-linux gdm-password][1172]: pam_unix(gdm-password:auth): Couldn't open /etc/securetty: No such file or directory
Nov 25 20:18:50 kali-linux gdm-password][1172]: gkr-pam: unable to locate daemon control file
Nov 25 20:18:50 kali-linux gdm-password][1172]: pam_unix(gdm-password:session): session opened for user cohst by (uid=0)
Nov 25 20:18:50 kali-linux systemd-logind[505]: New session 6 of user cohst.
Nov 25 20:18:50 kali-linux systemd[1]: Started Session 6 of user cohst.
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (**) Option "fd" "20"
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (II) event1 - Power Button: device removed
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (**) Option "fd" "23"
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (II) event0 - AT Translated Set 2 keyboard: device removed
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (**) Option "fd" "24"
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (II) event3 - VirtualPS/2 VMware VMMouse: device removed
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (**) Option "fd" "25"
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (II) event2 - VirtualPS/2 VMware VMMouse: device removed
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (II) systemd-logind: got pause for 13:67
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (II) systemd-logind: got pause for 226:0
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (II) systemd-logind: got pause for 13:64
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (II) systemd-logind: got pause for 13:65
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[769]: (II) systemd-logind: got pause for 13:66
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[1186]: _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[1186]: _XSERVTransMakeAllCOTSServerListeners: server already running
Nov 25 20:18:51 kali-linux /usr/lib/gdm3/gdm-x-session[1186]: (--) Log file renamed from "/home/cohst/.local/share/xorg/Xorg.pid-1188.log" to "/home/cohst/.local/share/xorg/Xorg.1.log"
Nov 25 20:18:52 kali-linux /usr/lib/gdm3/gdm-x-session[1186]: X.Org X Server 1.20.4
Nov 25 20:18:52 kali-linux /usr/lib/gdm3/gdm-x-session[1186]: X Protocol Version 11, Revision 0
Nov 25 20:18:52 kali-linux /usr/lib/gdm3/gdm-x-session[1186]: Build Operating System: Linux 4.9.0-8-amd64 i686 Debian
Nov 25 20:18:52 kali-linux /usr/lib/gdm3/gdm-x-session[1186]: Current Operating System: Linux kali-linux 5.3.0-kali2-686-pae 0000001 SMP Debian 5.3.9-3kali1 (2019-11-20) i686
Nov 25 20:18:52 kali-linux /usr/lib/gdm3/gdm-x-session[1186]: Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.3.0-kali2-686-p:

cohst

2019-11-25 19:58

reporter   ~0011348

By now it works again, after a new start of the Hypervisor. Can you Image, that it has might something to do with VMware upgrade vmsa-2019-0020? I did not patch the Hypervisor up to now, but in the update of yesterday there were microcode updates for Kali Linux. I'm not sure if that has to something with that.

cohst

2020-03-08 13:28

reporter   ~0012389

Ticket can be closed, I have installed the new Version of Kali 2020.1, the problem is solved.

rhertzog

2020-03-09 15:23

administrator   ~0012394

Thanks, I closed the ticket.

Issue History

Date Modified Username Field Change
2019-11-24 17:20 cohst New Issue
2019-11-25 19:48 cohst Note Added: 0011347
2019-11-25 19:58 cohst Note Added: 0011348
2020-03-08 13:28 cohst Note Added: 0012389
2020-03-09 15:22 rhertzog Assigned To => rhertzog
2020-03-09 15:22 rhertzog Status new => resolved
2020-03-09 15:22 rhertzog Resolution open => no change required
2020-03-09 15:23 rhertzog Note Added: 0012394