View Issue Details

IDProjectCategoryView StatusLast Update
0005838Kali Linux[All Projects] General Bugpublic2019-11-29 14:17
ReporterKaliMark Assigned ToGamb1t  
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.4 
Target VersionFixed in Version2020.1 
Summary0005838: Creating a Bootable Kali USB Drive on Windows with Rufus ends with grub> bash
DescriptionFollowing the instructions to install Kali on USB https://www.kali.org/docs/usb/kali-linux-live-usb-install/ from Win10, I always end up in GNU GRUB version 2.04-3kali.
Tried it 3 times, always the same result.
Also tried https://cdimage.kali.org/kali-2019.4/kali-linux-2019.4-lxde-amd64.iso, same result.
Steps To ReproduceI downloaded Kali 2019.4 https://cdimage.kali.org/kali-2019.4/kali-linux-2019.4-amd64.iso to install it on a 32 GB USB drive and created it using Rufus 3.8.1580 (current version) on Win10 1903. I tried it with and without persistent partition.
When booting the stick I always end up on a black screen with gnu grub bash: grub >
I am getting familiar with Kali, but have unfortunately no clue about grub.

Please advise how to create the stick and update the manual.
Additional InformationI tried creating the thumb drive using win32diskimager-binar, which worked out. I was able to boot and login to kali. However, I was not able to adjust the partition size. Trying to use gparted for modification, gparted is not able to inspect the patition. Drive ist only shown as /dev/sdb, not mounted. Usually I can see the partitions of the USB drives.

Activities

HiOnFruityPebbles

2019-11-29 00:29

reporter   ~0011463

Hey KaliMark , I've found that Etcher solves the problem, Rufus in my experience has had issues with the latest linux distros. I believe its because their kernel support is not updated very frequently

HiOnFruityPebbles

2019-11-29 00:40

reporter   ~0011464

https://www.balena.io/etcher/ Kali Team I believe this should be the recommended iso/image writer

1.It's Open-Source
2.It's Faster and has More Support
3.Updates are more frequent and hence less reports like this
4.Cross-Platform and Flashing Validation

Just a suggestion.

Gamb1t

2019-11-29 01:35

developer   ~0011466

I agree that Etcher will solve the problem. The doc page will be updated to swap from Rufus to Etcher, thanks for the report!

HiOnFruityPebbles

2019-11-29 01:44

reporter   ~0011467

Thanks Gamb1t , glad I could contribute!

KaliMark

2019-11-29 10:50

reporter   ~0011475

Hi Guys, awsome! Thanks for the quick support. This works. I am just wonderhin why they need 120 MB what rufus did with 1.2 MB... If Kali now factors the space needed by x 100, this would boost the USB-Stick industry ;-)
This issue can be closed.

rhertzog

2019-11-29 14:17

administrator   ~0011482

The documentation now refers to Etcher. Closing.

Issue History

Date Modified Username Field Change
2019-11-28 22:03 KaliMark New Issue
2019-11-29 00:29 HiOnFruityPebbles Note Added: 0011463
2019-11-29 00:40 HiOnFruityPebbles Note Added: 0011464
2019-11-29 01:35 Gamb1t Note Added: 0011466
2019-11-29 01:44 HiOnFruityPebbles Note Added: 0011467
2019-11-29 10:50 KaliMark Note Added: 0011475
2019-11-29 14:17 rhertzog Assigned To => Gamb1t
2019-11-29 14:17 rhertzog Status new => resolved
2019-11-29 14:17 rhertzog Resolution open => fixed
2019-11-29 14:17 rhertzog Fixed in Version => 2020.1
2019-11-29 14:17 rhertzog Note Added: 0011482