View Issue Details

IDProjectCategoryView StatusLast Update
0005878Kali Linux[All Projects] General Bugpublic2020-02-04 15:43
ReporterGamb1t Assigned Torhertzog  
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2020.2 
Summary0005878: During live boot debian-installer-launcher fails to run
DescriptionBefore 2019.4 debian-installer-launcher ran fine and was used to create the btrfs walkthrough. It currently fails making the btrfs walkthrough not possible.
Steps To ReproduceBoot into live boot mode
root@kali:~# apt install -y debian-installer-launcher
root@kali:~# debian-installer-launcher
no suitable d-i ignited image found, aborting.
umount: /lib/live/installer: no mount point specified

Activities

rhertzog

2019-12-11 10:59

administrator   ~0011643

Last edited: 2019-12-11 11:00

View 2 revisions

Do you have the issue with the 2019.4 live ISO or newer ISO where the installer was broken?

Why does the btrfs tutorial require debian-installer-launcher ? It would be better if it were adapted to be run in the regular installer. I believe that you should be able to complete the manual steps in the console available in CTRL+ALT+F2.

FTR debian-installer-launcher is not really maintained and we dropped it from the live ISO a long time ago due to this and I would prefer if we did not rely on it.

Gamb1t

2019-12-11 22:12

developer   ~0011647

I have had the issue on 2019.4 live ISO and newer. I dont fully understand the reasons that re4son chose to use live boot, however I do remember he ran into issues with the regular installer. This will have to be looked into if it can be adapted

rhertzog

2020-02-04 15:43

administrator   ~0012007

This has been fixed in debian-installer-launcher 37 that I just uploaded to Debian. It will be available in Kali in a few days.

The revelant part of the changes I made are those: https://salsa.debian.org/installer-team/debian-installer-launcher/commit/99e5d7a8f1e1015882c125e5b954d98270f816b1

Issue History

Date Modified Username Field Change
2019-12-05 22:58 Gamb1t New Issue
2019-12-11 10:59 rhertzog Assigned To => rhertzog
2019-12-11 10:59 rhertzog Status new => feedback
2019-12-11 10:59 rhertzog Note Added: 0011643
2019-12-11 11:00 rhertzog Note Edited: 0011643 View Revisions
2019-12-11 22:12 Gamb1t Note Added: 0011647
2019-12-11 22:12 Gamb1t Status feedback => assigned
2019-12-12 09:02 rhertzog Priority normal => high
2020-02-04 15:43 rhertzog Status assigned => resolved
2020-02-04 15:43 rhertzog Resolution open => fixed
2020-02-04 15:43 rhertzog Fixed in Version => 2020.2
2020-02-04 15:43 rhertzog Note Added: 0012007