View Issue Details

IDProjectCategoryView StatusLast Update
0005886Kali Linux[All Projects] Kali Package Bugpublic2019-12-11 09:02
Reporterelitehunter Assigned Torhertzog  
PrioritynormalSeveritycrashReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Product Version2019.4 
Target VersionFixed in Version 
Summary0005886: Wifi interface changed from wlan0 to wlx00117f1b8dec and wifi does not work
DescriptionI have updated and upgraded kali by apt-get update and apt-get upgrade command. Now my wifi does not work. I had atheros ar9271 driver which was working fine with monitor mode and manage mode untill this update. After this, wlan0 is gone and new interface wlx00117f1b8dec is showing instead of that. If i do ifconfig/iwconfig , it shows the same interface. Now wifi does not connect to any AP and monitor mode freezes any script that i run (ex- airgeddon).
I installed and uninstalled other driver like comapt-2010-06-26 but it stays the same. Hope to get it fixed soon.

Activities

elitehunter

2019-12-07 16:31

reporter  

20191207_220210.jpg (1,209,643 bytes)

SirEvgen

2019-12-07 16:39

reporter   ~0011594

I have same problem... and cant connecting to wifi.

usama

2019-12-08 03:52

reporter   ~0011596

same here though i renamed wlx000762cfe to wlan1.This problem appeared after upgrading to kali 2019.4.

elitehunter

2019-12-10 19:03

reporter   ~0011631

usama, that did not work for me? somebody help!!

akejjeka

2019-12-10 22:17

reporter   ~0011632

good morning or good evening

I had the same problem with two wifi cards (beklin N300 and ALFA network AWUS051NH)
which is now solved very easily after an administrator gives me the sulotion so I share it with you.

"The problem with the wifi device being renamed should be fixed with kali-defaults 2020.1.0.

To disable the MAC-based naming, kali-defaults is now setting up this symlink:
ln -sf /dev/null /etc/systemd/network/73-usb-net-by-mac.link

This regression is related to a change in systemd 244-2 that replaced the former udev rule with this systemd configuration file."

in a terminal root type: ln -sf / dev / null /etc/systemd/network/73-usb-net-by-mac.link

akejjeka

2019-12-10 22:18

reporter   ~0011633

and restart

akejjeka

2019-12-10 22:20

reporter   ~0011634

the solution is already in the RESOLUTE category

JokerSob

2019-12-10 22:55

reporter   ~0011635

@rhertzog Says : ( ticket : 0005885 - 0005884 - 0005887 )

This should be fixed with kali-defaults 2020.1.0.

To disable the MAC-based naming, kali-defaults is now setting up this symlink:
ln -sf /dev/null /etc/systemd/network/73-usb-net-by-mac.link

This regression is related to a change in systemd 244-2 that replaced the former udev rule with this systemd configuration file.

In addition, the Kali.org site has made some basic explanations. I think it might contain an answer to that question.
https://www.kali.org/news/major-metapackage-makeover/

I'm not sure whether I should wait to run the update and upgrade command. Can the solution to this problem be in the link above? Or will the update and upgrade command automatically correct everything?

JokerSob

2019-12-11 00:40

reporter   ~0011636

Although I received the answer that the problem was corrected in my own error report, I was confused when I saw your error report and therefore added the above note. However, after a clean installation of 2019.4, I ran the update and upgrade command for the first time and found that the problem was solved as described in @rhertzog.

Issue History

Date Modified Username Field Change
2019-12-07 16:31 elitehunter New Issue
2019-12-07 16:31 elitehunter File Added: 20191207_220210.jpg
2019-12-07 16:39 SirEvgen Note Added: 0011594
2019-12-08 03:52 usama Note Added: 0011596
2019-12-10 19:03 elitehunter Note Added: 0011631
2019-12-10 22:17 akejjeka Note Added: 0011632
2019-12-10 22:18 akejjeka Note Added: 0011633
2019-12-10 22:20 akejjeka Note Added: 0011634
2019-12-10 22:55 JokerSob Note Added: 0011635
2019-12-11 00:40 JokerSob Note Added: 0011636
2019-12-11 09:02 rhertzog Assigned To => rhertzog
2019-12-11 09:02 rhertzog Status new => resolved
2019-12-11 09:02 rhertzog Resolution open => fixed