View Issue Details

IDProjectCategoryView StatusLast Update
0005900Kali Linux[All Projects] General Bugpublic2019-12-11 11:01
ReporterEnceledusGoofOff Assigned Torhertzog  
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.4 
Target VersionFixed in Version 
Summary0005900: installing via netboot pkgsel
DescriptionWhen attempting netboot/ PXE boot pkgsel attempts to start tasksel, tasksel is not found, and the install fails

Dec 10 18:09:46 pkgsel: starting tasksel
Dec 10 18:09:46 in-target: sh: 1: tasksel: not found
Dec 10 18:09:46 main-menu[840]: (process:xxxx) dpgk-divert: warning: diverting file '/sbin/start/stop-daemon' from an Essential package with rename is dangerous, use --no-rename
Dec 10 18:09:46 main-menu[840]: (process:xxxx) dpgk-divert: warning: diverting file '/sbin/start/stop-daemon' from an Essential package with rename is dangerous, use --no-rename
Dec 10 18:09:46 main-menu[840]: (process:xxxx) dpgk-divert: warning: diverting file '/sbin/start/stop-daemon' from an Essential package with rename is dangerous, use --no-rename
Dec 10 18:09:46 main-menu[840]: WARNING **: Configuring 'pkgsel' failed with error code 127
Dec 10 18:09:46 main-menu[840]: WARNING **: Menu item 'pkgsel' failed
Steps To ReproducePXE boot/ netboot on rolling

Activities

rhertzog

2019-12-11 09:01

administrator   ~0011640

Yeah, I know of this regression since I forked tasksel, its priority in the package is optional and while Debian has an override to bump it to important so that it gets installed by debootstrap, we don't have this. I have plans to fix it in pkgsel and in the package.

rhertzog

2019-12-11 11:01

administrator   ~0011644

I uploaded pkgsel 0.68~kali1 which should fix this issue.

Issue History

Date Modified Username Field Change
2019-12-10 18:39 EnceledusGoofOff New Issue
2019-12-11 08:59 rhertzog Assigned To => rhertzog
2019-12-11 08:59 rhertzog Status new => assigned
2019-12-11 09:01 rhertzog Note Added: 0011640
2019-12-11 11:01 rhertzog Status assigned => resolved
2019-12-11 11:01 rhertzog Resolution open => fixed
2019-12-11 11:01 rhertzog Note Added: 0011644