View Issue Details

IDProjectCategoryView StatusLast Update
0005922Kali Linux[All Projects] Feature Requestspublic2019-12-17 13:45
ReporterMister_X Assigned Torhertzog  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.4 
Target VersionFixed in Version2020.1 
Summary0005922: /root permissions different than Debian
Description/root directory permission is 'drwxr-xr-x'. However, on a regular Debian, it's 'drwx------'.

Activities

rhertzog

2019-12-17 10:04

administrator   ~0011699

This is likely due to live-build in some way. I'm doing a quick try where I drop the custom /root/.bashrc that we setup to see if it's that override that explains the permissions.

rhertzog

2019-12-17 13:45

administrator   ~0011704

Fixed with https://gitlab.com/kalilinux/build-scripts/live-build-config/commit/520f5d48af5d0a93fba50c3613b81a471ef85d27

Issue History

Date Modified Username Field Change
2019-12-15 18:39 Mister_X New Issue
2019-12-17 10:03 rhertzog Assigned To => rhertzog
2019-12-17 10:03 rhertzog Status new => assigned
2019-12-17 10:04 rhertzog Note Added: 0011699
2019-12-17 13:45 rhertzog Status assigned => resolved
2019-12-17 13:45 rhertzog Resolution open => fixed
2019-12-17 13:45 rhertzog Fixed in Version => 2020.1
2019-12-17 13:45 rhertzog Note Added: 0011704