View Issue Details

IDProjectCategoryView StatusLast Update
0006000Kali Linux[All Projects] General Bugpublic2020-01-17 15:33
Reporterioscanner Assigned Torhertzog  
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionnot fixable 
Product Version2019.4 
Target VersionFixed in Version 
Summary0006000: After the latest update it seems to have broken the kernel
DescriptionI did the latest update and then VMware attempted to rebuild the VMware modules. It errors now and can't compete:

/tmp/modconfig-0t5cgZ/vmnet-only/userif.c:577:17: error: ‘skb_frag_t’ {aka ‘const struct bio_vec’} has no member named ‘size’
Steps To ReproduceI did see the bug with mkinitramfs that was also an issue after the upgrade. I patched and reran, but it didn't allow VMware to build its kernel modules.

Activities

ioscanner

2020-01-17 04:57

reporter   ~0011931

So it just seems to be the 5.4 kernel update. If I use the 5.3 kernel before the update vmware still works just fine. It seems the issue the the: linux-image-5.4.0-kali2-amd64 or the headers. Not sure what changed.

rhertzog

2020-01-17 14:44

administrator   ~0011932

What do you mean with "VMware attempted to rebuild the VMware modules"?

VMware support is provided by the packages open-vm-tools and open-vm-dkms and the modules in that package do build correctly with Linux 5.4 AFAIK.

Have you manually installed something else?

ioscanner

2020-01-17 15:21

reporter   ~0011933

Sorry, I was not clear. I have VMware workstation Pro 15 installed to run a few Windows hosts and different versions of tools needed. VMware needs to load its kernel modules to support the guest VMs. After I upgraded it could no longer build the vmnet modules needed to enable ethernet for the guest VMs. I rebooted and used the 5.3 kernel and the issue is not present.

rhertzog

2020-01-17 15:33

administrator   ~0011934

Ah, OK, that makes it clearer but I'm afraid that we are not in a position to fix this, you have to take this up with VMWare. Those modules are not shipped by Kali.

Issue History

Date Modified Username Field Change
2020-01-16 05:10 ioscanner New Issue
2020-01-17 04:57 ioscanner Note Added: 0011931
2020-01-17 14:44 rhertzog Note Added: 0011932
2020-01-17 15:21 ioscanner Note Added: 0011933
2020-01-17 15:33 rhertzog Assigned To => rhertzog
2020-01-17 15:33 rhertzog Status new => closed
2020-01-17 15:33 rhertzog Resolution open => not fixable
2020-01-17 15:33 rhertzog Note Added: 0011934