View Issue Details

IDProjectCategoryView StatusLast Update
0006037Kali Linux[All Projects] Kali Package Bugpublic2020-02-01 18:27
Reporters5bankx Assigned To 
PriorityimmediateSeveritymajorReproducibilityhave not tried
Status newResolutionopen 
Product Version2020.1 
Target VersionFixed in Version 
Summary0006037: No headers for rasp pi4
DescriptionTrying to setup a wireless adapter over a raspberry pi4.
Either after the installation of kalipi-kernel-headers
the output of installation no matter if dkms or make file
is:" it seems the kernel headers are not installed".
The raspberrypi-kernel-headers runs for Debian, but useless for kali.
Any solution ? TX


has duplicate 0006051 closedsteev weird behavior awus0036ach 



2020-01-30 15:41

developer   ~0011976

This appears to be more than just a kernel header issue though.

The almost working, workaround, is to either symlink the linux-headers4.19.93-Re4son-v8+ directory to linux-headers-4.19.93-Re4son-v8l+ or move it to that name. Then go into /lib/modules/4.19.93-Re4son-v8l+ and create two symlinks to /usr/src/linux-headers-4.19.93-Re4son-v8l+ for "build" and "source"

Unfortunately, dkms sees it's aarch64 and isn't doing the conversion to being arm64, not sure where that regression comes from, so you have to make sure it's passing ARCH=arm64 and not ARCH=aarch64.


2020-01-30 15:44

developer   ~0011977

Oh, also, you'll need the app "bc" installed as well.


2020-01-30 16:53

developer   ~0011978

Is this realtek-rtl88xxau-dkms ?


2020-01-30 17:16

developer   ~0011979

if you've made the changes mentioned above... `ARCH=arm64 make` in the directory should give you a module at least.


2020-02-01 08:51

reporter   ~0011997

Fixed in version 4.19.93-20200201.
Could you please run
"apt update && apt install kalipi-kernel-headers"
and let us know if that's working for you?

Many thanks


2020-02-01 18:27

reporter   ~0011998

Hi !
Thank you, it worked as smooth as oil.
The apt install realtek-rtl88xxau-dkms
gave the known problem aarch64/arm64.
The latest aircrack-ng's driver installed with
no problem and it works perfectly.
Many thanks. Regard

Issue History

Date Modified Username Field Change
2020-01-30 05:14 s5bankx New Issue
2020-01-30 15:41 steev Note Added: 0011976
2020-01-30 15:44 steev Note Added: 0011977
2020-01-30 16:53 steev Note Added: 0011978
2020-01-30 17:16 steev Note Added: 0011979
2020-01-31 19:21 steev Relationship added has duplicate 0006051
2020-02-01 08:51 re4son Note Added: 0011997
2020-02-01 18:27 s5bankx Note Added: 0011998