View Issue Details

IDProjectCategoryView StatusLast Update
0006170Kali Linux[All Projects] Tool Upgradepublic2020-05-26 04:59
Reportervipinkumar1712 Assigned Tosbrun  
PriorityurgentSeveritycrashReproducibilityalways
Status feedbackResolutionreopened 
Product Version2020.1 
Target VersionFixed in Version 
Summary0006170: Broadcom Inc. and subsidiaries BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01) is unable to connect with wifi
DescriptionI have Dell latitude E5440 with
Broadcom Inc. and subsidiaries BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01).
In Kali 2020.1,it is unable to connect with any Wi-fi network(Scanning is working). I am Using "b43-fwcutter" driver and "firmware-b43-installer" firmware.

Activities

vipinkumar1712

2020-03-08 08:54

reporter  

atdtphreaker

2020-03-14 16:27

reporter   ~0012416

I've similar issue FOLLOWING a fresh install of Kali 2020.1 on my MacBook Pro (Dual Boot).

**NOT BEING RECOGNIZED (not working) - Network controller: Broadcom Inc. and subsidiaries BCM4331 802.11a/b/g/n (rev 02) - (internal)

*TESTED - Recognized (working fine) ->> ath9k_htc Qualcomm Atheros Communications AR9271 802.11n (Alfa) (USB)
*TESTED - Recognized (working fine) ->> rt73usb Linksys WUSB54GC v1 802.11g Adapter [Ralink RT73] (USB)


I've never had this problem before.

Thank you. I appreciate your work and time, greatly.

rhertzog

2020-03-16 15:26

administrator   ~0012418

That's because firmware-b43-installer is not installed on your system. It used to be installed by default but with since the package requires the network to be installable, it got dropped from the default metapackage.

atdtphreaker

2020-03-16 18:37

reporter   ~0012419

@rhertzog

I installed 'firmware-b43-installer' (sudo apt install firmware-b43-installer). It seems to be working now.

Thank you for the feedback and your time.

atdtphreaker

2020-03-16 21:16

reporter   ~0012420

@rhertzog

I need to AMEND the previous comment of mine. It works BUT DROPS randomly and just SCANS for networks, connects to one AND then drops again repeatedly. I've tested this many times in multiple scenarios.

Thanks, I appreciate your time.

vipinkumar1712

2020-03-17 00:29

reporter   ~0012421

@rhertzog


I hope it will be fixed soon.
Thankyou

sbrun

2020-05-13 08:36

manager   ~0012775

new version 1:019-5 is in kali-rolling

vipinkumar1712

2020-05-26 04:59

reporter   ~0012837

After updating the firmware,it's still dropping connections.

Issue History

Date Modified Username Field Change
2020-03-08 08:54 vipinkumar1712 New Issue
2020-03-08 08:54 vipinkumar1712 Status new => assigned
2020-03-08 08:54 vipinkumar1712 Assigned To => sbrun
2020-03-08 08:54 vipinkumar1712 File Added: Screenshot_2020-03-08_14-23-56.png
2020-03-14 16:27 atdtphreaker Note Added: 0012416
2020-03-16 15:26 rhertzog Note Added: 0012418
2020-03-16 18:37 atdtphreaker Note Added: 0012419
2020-03-16 21:16 atdtphreaker Note Added: 0012420
2020-03-17 00:29 vipinkumar1712 Note Added: 0012421
2020-05-13 08:36 sbrun Status assigned => resolved
2020-05-13 08:36 sbrun Resolution open => fixed
2020-05-13 08:36 sbrun Note Added: 0012775
2020-05-26 04:59 vipinkumar1712 Status resolved => feedback
2020-05-26 04:59 vipinkumar1712 Resolution fixed => reopened
2020-05-26 04:59 vipinkumar1712 Note Added: 0012837