View Issue Details

IDProjectCategoryView StatusLast Update
0006182Kali Linux[All Projects] General Bugpublic2020-12-01 10:41
Reporterreybango Assigned To 
Status closedResolutionopen 
Product Version2020.1 
Target VersionFixed in Version 
Summary0006182: smbclient version 4.11.5-Debian throw connection negotiation error
DescriptionMy Kali version: Linux kali 5.4.0-kali4-amd64 0000001 SMP Debian 5.4.19-1kali1 (2020-02-17) x86_64 GNU/Linux

In the version of smbclient shipped in Kali, doing a simple call like "smbclient -L" will result in the following error message:

"protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED"

I installed smbclient onto a regular Ubuntu VM. The version installed was older (4.10.7-Ubuntu) and that worked perfectly bringing back all open shares.

I tried uninstalling and reinstalling smbclient in Kali but the issue persists.

So it seems that the newer version of smbclient has a bug.
Steps To ReproduceConnect to Hack the Box
Issue "smbclient -L" to enumerate open shares against the "Lame" box
Get the error message



2020-03-11 22:23

reporter   ~0012406

Adding to this. I was able to solve this issue by adding the following to /etc/samba/smb.conf under the [global] section:

client min protocol = NT1

or by appending this, --option='client min protocol=NT1', to any Samba client that needs SMBv1 support:

e.g.: smbclient // --option='client min protocol=NT1'

I found the following issue in the Fedora bug tracker which mentioned the smb.conf switch solution:

Digging further it looks like Samba removed support for SMBv1 late last year:

See the section titled: "SMB1 is disabled by default"


2020-12-01 10:41

administrator   ~0013773

This report has been filed against an old version of Kali. We will be closing this ticket due to inactivity.
Please could you see if you are able to replicate this issue with the latest version of Kali Linux (
If you are still facing the same problem, feel free to re-open the ticket. If you choose to do this, could you provide more information to the issue you are facing, and also give information about your setup?
For more information, please read:

Issue History

Date Modified Username Field Change
2020-03-10 16:29 reybango New Issue
2020-03-11 22:23 reybango Note Added: 0012406
2020-12-01 10:41 g0tmi1k Note Added: 0013773
2020-12-01 10:41 g0tmi1k Status new => closed