View Issue Details

IDProjectCategoryView StatusLast Update
0006202Kali Linux[All Projects] Kali Package Improvementpublic2020-03-20 13:59
Reportersdeepaksharma007 Assigned Tosbrun  
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Versionkali-dev 
Target VersionFixed in Version 
Summary0006202: unable to upgrade python.
Descriptionrespected sir/madam,
i am a kali linux user of i386 architecture. i am not able to upgrade my python2 package to python3 package, due to this problem i am not able to update my system totally. Even if i tried to update && upgrade it, i am receiving such error as mention below.....

root@kali:~# apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 python3 : PreDepends: python3-minimal (= 3.6.4-1) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

i am in emergency situation.i have tried enough. somebody please help me to recover this problem.

Activities

sbrun

2020-03-20 13:59

manager   ~0012498

Thank you for your interest in Kali but it looks like that you need help and guidance to perform some task. We have community support forums on http://forums.kali.org or on IRC with the #kali-linux channel on irc.freenode.net), please post your questions there.

You can start to read the documentation here:
https://www.kali.org/docs/general-use/updating-kali/

Issue History

Date Modified Username Field Change
2020-03-19 13:29 sdeepaksharma007 New Issue
2020-03-20 13:59 sbrun Assigned To => sbrun
2020-03-20 13:59 sbrun Status new => closed
2020-03-20 13:59 sbrun Resolution open => no change required
2020-03-20 13:59 sbrun Note Added: 0012498