View Issue Details

IDProjectCategoryView StatusLast Update
0006242Kali Linux[All Projects] General Bugpublic2020-04-29 10:11
Reporterg0tmi1k Assigned Torhertzog  
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2020.2 
Summary0006242: TFTP listening by default
Description```
kali@kali:~$ date
Mon 30 Mar 2020 12:33:03 PM EDT
kali@kali:~$
kali@kali:~$ sudo ss -antup
Netid State Recv-Q Send-Q Local Address:Port Peer Address:Port Process
udp UNCONN 0 0 0.0.0.0:69 0.0.0.0:* users:(("inetutils-inetd",pid=537,fd=4))
kali@kali:~$
kali@kali:~$ ps -ef | grep [5]37
root 537 1 0 12:23 ? 00:00:00 /usr/sbin/inetutils-inetd
kali@kali:~$
kali@kali:~$ cat /etc/inetd.conf | grep -v '^#'





tftp dgram udp wait nobody /usr/sbin/tcpd /usr/sbin/in.tftpd --tftpd-timeout 300 --retry-timeout 5 --mcast-port 1758 --mcast-addr 239.239.239.0-255 --mcast-ttl 1 --maxthread 100 --verbose=5 /srv/tftp




kali@kali:~$
```
Additional InformationThis is on a clean install of `kali-linux-2020-W14-installer-amd64.iso`. Default options selected during install

Activities

rhertzog

2020-04-29 10:11

administrator   ~0012692

So the issue seems to be that in the live image we have the appropriate preseeding so that it's running in daemon mode (and thus disabled) but we lost this in the separate installer image.

I just added the required preseed to the one embedded in the installer and this should thus go away with tomorrow's daily build.

Issue History

Date Modified Username Field Change
2020-03-31 09:46 g0tmi1k New Issue
2020-03-31 09:46 g0tmi1k Status new => assigned
2020-03-31 09:46 g0tmi1k Assigned To => rhertzog
2020-04-29 10:11 rhertzog Status assigned => resolved
2020-04-29 10:11 rhertzog Resolution open => fixed
2020-04-29 10:11 rhertzog Fixed in Version => 2020.2
2020-04-29 10:11 rhertzog Note Added: 0012692