View Issue Details

IDProjectCategoryView StatusLast Update
0006336Kali Linux[All Projects] Kali Package Bugpublic2020-06-15 08:49
Reporter4rbee Assigned Tosbrun  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2020.1 
Target VersionFixed in Version 
Summary0006336: Faraday not working
Description# uname -a
Linux kali 5.5.0-kali2-amd64 0000001 SMP Debian 5.5.17-1kali1 (2020-04-21) x86_64 GNU/Linux


# faraday-server
cannot import name 'ImmutableDict' from 'werkzeug' (/usr/lib/python3/dist-packages/werkzeug/__init__.py)
Missing dependencies.
Please execute: pip install -r requirements_server.txt

looks like this requirement : werkzeug<1.0.0 is the issue

root@kali:~# apt info python3-werkzeug
Package: python3-werkzeug
Version: 1.0.0+dfsg1-1
Steps To Reproducerun:
faraday-server

Relationships

related to 0006390 resolvedsbrun faraday unmet dependecies 

Activities

sbrun

2020-04-30 13:01

manager   ~0012700

we need to update flask-babelex

sbrun

2020-04-30 15:53

manager   ~0012703

I have imported python3-flask-babelex version 0.9.4-1 in kali-rolling.

Please update your system, check that you have the correct version of python3-flask-babelex (it takes a few hours for all the mirrors to be up to date) and retry.

sbrun

2020-05-06 09:53

manager   ~0012755

faraday is currently broken because of python3-marshmallow version 3.5.1-1, it requires version < 3.0

sbrun

2020-06-15 08:49

manager   ~0012921

I have updated faraday to version 3.11.1-0kali2.
It fixes the issues of incorrect Python modules versions.

Issue History

Date Modified Username Field Change
2020-04-29 17:54 4rbee New Issue
2020-04-30 07:25 sbrun Assigned To => sbrun
2020-04-30 07:25 sbrun Status new => assigned
2020-04-30 13:01 sbrun Status assigned => confirmed
2020-04-30 13:01 sbrun Note Added: 0012700
2020-04-30 15:53 sbrun Status confirmed => feedback
2020-04-30 15:53 sbrun Note Added: 0012703
2020-05-06 09:53 sbrun Note Added: 0012755
2020-06-09 12:46 sbrun Relationship added related to 0006390
2020-06-15 08:49 sbrun Status feedback => resolved
2020-06-15 08:49 sbrun Resolution open => fixed
2020-06-15 08:49 sbrun Note Added: 0012921