View Issue Details

IDProjectCategoryView StatusLast Update
0006382Kali Linux[All Projects] Kali Package Bugpublic2020-05-18 11:42
Reportersteev Assigned Tosbrun  
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0006382: Joplin-cli and Joplin write their databases to separate directories
DescriptionNot sure if this is an upstream bug, or a Kali packaging bug, so I figured I'd open it here first and we could go upstream if needed.

joplin-cli writes its database and info to ~/.config/joplin but the gui writes it to ~/.config/joplin-desktop; there's a third Joplin directory that appears to be Electron informations as well.

I would think that joplin-cli and Joplin's electron app would write to the same directory, but I could be wrong. I took a quick glance through /usr/lib/joplin-cli and strings /usr/lib/joplin/joplin and nothing really stuck out as to why the discrepancy.
Steps To ReproduceInstall Joplin, import TJ's Pentesting template from https://github.com/tjnull/TJ-JPT - install joplin-cli - launch it and notice that there are no notes in the cli version.
Additional InformationSimple workaround (maybe easier to just document this?) - symlink ~/.config/joplin to ~/.config/joplin-desktop to have the same notes in both.

Activities

sbrun

2020-05-18 08:53

manager   ~0012801

This is not a bug. Upstream has implemented it intentionally. Sharing the data can create issues.

See https://discourse.joplinapp.org/t/joplin-and-joplin-desktop-create-separate-configs/3712 for details

So I think we shouldn't change that in Kali.

If you really want / need to open a specific database, you can use the not-officially supported option --profile:
https://discourse.joplinapp.org/t/set-database-location-in-terminal-app/4255
https://discourse.joplinapp.org/t/how-can-i-save-the-joplin-database-in-specific-directory-on-linux/1954

I will add a note in the packages to explain this.

Issue History

Date Modified Username Field Change
2020-05-15 03:39 steev New Issue
2020-05-18 07:16 sbrun Assigned To => sbrun
2020-05-18 07:16 sbrun Status new => assigned
2020-05-18 08:53 sbrun Note Added: 0012801
2020-05-18 11:42 sbrun Status assigned => resolved
2020-05-18 11:42 sbrun Resolution open => fixed