View Issue Details

IDProjectCategoryView StatusLast Update
0006404Kali Linux[All Projects] Tool Upgradepublic2020-06-23 08:13
Reporterprofessor833 Assigned Tosbrun  
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionnot fixable 
Product Version2020.2 
Target VersionFixed in Version 
Summary0006404: cannot run apt-get autoremove
DescriptionI have recencntly upgraded my kali-linux (persistent) live usb to kali-linux 2020.2 and the upgrade was succesful but whenever i try to run apt-get autoremove i get this error:

root@kali:~# apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  linux-image-5.5.0-kali2-amd64
0 upgraded, 0 newly installed, 1 to remove and 79 not upgraded.
3 not fully installed or removed.
Need to get 0 B/50.0 MB of archives.
After this operation, 282 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 338100 files and directories currently installed.)
Removing linux-image-5.5.0-kali2-amd64 (5.5.17-1kali1) ...
/etc/kernel/postrm.d/initramfs-tools:
run-parts: failed to exec /etc/kernel/postrm.d/initramfs-tools: Exec format error
run-parts: /etc/kernel/postrm.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-5.5.0-kali2-amd64 (--remove):
 installed linux-image-5.5.0-kali2-amd64 package post-removal script subprocess returned error exit status 1
dpkg: too many errors, stopping
Errors were encountered while processing:
 linux-image-5.5.0-kali2-amd64
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

and due to this i can't install any new package also.

Activities

sbrun

2020-06-09 12:42

manager   ~0012904

The message mentions " 3 not fully installed or removed."
You should try to fix this with "sudo apt install --fix-broken"

rhertzog

2020-06-09 20:04

administrator   ~0012907

Furthermore, kernels packages are supposed to be marked "on hold" on live image because you should not upgrade them or remove them. You should not try to work around that and I wonder how you managed to get into a situation where you are trying to remove a kernel package.

What's the currently running kernel ? Share the output of "uname -a" please.

sbrun

2020-06-23 08:13

manager   ~0012979

closing because no reply of reporter

Issue History

Date Modified Username Field Change
2020-05-22 11:02 professor833 New Issue
2020-05-22 11:02 professor833 Status new => assigned
2020-05-22 11:02 professor833 Assigned To => sbrun
2020-06-09 12:42 sbrun Status assigned => feedback
2020-06-09 12:42 sbrun Note Added: 0012904
2020-06-09 20:04 rhertzog Note Added: 0012907
2020-06-23 08:13 sbrun Status feedback => closed
2020-06-23 08:13 sbrun Resolution open => not fixable
2020-06-23 08:13 sbrun Note Added: 0012979