View Issue Details

IDProjectCategoryView StatusLast Update
0006539Kali Linux[All Projects] General Bugpublic2020-06-30 20:42
Reporterghostpapper Assigned Tosteev  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version2020.2 
Target VersionFixed in Version 
Summary0006539: Cannot Open Display
Descriptionwe are experiencing problems when running rdesktop, remmina or freerdesktop on kali 2020-2. Everyone is returning errors with DIsplay. I tried everything but without success

Steps To Reproduceroot@kali:/opt/tools# rdesktop 51.255.208.71
Autoselecting keyboard map 'pt-br' from locale
UI(error): ui_init(), failed to open X11 display:
 or

xprop: unable to open display ''
Remmina plugin glibsecret (type=Secret) has registered but not yet initialized/activated. Initialization order is 2000.
[glibsecret] unable to get secret service: Cannot autolaunch D-Bus without X11 $DISPLAY
Unable to init server: Não foi possível conectar: Conexão recusada

(org.remmina.Remmina:2645): Gtk-WARNING **: 14:06:15.507: cannot open display:

Activities

steev

2020-06-30 20:42

developer   ~0013042

Running graphical applications as root is generally frowned upon.

This is not a bug, so the bug tracker is unfortunately the wrong place. Technical support happens in the forums https://forums.kali.org or on IRC in the #kali-linux channel on irc.freenode.net

Issue History

Date Modified Username Field Change
2020-06-30 17:06 ghostpapper New Issue
2020-06-30 20:42 steev Assigned To => steev
2020-06-30 20:42 steev Status new => closed
2020-06-30 20:42 steev Resolution open => no change required
2020-06-30 20:42 steev Note Added: 0013042