View Issue Details

IDProjectCategoryView StatusLast Update
0006587Kali Linux[All Projects] Kali Package Bugpublic2020-07-20 16:21
Reporterpanicacid Assigned Torhertzog  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2020.2 
Target VersionFixed in Version 
Summary0006587: Kali-Themes Package Broken on RPi
DescriptionWhen doing an apt-get upgrade the kali linux themes package tries to mount a symbolic link on /boot/grub/themes/kali/background.png

However the boot partition on the RPi is FAT32 and doesn't support symlinks

I've logged this as high as this bug also prevents you from running a sudo apt-get install kali-linux-large etc. it fails because the themes package is broken.
Steps To Reproducesudo apt-get upgrade on a fresh install of 2020.2b
Additional InformationWorkaround:

Sudo apt-get remove kali-themes-common -f
sudo apt clean (as a precation)
Sudo apt-get install kali-themes-common -f
sudo dpkg --configure -a (as a check - no errors)
sudo apt-get upgrade (as a check - no errors)

Relationships

duplicate of 0006583 resolvedrhertzog Upgrading kali-themes to 2020.3.0 fails when /boot is vfat 

Activities

panicacid

2020-07-19 20:53

reporter  

kalibug.png (338,950 bytes)

rhertzog

2020-07-20 16:21

administrator   ~0013091

Duplicate of 0006583. Should be fixed with kali-themes 2020.3.1.

Issue History

Date Modified Username Field Change
2020-07-19 20:53 panicacid New Issue
2020-07-19 20:53 panicacid File Added: kalibug.png
2020-07-20 16:21 rhertzog Assigned To => rhertzog
2020-07-20 16:21 rhertzog Status new => closed
2020-07-20 16:21 rhertzog Resolution open => fixed
2020-07-20 16:21 rhertzog Note Added: 0013091
2020-07-20 16:21 rhertzog Relationship added duplicate of 0006583