View Issue Details

IDProjectCategoryView StatusLast Update
0000663Kali Linux[All Projects] Queued Tool Additionpublic2021-05-18 11:00
ReporterMeatballs Assigned Tomuts  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Versionkali-dev 
Summary0000663: FreeRDP Pash the Hash (Restricted Mode Admin)
Descriptionhttp://labs.portcullis.co.uk/blog/new-restricted-admin-feature-of-rdp-8-1-allows-pass-the-hash/
http://labs.portcullis.co.uk/tools/freerdp-pth/

Would be cool, part of the pth toolkit/menu?

Activities

Meatballs

2013-10-21 21:16

reporter   ~0001037

•Is the tool useful / functional in a Penetration Testing environment?
RDP access with just a hash on Server 2k12...

•Does the tool contain functionality of other existing tools?
Nope

•Does the licensing of the tool allow for free re-distribution?
FreeRDP is Apache 2.0 (I assume this fork is too)
 
•How much resources does the tool require? Will it work in a “standard” environment?

Guess so? :p

rhertzog

2013-12-03 14:53

administrator   ~0001120

Reading http://labs.portcullis.co.uk/tools/freerdp-pth/ it looks like we only need to update FreeRDP to a newer version since the upstream project implemented the required support.

Unfortunately upsteam has not yet made a proper release so we should make a snapshot of the git repository to use as basis for the updated package. I just uploaded freerdp_1.1.0~beta1+git20131203-0kali.dsc to kali-proposed-updates.

Please test and report back if you find problems!

rhertzog

2014-01-07 16:11

administrator   ~0001273

The new package fails to build on armel/armhf. This needs to be investigated since Debian suffers from the same problem (and thus there's no fix to grab).

muts

2014-07-24 01:03

reporter   ~0002369

Historic, closed.

Issue History

Date Modified Username Field Change
2013-10-21 18:25 Meatballs New Issue
2013-10-21 21:16 Meatballs Note Added: 0001037
2013-12-03 14:53 rhertzog Note Added: 0001120
2014-01-07 16:11 rhertzog Note Added: 0001273
2014-07-24 01:03 muts Note Added: 0002369
2014-07-24 01:03 muts Status new => closed
2014-07-24 01:03 muts Assigned To => muts
2014-07-24 01:03 muts Resolution open => fixed
2014-07-24 01:03 muts Status closed => resolved
2021-05-18 10:55 g0tmi1k Fixed in Version => kali-dev
2021-05-18 11:00 g0tmi1k Category New Tool Requests => Queued Tool Addition