View Issue Details

IDProjectCategoryView StatusLast Update
0006685Kali Linux[All Projects] General Bugpublic2020-09-08 10:27
Reporterwobblyoverview Assigned Todaniruiz  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2020.3 
Target VersionFixed in Version2020.4 
Summary0006685: Qterminal unable to change font
Descriptionin xfce4 on 2020.3 the font cannot be changed. a default is set, and preview updates but the apply/ok buttons do not commit the change.
also found this thread on the forums for the same:
https://forums.kali.org/showthread.php?51025-Can-t-change-Terminal-font-and-size-in-new-update

my case is tested on a brand new install
Steps To Reproduce- open xfceterminal -> file -> preferences
- change font size or type
- click apply/ok

Relationships

has duplicate 0006594 closeddaniruiz QTerminal Font doesnt change 

Activities

wobblyoverview

2020-08-27 14:24

reporter   ~0013335

looks like i cant edit this but some fonts look to be missing as well from the xfce terminal font drop down in the preferences too

doc

2020-08-27 18:27

reporter   ~0013336

When you open terminal and select about does it say QT Terminal? If you want terminal to run the xfce4-terminal try this run exo-preferred-application and change the default terminal emulator under the Utilities tab. Hope that helps, QT terminal I found limited on fonts myself.

snoozer

2020-08-28 13:08

reporter   ~0013347

it was qtterminal not xfce4-terminal as expected, which also was not even installed oddly. i dont recall seeing anything in the release notes about this change but it may throw off many people.
xfce4-terminal works as expected, qtterminal does not and isn't an expected application. i think this is also a change from previous kali versions as well.

steev

2020-08-28 16:00

developer   ~0013348

We've used qterminal as the default terminal in the XFCE desktop since we made the switch. I don't know if we called out specifically that it was, but it has been the case as we found it fit our wants and needs a lot better than xfce-terminal.

daniruiz

2020-09-02 11:45

developer   ~0013373

This issue is caused by an update in Qt5 library not by qterminal per se.
For now, the only way to fix this is by manually modifying the fontFamily parameter inside ~/.config/qterminal.org/qterminal.ini. Once you've changed that the dialog works again.
For example use "fontFamily=Hack"

One of the reasons Kali uses qterminal and FiraCode font is to support font ligatures.

daniruiz

2020-09-02 11:50

developer   ~0013374

Actually, I've found that removing the space from the name fixes this issue.

simply edit ~/.config/qterminal.org/qterminal.ini and set fontFamily=FiraCode

harpistlaundry

2020-09-02 13:28

reporter   ~0013383

was going to also report and saw this plus a bunch of forum posts for the same

https://forums.kali.org/showthread.php?51025-Can-t-change-Terminal-font-and-size-in-new-update
https://forums.kali.org/showthread.php?50975-Unable-to-change-terminal-font-on-new-installation
https://forums.kali.org/showthread.php?50088-Terminal-font-and-size-will-not-change
https://forums.kali.org/showthread.php?50415-Can-t-change-Terminak-fon-or-font-size

im ok with firacode fonts but some might not be, wether is readability or something else and they may not see this issue. changing the ini is ok but the ui also doesnt list all fonts as a secondary issue

daniruiz

2020-09-02 14:01

developer   ~0013384

@harpistlaundry
Changing the fontname to FiraCode (without the space) fixes the issue and you can now change the font using the dialog.
The fix has been added to the package so it'll be updated soon.

daniruiz

2020-09-08 10:27

developer   ~0013403

Fixed with kali-themes 2020.4.1

You need to remove your local settings ~/.config/qterminal.org/qterminal.ini

Issue History

Date Modified Username Field Change
2020-08-27 14:14 wobblyoverview New Issue
2020-08-27 14:24 wobblyoverview Note Added: 0013335
2020-08-27 18:27 doc Note Added: 0013336
2020-08-28 13:08 snoozer Note Added: 0013347
2020-08-28 16:00 steev Note Added: 0013348
2020-09-02 11:45 daniruiz Note Added: 0013373
2020-09-02 11:50 daniruiz Note Added: 0013374
2020-09-02 12:02 daniruiz Assigned To => daniruiz
2020-09-02 12:02 daniruiz Status new => assigned
2020-09-02 13:28 harpistlaundry Note Added: 0013383
2020-09-02 14:01 daniruiz Note Added: 0013384
2020-09-03 13:36 daniruiz Summary xfce4 terminal unable to change font => Qterminal unable to change font
2020-09-03 13:36 daniruiz Relationship added has duplicate 0006594
2020-09-08 10:27 daniruiz Note Added: 0013403
2020-09-08 10:27 daniruiz Status assigned => resolved
2020-09-08 10:27 daniruiz Resolution open => fixed
2020-09-08 10:27 daniruiz Fixed in Version => 2020.4