View Issue Details

IDProjectCategoryView StatusLast Update
0006699Kali Linux[All Projects] Kali Package Bugpublic2020-09-02 16:17
Reportereliahderechte Assigned Tosteev  
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2020.3 
Target VersionFixed in Version 
Summary0006699: Libc6/Libc unmet dependencies bug
DescriptionEverytime I try to install something i get this (the same for every command with "upgrade"):

root@Eliah-Studium-Laptop-6QH2JV54:/home/retro# sudo apt-get install hashcat
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 hashcat : Depends: hashcat-data (>= 6.1.1+ds1-1) but 6.0.0+ds1-1 is to be installed
 libc-bin : Depends: libc6 (< 2.31) but 2.31-2 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

And yes I've already tried "apt --fix-broken install" several times. When running it I get this:

root@Eliah-Studium-Laptop-6QH2JV54:/home/retro# apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libc-bin
The following packages will be upgraded:
  libc-bin
1 upgraded, 0 newly installed, 0 to remove and 259 not upgraded.
5 not fully installed or removed.
Need to get 0 B/801 kB of archives.
After this operation, 13.3 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up libc6:amd64 (2.31-2) ...
Checking for services that may need to be restarted...
Checking init scripts...
Nothing to restart.
sleep: cannot read realtime clock: Invalid argument
dpkg: error processing package libc6:amd64 (--configure):
 installed libc6:amd64 package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 libc6:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

I've spent days looking for an answer but without success. When I try "sudo dpkg --configure -a" I get this:

root@Eliah-Studium-Laptop-6QH2JV54:/home/retro# sudo dpkg --configure -a
Setting up libc6:amd64 (2.31-2) ...
Checking for services that may need to be restarted...
Checking init scripts...
Nothing to restart.
sleep: cannot read realtime clock: Invalid argument
dpkg: error processing package libc6:amd64 (--configure):
 installed libc6:amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of libc6-i386:
 libc6-i386 depends on libc6 (= 2.31-2); however:
  Package libc6:amd64 is not configured yet.

dpkg: error processing package libc6-i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-dev:amd64:
 libc6-dev:amd64 depends on libc6 (= 2.31-2); however:
  Package libc6:amd64 is not configured yet.

dpkg: error processing package libc6-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc-dev-bin:
 libc-dev-bin depends on libc6 (>> 2.31); however:
  Package libc6:amd64 is not configured yet.
 libc-dev-bin depends on libc6 (<< 2.32); however:
  Package libc6:amd64 is not configured yet.

dpkg: error processing package libc-dev-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-dbg:amd64:
 libc6-dbg:amd64 depends on libc6 (= 2.31-2); however:
  Package libc6:amd64 is not configured yet.

dpkg: error processing package libc6-dbg:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent processing triggers for man-db:
 man-db depends on libc6 (>= 2.28); however:
  Package libc6:amd64 is not configured yet.

dpkg: error processing package man-db (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for libc-bin:
 libc-bin depends on libc6 (>> 2.30); however:
  Package libc6:amd64 is not configured yet.
 libc-bin depends on libc6 (<< 2.31); however:
  Version of libc6:amd64 on system is 2.31-2.

dpkg: error processing package libc-bin (--configure):
 dependency problems - leaving triggers unprocessed
Errors were encountered while processing:
 libc6:amd64
 libc6-i386
 libc6-dev:amd64
 libc-dev-bin
 libc6-dbg:amd64

Please correct as soon as possible, because I can't update anything, which means I can't update "TOR" which means I got a BIG security leak, because many hackers use TOR, and by that they can steal my data, get access to my laptop....

Relationships

duplicate of 0006659 assigned libc6:amd64 (2.31-2) WSL Kali 

Activities

steev

2020-09-02 16:17

developer   ~0013389

While you didn't say it, I'm assuming this is under WSL. Please see https://bugs.kali.org/view.php?id=6659

Issue History

Date Modified Username Field Change
2020-09-02 11:27 eliahderechte New Issue
2020-09-02 16:17 steev Assigned To => steev
2020-09-02 16:17 steev Status new => resolved
2020-09-02 16:17 steev Resolution open => duplicate
2020-09-02 16:17 steev Note Added: 0013389
2020-09-02 16:17 steev Relationship added duplicate of 0006659