View Issue Details

IDProjectCategoryView StatusLast Update
0006717Kali Linux[All Projects] General Bugpublic2020-12-01 10:50
ReporterSkystrike87 Assigned To 
Status newResolutionopen 
Product Version2020.3 
Target VersionFixed in Version 
Summary0006717: Live USB drops into busybox initramfs during boot with persistence.
DescriptionAfter following the instructions on the website for adding persistence multiple times to make sure it wasn't something I did wrong, trying to boot into a persistent session only brings me into busybox command line.
I have verified the sha256sum of the ISO that I write to the disk and tried using dd and etcher and mkusb all to try getting this working.



2020-09-15 19:53

reporter   ~0013425

how did you downloaded iso direct from page? what's your output when boot to busybox could provide a screenshot or pic


2020-09-15 20:03

reporter   ~0013427

my computer wont screenshot until i boot
no errors show when busybox comes up but when i open boot.log it tells me it has a mount error for /dev/loop0


2020-09-15 20:04

reporter   ~0013428

and yes the ISO comes from the website, have tried with both a direct download and torrent link


2020-09-16 15:10

reporter   ~0013438

what capacity iso file with kali is? which graphical environment do you choose because when i choose mate in previous versions of kali i had trouble with it i recommend gnome its heavy yeah but very customizeable. Do your error is the same or similar to this ((initramfs) mount: mounting dev/loop0 on //filesystem.squashfs failed: Input/Output error Can not mount /dev/loop0 (/cdrom/casper/filesystem.squashfs) on //filesystem.squashfs) ? and most silly answer did you tried mount /dev/loop0 ? how did make your usb bootable using rufus or diferrent if so try rufus and most important DO NOT CHOOSE ISO way in rufus choose dd way when process will finish boot and check


2020-09-17 15:56

reporter   ~0013445

That error is similar, but I'm pretty sure mine said "no such file or directory" not th input/output error.
And Rufus is Windows only, I tried 3 ways from a Linux Mint 20 and got this problem on all


2020-09-17 15:58

reporter   ~0013446

Just tried looking at my boot.log, and miraculously it booted


2020-09-18 18:04

reporter   ~0013451

so problem resolved ?

Issue History

Date Modified Username Field Change
2020-09-11 22:55 Skystrike87 New Issue
2020-09-15 19:53 Michu Note Added: 0013425
2020-09-15 20:03 Skystrike87 Note Added: 0013427
2020-09-15 20:04 Skystrike87 Note Added: 0013428
2020-09-16 15:10 Michu Note Added: 0013438
2020-09-17 15:56 Skystrike87 Note Added: 0013445
2020-09-17 15:58 Skystrike87 Note Added: 0013446
2020-09-18 18:04 Michu Note Added: 0013451
2020-12-01 10:50 g0tmi1k Severity major => minor