View Issue Details

IDProjectCategoryView StatusLast Update
0006779Kali Linux[All Projects] Kali Package Bugpublic2020-10-13 16:12
Reporterwrathofgod Assigned Tosteev  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2020.3 
Target VersionFixed in Version 
Summary0006779: GUI Black Screen / Bash Terminal type
DescriptionOnce all the issues i got installing KL, finally, connecting with the GUI,
a black screen showed up (exactly the same as the Bash Terminal).

Didn't see the beautiful Kali Linux Desktop :-(
Steps To ReproduceIn Bash terminal,
ip add
Get the ip
Open the remote access
Type the ip and user
>>> then, black screen bash terminal type open.
Additional InformationLearning from the masters (you tech guys)
Thank you for your patience and knowledge

-Couldn't get the screen shot, as i don't know how to get it remotley

Activities

steev

2020-10-10 00:02

developer   ~0013547

Which remote access are you using? Have you tried https://www.kali.org/news/win-kex-version-2-0/ ?

steev

2020-10-10 00:07

developer   ~0013548

Keep in mind that WSL does not come with a desktop installed by default, and very few tools. So you may want to read over the documentation we have at https://kali.org/docs

wrathofgod

2020-10-12 01:35

reporter   ~0013549

Steev... i already installed "kex version" but nothing happened.
Also, i installed "large" just in case, but nothing also.

steev

2020-10-12 01:42

developer   ~0013550

How are you "connecting to the GUI", as you put it?

Can you give the exact steps you're running? I can't reproduce the issue here at all.

wrathofgod

2020-10-12 01:48

reporter   ~0013551

How to
1. Remotely: Once inside Bash terminal, type
a. ip add
b. Choose the 4: and use the 1st ip add
c. Open the remote access and type the ip add and user
> nothing happened but just a black screen like the same bash terminal

2. Using the Terminal (multi terminal)
a. Once installed the "kex version" it supposed pop up as an option in that terminal to open it as GUI.
> nothing happened.

steev

2020-10-12 01:56

developer   ~0013552

You're misunderstanding the documentation for kex - it doesn't and can't create an option in the Windows Terminal application. You have to add those to your settings manually, or you can run "kex" or "kex --win" to run it in fullscreen/windowed mode - https://www.kali.org/docs/wsl/win-kex-win/ or run "kex --sl" to run it in "seamless" mode - https://www.kali.org/docs/wsl/win-kex-sl/

And again, if you want those options in Windows Terminal, you will need to add them yourself by choosing whichever ones you want from https://www.kali.org/docs/wsl/win-kex/ and enter them in the settings from Windows Terminal (either via selecting the Settings option from the dropdown, or using "Ctrl+," assuming you haven't changed the default keybind for it.

steev

2020-10-12 02:02

developer   ~0013553

As to remote access - that uses rdp, so you need to make sure to start the xrdp service (I'm assuming you have) - you may have to restart xrdp's service "sudo service xrdp restart" after having installed a desktop (or kex, which pulls one in when you "apt install kali-win-kex" unless you tell it not to install recommends) - but again, I can't reproduce the issue with xrdp as when I connect (i just use localhost:port for the connection) it loads my desktop here.

Issue History

Date Modified Username Field Change
2020-10-09 21:15 wrathofgod New Issue
2020-10-10 00:02 steev Note Added: 0013547
2020-10-10 00:07 steev Note Added: 0013548
2020-10-12 01:35 wrathofgod Note Added: 0013549
2020-10-12 01:42 steev Note Added: 0013550
2020-10-12 01:48 wrathofgod Note Added: 0013551
2020-10-12 01:56 steev Note Added: 0013552
2020-10-12 02:02 steev Note Added: 0013553
2020-10-13 16:12 steev Assigned To => steev
2020-10-13 16:12 steev Status new => resolved
2020-10-13 16:12 steev Resolution open => no change required