View Issue Details

IDProjectCategoryView StatusLast Update
0000680Kali Linux[All Projects] General Bugpublic2014-07-22 19:19
Reporterg0tmi1k Assigned Torhertzog  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.5 
Target Version1.0.6Fixed in Version1.0.8 
Summary0000680: EFI boot support
DescriptionThe current Kali Linux (1.0.5) x64 doesn’t have the necessary EFI files on it.
Comparing it to the latest version of Debian (7.2.0) x64 - CD Version.

    root@kali ~/Desktop$ ls -lah *.iso
    -rwxrw-rw- 1 root root 623M Oct 28 13:14 debian-7.2.0-amd64-CD-1.iso
    -rwxrw-rw- 1 root root 2.4G Oct 28 13:25 kali-linux-1.0.5-amd64.iso
    root@kali ~/Desktop$ dumpet -i debian-7.2.0-amd64-CD-1.iso
    Validation Entry:
        Header Indicator: 0x01 (Validation Entry)
        PlatformId: 0x00 (80x86)
        ID: ""
        Checksum: 0x55aa
        Key bytes: 0x55aa
    Boot Catalog Default Entry:
        Entry is bootable
        Boot Media emulation type: no emulation
        Media load segment: 0x0 (0000:7c00)
        System type: 0 (0x00)
        Load Sectors: 4 (0x0004)
        Load LBA: 122249 (0x0001dd89)
    Section Header Entry:
        Header Indicator: 0x91 (Final Section Header Entry)
        PlatformId: 0xef (EFI)
        Section Entries: 1
        ID: ""
    Boot Catalog Section Entry:
        Entry is bootable
        Boot Media emulation type: no emulation
        Media load address: 0 (0x0000)
        System type: 0 (0x00)
        Load Sectors: 896 (0x0380)
        Load LBA: 89982 (0x00015f7e)
    root@kali ~/Desktop$ dumpet -i kali-linux-1.0.5-amd64.iso
    Validation Entry:
        Header Indicator: 0x01 (Validation Entry)
        PlatformId: 0x00 (80x86)
        ID: ""
        Checksum: 0x55aa
        Key bytes: 0x55aa
    Boot Catalog Default Entry:
        Entry is bootable
        Boot Media emulation type: no emulation
        Media load segment: 0x0 (0000:7c00)
        System type: 0 (0x00)
        Load Sectors: 4 (0x0004)
        Load LBA: 13447 (0x00003487)
    root@kali ~/Desktop$


Looking at the Debian image, the file '/.disk/mkisofs' contains the following arguments when generating their ISO file:
     -eltorito-alt-boot -e boot/grub/efi.img -no-emul-boot

Additional Information'To make a disk also EFI bootable, it needs an EFI bootable image, such as efiboot.img in our trees, and that needs to be inserted as a second El Torito boot image. To do this, we insert a 4th section between the El Torito section and the section about our tree, which looks like this:’
Source: https://fedoraproject.org/wiki/User:Pjones/BootableCDsForBIOSAndUEFI#New_UEFI.2FBIOS_hybrid_method

Activities

rhertzog

2013-12-06 11:29

administrator   ~0001136

Last edited: 2014-01-20 14:32

View 2 revisions

For the record, I opened a wishlist bug against live-build to get proper UEFI support: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=731709

rhertzog

2013-12-31 09:35

administrator   ~0001248

Adding some links that might be relevant:
https://forums.kali.org/showthread.php?271-How-to-EFI-install-Kali-Linux
http://securitty.tumblr.com/post/54774007612/kali-linux-macbook-usb-boot-full-disk-encryption

rhertzog

2014-03-28 21:26

administrator   ~0001645

Some progress report. I uploaded live-build 3.0.5-1kali4 (to kali-proposed-updates) that knows how to enable EFI boot support by using syslinux 6. But syslinux 6 is only available in kali-dev for now because it likely breaks the build of debian-installer...

That means that daily builds of kali-dev will have EFI support tomorrow:
http://archive.kali.org/kali-daily-images/

Feel free to test them and report back. If you're using the EFI support, your boot menu will be labeled "EFI Boot Menu", if you see only "Boot Menu" then you're using the BIOS boot method.

rhertzog

2014-07-22 19:19

administrator   ~0002356

We now have proper EFI boot support, at least if you copy the ISO on a USB stick and if you boot from it. You need live-build 3.0.5-1kali7 to build a proper EFI image.

Issue History

Date Modified Username Field Change
2013-11-01 16:30 g0tmi1k New Issue
2013-11-01 16:30 g0tmi1k Description Updated View Revisions
2013-12-06 11:29 rhertzog Note Added: 0001136
2013-12-06 11:29 rhertzog Assigned To => rhertzog
2013-12-06 11:29 rhertzog Status new => assigned
2013-12-06 11:30 rhertzog Priority normal => high
2013-12-06 11:30 rhertzog Target Version => 1.0.6
2013-12-31 09:35 rhertzog Note Added: 0001248
2014-01-20 14:32 rhertzog Note Edited: 0001136 View Revisions
2014-03-28 21:26 rhertzog Note Added: 0001645
2014-06-29 19:52 vichet Issue cloned: 0001464
2014-07-22 19:19 rhertzog Note Added: 0002356
2014-07-22 19:19 rhertzog Status assigned => closed
2014-07-22 19:19 rhertzog Resolution open => fixed
2014-07-22 19:19 rhertzog Fixed in Version => 1.0.8