View Issue Details

IDProjectCategoryView StatusLast Update
0006820Kali Linux[All Projects] Kali Package Bugpublic2021-01-11 10:41
Reporterskulldealer Assigned Todaniruiz  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2020.3 
Target VersionFixed in Version 
Summary0006820: important package missing in repo source (name-tilix)
Descriptionimportant and popular terminal multiplexer called tilix is missing.
please fix it.

output-
root@ISP:/# apt update && apt-cache search tilix && apt install tilix -y && apt-get install tilix -y && cat /etc/apt/sources.list
Hit:1 https://kali.download/kali kali-rolling InRelease
Hit:2 http://ppa.launchpad.net/apt-fast/stable/ubuntu bionic InRelease
Hit:3 http://deb.i2p2.no unstable InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package tilix
root@ISP:/#

Steps To Reproducetry this command-


apt update && apt-cache search tilix && apt install tilix -y && apt-get install tilix -y && cat /etc/apt/sources.list


ideally it should install tilix.

used mirrorscript v2 to find best server

Activities

skulldealer

2020-11-04 13:39

reporter   ~0013632

or is it that i am missing on a important source?

dQw4w9WgXcQ

2020-11-04 15:30

reporter   ~0013633

Have you tried this

Execute the command: mousepad /etc/apt/sources.list
Remove everything within that sources.list file
Duckduckgo for "Kali Linux Repository" (https://docs.kali.org/general-use/kali-linux-sources-list-repositories)
Scroll down and look for "The kali-rolling repository"
Copy everything within that kali-rolling and paste on sources.list file
Save the sources.list file
Execute the command: apt-get update
Now install your package(e.g:apt-get install tilix)

Or perhaps try


wget https://github.com/gnunn1/tilix/releases/download/1.9.3/tilix.zip
sudo unzip tilix.zip -d /
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/



Because you might have to install it manually because Kali are normally a few versions behind on most tool repositories so.

skulldealer

2020-11-04 16:10

reporter   ~0013634

Tried renewing sources many times. Same issue. Usually Tilix can get easily installed on kali linux. I installed kali newly again on vm using week 45 installer iso file. I had this problem so I recreated my sources.list many times. Same issue.


Yeah I was able to install tillix by normal manual method but it was unnecessary.

Are you able to install Tilix?

steev

2020-11-04 16:49

developer   ~0013636

Unfortunately, it was removed from Debian testing (which Kali is built on) - https://tracker.debian.org/news/1180947/tilix-removed-from-testing/ which also caused it to be removed from Kali.

rhertzog

2020-11-04 17:06

administrator   ~0013637

@dQw4w9WgXcQ I appreciate that you are trying to help but please refrain from doing broad assertions when you are not sure.

> Because you might have to install it manually because Kali are normally a few versions behind on most tool repositories so.

This is just plain wrong. It's quite the opposite, Kali is based on Debian testing which gets the lastest updates when the package is well maintained in Debian. In the case of tilix, the package has been dropped from testing due to a bug that has not been handled by its maintainers: https://bugs.debian.org/968816
See https://tracker.debian.org/pkg/tilix for more information about the package in Debian.

So you should really get in contact with the Debian maintainer and/or offer your help to get the package fixed in Debian and then it will come back to Kali.

rhertzog

2020-11-04 17:12

administrator   ~0013639

I sent a short mail to the Debian maintainers to make them aware of the package removal, hopefully that will trigger some action.

dQw4w9WgXcQ

2020-11-04 17:23

reporter   ~0013640

I apologise because English is not first language and sometimes I might have misunderstanding at some things.w

Sorry if I offended or upset you any way.

skulldealer

2020-11-04 18:08

reporter   ~0013641

Ok I got it. For now I have manually installed Tilix by the instructions provided in their GitHub page and the same are also provided above in this thread. I hope after Tilix is brought back to debian everything stays fine and nothing breaks because I have manually installed Tilix

Issue History

Date Modified Username Field Change
2020-11-04 13:32 skulldealer New Issue
2020-11-04 13:39 skulldealer Note Added: 0013632
2020-11-04 15:30 dQw4w9WgXcQ Note Added: 0013633
2020-11-04 16:10 skulldealer Note Added: 0013634
2020-11-04 16:49 steev Note Added: 0013636
2020-11-04 17:06 rhertzog Note Added: 0013637
2020-11-04 17:12 rhertzog Note Added: 0013639
2020-11-04 17:23 dQw4w9WgXcQ Note Added: 0013640
2020-11-04 18:08 skulldealer Note Added: 0013641
2020-12-01 10:48 g0tmi1k Priority immediate => normal
2020-12-01 10:50 g0tmi1k Severity major => minor
2021-01-11 10:41 daniruiz Assigned To => daniruiz
2021-01-11 10:41 daniruiz Status new => resolved
2021-01-11 10:41 daniruiz Resolution open => fixed