View Issue Details

IDProjectCategoryView StatusLast Update
0006900Kali Linux[All Projects] Kali Package Bugpublic2021-09-14 20:19
Reporterlyhistory Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionsuspended 
Product Version2020.4 
Target VersionFixed in Version 
Summary0006900: GVM unable to login after upgrade to latest version
Description
### Summary

**Kernel:** Linux kali 5.8.0-kali3-amd64 0000001 SMP Debian 5.8.14-1kali1 (2020-10-13) x86_64 GNU/Linux

so the previous gvm version I remember is 9.0.1, then I did apt upgrade, and gvm successfully upgraded to the latest version:

**gsad:** Greenbone Security Assistant 20.08.0~git
**gvmd:** Greenbone Vulnerability Manager 20.08.0 Manager DB revision 233
**openvas-scanner:** OpenVAS 20.8.0
**gvm-libs:** gvm-libs 20.8.0

### Issues
after the successful upgrade, I run into "Gvmd: database is wrong version", then I found out I need to do a gvm migrate after this major version upgrade,
then I managed to migrate using the role provided by kali:_gvm

and finally I gave it a test, but I failed login with the admin username&password which worked on previous version!!!
not sure if it's because of the db migration might has some small bugs, may be related to the warnings and errors showed in the gvm.log,
so I have to manually changed the password and then can login with the new password again,
I posted on gvm community first, and they recommend me to open an issue here,
for your reference, my original post is here:
https://community.greenbone.net/t/sharing-on-how-to-resolve-gvmd-migration-issue-with-small-issues-to-discuss/7733

Activities

lyhistory

2020-12-03 12:38

reporter   ~0013937

sorry, your firewall keep blocking my post, so it's impossible for me to post the whole content, please refer to
https://community.greenbone.net/t/sharing-on-how-to-resolve-gvmd-migration-issue-with-small-issues-to-discuss/7733

sbrun

2020-12-03 13:30

manager   ~0013938

Thanks for the report.
I don't think the user issue is related to the warnings in gvmd.log
It's probably because of the complex upgrade: upstream changed several things and we can't handle all the changes during package installation so we update the gvm-setup script.

The user needs to run gvm-setup after the upgrade. I will document it better in the package.

g0tmi1k

2021-09-14 20:19

administrator   ~0015186

This report has been filed against an old version of Kali. We will be closing this ticket due to inactivity.
Please could you see if you are able to replicate this issue with the latest version of Kali Linux (https://www.kali.org/get-kali/)?
If you are still facing the same problem, feel free to re-open the ticket. If you choose to do this, could you provide more information to the issue you are facing, and also give information about your setup?
For more information, please read: https://kali.training/topic/filing-a-good-bug-report/

Issue History

Date Modified Username Field Change
2020-12-03 12:31 lyhistory New Issue
2020-12-03 12:38 lyhistory Note Added: 0013937
2020-12-03 13:30 sbrun Note Added: 0013938
2021-09-14 20:19 g0tmi1k Status new => closed
2021-09-14 20:19 g0tmi1k Resolution open => suspended
2021-09-14 20:19 g0tmi1k Note Added: 0015186