View Issue Details

IDProjectCategoryView StatusLast Update
0006925Kali Linux[All Projects] General Bugpublic2021-01-09 09:03
Reporter99limm Assigned Todaniruiz  
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2020.4 
Target VersionFixed in Version 
Summary0006925: Newline (\n) handled differently by zsh and bash.
DescriptionI was doing some pentesting on a windows machine, and I decided to use the base64 encoding to bypass the filter.
At first I used the following command in zsh to encode:
# echo " .....\n...."...|...
and then I test:
# echo " .....\n...."...|...
the problem that we have the same result which is different when I run the command in the bash.
the problem is how zshell treats \ n

Activities

99limm

2020-12-11 22:07

reporter  

Problem 3.png (341,173 bytes)
problem 2.png (32,013 bytes)
problem 2.png (32,013 bytes)
problem 4.PNG (280,942 bytes)

daniruiz

2020-12-28 11:35

developer   ~0014005

You can eider scape the backslash '\\n' or use echo -E

Issue History

Date Modified Username Field Change
2020-12-11 22:07 99limm New Issue
2020-12-11 22:07 99limm File Added: Problem 3.png
2020-12-11 22:07 99limm File Added: problem 2.png
2020-12-11 22:07 99limm File Added: problem 4.PNG
2020-12-28 11:35 daniruiz Note Added: 0014005
2021-01-09 09:03 daniruiz Assigned To => daniruiz
2021-01-09 09:03 daniruiz Status new => closed
2021-01-09 09:03 daniruiz Resolution open => no change required