View Issue Details

IDProjectCategoryView StatusLast Update
0007060Kali Linux[All Projects] Kali Package Bugpublic2021-02-23 08:56
Reportershg8 Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0007060: libpcap-dev new version 1.10.0-2 doesn't have support for IEEE 802.11 (armhf)
DescriptionMy program uses libpcap to capture wireless packets. When I tried to use libpcap-dev on armhf to capture IEEE 802.11 packets, there's an error message "That device doesn't support monitor mode," even though my network adapter supports monitor mode. The adapter works fine with aircrack-ng. **The last version of libpcap 1.9.1-4 also works perfectly fine.** The new version seems to be compiled without support for 802.11 packets.

uname -r
 -- 4.19.118-Re4son-v7+

dpkg -s libc6
 -- Version: 2.31-4

hardware: Raspberry Pi 3B+
Steps To Reproducetcpdump -I wlan0mon
 -- That device doesn't support monitor mode.

tcpdump -i wlan0mon (without 802.11 headers)
 -- works fine. wireless packets are captured without headers

Activities

shg8

2021-02-23 00:28

reporter   ~0014239

libnl-3-dev is installed as well

Issue History

Date Modified Username Field Change
2021-02-23 00:14 shg8 New Issue
2021-02-23 00:28 shg8 Note Added: 0014239