View Issue Details

IDProjectCategoryView StatusLast Update
0007101Kali Linux[All Projects] Kali Package Bugpublic2021-03-18 14:24
Reportertn4417 Assigned Tosbrun  
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version2021.1 
Target VersionFixed in Version 
Summary0007101: hamster-sidejack and hamster-time-tracker conflict
Description# apt-get install -y kali-tools-web
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  apache-users dotdotpwn eyewitness ftester hamster-sidejack httprint httrack jboss-autopwn joomscan libalgorithm-c3-perl libb-hooks-endofscope-perl
  libb-hooks-op-check-perl libclass-c3-perl libclass-c3-xs-perl libclass-load-perl libclass-load-xs-perl libclass-method-modifiers-perl
  libclass-tiny-perl libclass-xsaccessor-perl libdata-optlist-perl libdevel-callchecker-perl libdevel-caller-perl libdevel-globaldestruction-perl
  libdevel-lexalias-perl libdevel-overloadinfo-perl libdevel-partialdump-perl libdevel-stacktrace-perl libdist-checkconflicts-perl
  libdynaloader-functions-perl libeval-closure-perl libfox-1.6-0 libfxscintilla20 libhttrack2 libimport-into-perl libio-all-lwp-perl libio-all-perl
  libmodule-implementation-perl libmodule-runtime-conflicts-perl libmodule-runtime-perl libmoo-perl libmoose-perl libmro-compat-perl
  libnamespace-clean-perl libnet-tftp-perl libpackage-deprecationmanager-perl libpackage-stash-perl libpackage-stash-xs-perl libpadwalker-perl
  libparallel-forkmanager-perl libparams-classify-perl libparams-util-perl libregexp-common-perl librole-tiny-perl libspiffy-perl libstrictures-perl
  libsub-exporter-perl libsub-exporter-progressive-perl libsub-identify-perl libsub-install-perl libsub-quote-perl libvariable-magic-perl
  owasp-mantra-ff padbuster paros plecost pry python3-easyprocess python3-fuzzywuzzy python3-geoip python3-levenshtein python3-pygeoip
  python3-pyvirtualdisplay racc ruby-childprocess ruby-coderay ruby-connection-pool ruby-fxruby ruby-jwt ruby-mechanize ruby-method-source
  ruby-net-http-persistent ruby-net-http-pipeline ruby-nfnetlink ruby-nfqueue ruby-ntlm ruby-selenium-webdriver ruby-webrobots sslsniff tlssled
  uniscan watobo webscarab xsser
Suggested packages:
  webhttrack httrack-doc libdb-file-lock-perl libfile-readbackwards-perl libfreezethaw-perl libmldbm-perl libscalar-number-perl
  libbareword-filehandles-perl libindirect-perl libmultidimensional-perl firefoxdriver
The following NEW packages will be installed:
  apache-users dotdotpwn eyewitness ftester hamster-sidejack httprint httrack jboss-autopwn joomscan kali-tools-web libalgorithm-c3-perl
  libb-hooks-endofscope-perl libb-hooks-op-check-perl libclass-c3-perl libclass-c3-xs-perl libclass-load-perl libclass-load-xs-perl
  libclass-method-modifiers-perl libclass-tiny-perl libclass-xsaccessor-perl libdata-optlist-perl libdevel-callchecker-perl libdevel-caller-perl
  libdevel-globaldestruction-perl libdevel-lexalias-perl libdevel-overloadinfo-perl libdevel-partialdump-perl libdevel-stacktrace-perl
  libdist-checkconflicts-perl libdynaloader-functions-perl libeval-closure-perl libfox-1.6-0 libfxscintilla20 libhttrack2 libimport-into-perl
  libio-all-lwp-perl libio-all-perl libmodule-implementation-perl libmodule-runtime-conflicts-perl libmodule-runtime-perl libmoo-perl libmoose-perl
  libmro-compat-perl libnamespace-clean-perl libnet-tftp-perl libpackage-deprecationmanager-perl libpackage-stash-perl libpackage-stash-xs-perl
  libpadwalker-perl libparallel-forkmanager-perl libparams-classify-perl libparams-util-perl libregexp-common-perl librole-tiny-perl libspiffy-perl
  libstrictures-perl libsub-exporter-perl libsub-exporter-progressive-perl libsub-identify-perl libsub-install-perl libsub-quote-perl
  libvariable-magic-perl owasp-mantra-ff padbuster paros plecost pry python3-easyprocess python3-fuzzywuzzy python3-geoip python3-levenshtein
  python3-pygeoip python3-pyvirtualdisplay racc ruby-childprocess ruby-coderay ruby-connection-pool ruby-fxruby ruby-jwt ruby-mechanize
  ruby-method-source ruby-net-http-persistent ruby-net-http-pipeline ruby-nfnetlink ruby-nfqueue ruby-ntlm ruby-selenium-webdriver ruby-webrobots
  sslsniff tlssled uniscan watobo webscarab xsser
0 upgraded, 94 newly installed, 0 to remove and 0 not upgraded.
Need to get 86.9 MB of archives.
After this operation, 220 MB of additional disk space will be used.
Get:1 http://kali.download/kali kali-rolling/main amd64 libclass-method-modifiers-perl all 2.13-1 [19.2 kB]
Get:2 http://kali.download/kali kali-rolling/main amd64 libb-hooks-op-check-perl amd64 0.22-1+b3 [11.3 kB]
Get:3 http://kali.download/kali kali-rolling/main amd64 libdynaloader-functions-perl all 0.003-1.1 [12.7 kB]
Get:4 http://kali.download/kali kali-rolling/main amd64 libdevel-callchecker-perl amd64 0.008-1+b2 [15.9 kB]
Get:5 http://kali.download/kali kali-rolling/main amd64 libparams-classify-perl amd64 0.015-1+b3 [25.7 kB]
Get:6 http://kali.download/kali kali-rolling/main amd64 libmodule-runtime-perl all 0.016-1 [19.4 kB]
Get:7 http://kali.download/kali kali-rolling/main amd64 libimport-into-perl all 1.002005-1 [11.6 kB]
Get:8 http://kali.download/kali kali-rolling/main amd64 librole-tiny-perl all 2.002004-1 [21.4 kB]
Get:9 http://kali.download/kali kali-rolling/main amd64 libstrictures-perl all 2.000006-1 [18.6 kB]
Get:10 http://kali.download/kali kali-rolling/main amd64 libsub-quote-perl all 2.006006-1 [21.0 kB]
Get:11 http://kali.download/kali kali-rolling/main amd64 libmoo-perl all 2.004004-1 [59.9 kB]
Get:12 http://kali.download/kali kali-rolling/main amd64 libparallel-forkmanager-perl all 2.02-1 [30.4 kB]
Get:13 http://kali.download/kali kali-rolling/main amd64 libspiffy-perl all 0.46-1 [25.7 kB]
Get:14 http://kali.download/kali kali-rolling/main amd64 libio-all-perl all 0.87-1 [66.7 kB]
Get:15 http://kali.download/kali kali-rolling/main amd64 libio-all-lwp-perl all 0.14-2.1 [15.5 kB]
Get:16 http://kali.download/kali kali-rolling/main amd64 apache-users amd64 2.1-1kali4 [3,452 B]
Get:17 http://kali.download/kali kali-rolling/main amd64 libnet-tftp-perl all 0.1901-1.1 [14.0 kB]
Get:18 http://kali.download/kali kali-rolling/main amd64 dotdotpwn amd64 3.0.2-0kali2 [35.8 kB]
Get:19 http://kali.download/kali kali-rolling/main amd64 python3-levenshtein amd64 0.12.2-1 [39.1 kB]
Get:20 http://kali.download/kali kali-rolling/main amd64 python3-fuzzywuzzy all 0.18.0-1 [20.6 kB]
Get:21 http://kali.download/kali kali-rolling/main amd64 python3-easyprocess all 0.2.5-2 [11.6 kB]
Get:22 http://kali.download/kali kali-rolling/main amd64 python3-pyvirtualdisplay all 0.2.1-3 [11.1 kB]
Get:23 http://kali.download/kali kali-rolling/main amd64 eyewitness amd64 20210305.1-0kali1 [1,371 kB]
Get:24 http://kali.download/kali kali-rolling/main amd64 ftester all 1.0-1kali2 [20.9 kB]
Get:25 http://kali.download/kali kali-rolling/main amd64 hamster-sidejack amd64 2.0-1kali4 [45.1 kB]
Get:26 http://kali.download/kali kali-rolling/main amd64 libhttrack2 amd64 3.49.2-1.1 [268 kB]
Get:27 http://kali.download/kali kali-rolling/main amd64 httrack amd64 3.49.2-1.1 [39.7 kB]
Get:28 http://kali.download/kali kali-rolling/main amd64 jboss-autopwn all 0.1-1kali1 [66.8 kB]
Get:29 http://kali.download/kali kali-rolling/main amd64 libregexp-common-perl all 2017060201-1 [177 kB]
Get:30 http://kali.download/kali kali-rolling/main amd64 joomscan all 0.0.7-0kali2 [64.3 kB]
Get:31 http://kali.download/kali kali-rolling/non-free amd64 httprint amd64 0.301-0kali3 [556 kB]
Get:32 http://kali.download/kali kali-rolling/non-free amd64 owasp-mantra-ff amd64 0.9-1kali2 [49.4 MB]
Get:33 http://kali.download/kali kali-rolling/main amd64 padbuster all 0.3.3-1kali3 [12.3 kB]
Get:34 http://kali.download/kali kali-rolling/main amd64 paros all 3.2.13-1kali3 [1,580 kB]
Get:35 http://kali.download/kali kali-rolling/main amd64 plecost all 1.1.2-0kali1 [1,320 kB]
Get:36 http://kali.download/kali kali-rolling/main amd64 sslsniff amd64 0.8-9 [124 kB]
Get:37 http://kali.download/kali kali-rolling/main amd64 tlssled all 1.3-0kali2 [9,904 B]
Get:38 http://kali.download/kali kali-rolling/main amd64 libparams-util-perl amd64 1.102-1+b1 [25.6 kB]
Get:39 http://kali.download/kali kali-rolling/main amd64 libsub-install-perl all 0.928-1.1 [10.8 kB]
Get:40 http://kali.download/kali kali-rolling/main amd64 libdata-optlist-perl all 0.110-1.1 [10.8 kB]
Get:41 http://kali.download/kali kali-rolling/main amd64 libmodule-implementation-perl all 0.09-1.1 [12.4 kB]
Get:42 http://kali.download/kali kali-rolling/main amd64 libpackage-stash-perl all 0.39-1 [21.9 kB]
Get:43 http://kali.download/kali kali-rolling/main amd64 libclass-load-perl all 0.25-1 [16.1 kB]
Get:44 http://kali.download/kali kali-rolling/main amd64 libclass-load-xs-perl amd64 0.10-1+b5 [14.6 kB]
Get:45 http://kali.download/kali kali-rolling/main amd64 libsub-exporter-progressive-perl all 0.001013-1 [7,588 B]
Get:46 http://kali.download/kali kali-rolling/main amd64 libdevel-globaldestruction-perl all 0.14-1.1 [8,312 B]
Get:47 http://kali.download/kali kali-rolling/main amd64 libalgorithm-c3-perl all 0.11-1 [11.7 kB]
Get:48 http://kali.download/kali kali-rolling/main amd64 libclass-c3-perl all 0.35-1 [22.9 kB]
Get:49 http://kali.download/kali kali-rolling/main amd64 libmro-compat-perl all 0.13-1 [12.2 kB]
Get:50 http://kali.download/kali kali-rolling/main amd64 libsub-identify-perl amd64 0.14-1+b3 [12.0 kB]
Get:51 http://kali.download/kali kali-rolling/main amd64 libdevel-overloadinfo-perl all 0.005-1 [7,212 B]
Get:52 http://kali.download/kali kali-rolling/main amd64 libdevel-stacktrace-perl all 2.0400-1 [28.6 kB]
Get:53 http://kali.download/kali kali-rolling/main amd64 libsub-exporter-perl all 0.987-1 [47.2 kB]
Get:54 http://kali.download/kali kali-rolling/main amd64 libeval-closure-perl all 0.14-1 [11.5 kB]
Get:55 http://kali.download/kali kali-rolling/main amd64 libdist-checkconflicts-perl all 0.11-1.1 [10.2 kB]
Get:56 http://kali.download/kali kali-rolling/main amd64 libmodule-runtime-conflicts-perl all 0.003-1.1 [7,156 B]
Get:57 http://kali.download/kali kali-rolling/main amd64 libpackage-deprecationmanager-perl all 0.17-1.1 [16.6 kB]
Get:58 http://kali.download/kali kali-rolling/main amd64 libpackage-stash-xs-perl amd64 0.29-1+b2 [20.2 kB]
Get:59 http://kali.download/kali kali-rolling/main amd64 libmoose-perl amd64 2.2014-2 [802 kB]
Get:60 http://kali.download/kali kali-rolling/main amd64 uniscan all 6.3-0kali2 [219 kB]
Get:61 http://kali.download/kali kali-rolling/main amd64 ruby-coderay all 1.1.3-3 [77.5 kB]
Get:62 http://kali.download/kali kali-rolling/main amd64 ruby-method-source all 1.0.0-2 [9,060 B]
Get:63 http://kali.download/kali kali-rolling/main amd64 pry all 0.13.1-1 [141 kB]
Get:64 http://kali.download/kali kali-rolling/main amd64 libfox-1.6-0 amd64 1.6.57-1 [877 kB]
Get:65 http://kali.download/kali kali-rolling/main amd64 libfxscintilla20 amd64 2.28.0-0kali2 [765 kB]
Get:66 http://kali.download/kali kali-rolling/main amd64 ruby-fxruby amd64 1.6.29-0kali7+b1 [1,602 kB]
Get:67 http://kali.download/kali kali-rolling/main amd64 ruby-jwt all 2.2.2-1 [21.2 kB]
Get:68 http://kali.download/kali kali-rolling/main amd64 ruby-connection-pool all 2.2.2-1 [9,080 B]
Get:69 http://kali.download/kali kali-rolling/main amd64 ruby-net-http-persistent all 3.1.0-2 [21.0 kB]
Get:70 http://kali.download/kali kali-rolling/main amd64 ruby-ntlm all 0.6.1-2 [17.3 kB]
Get:71 http://kali.download/kali kali-rolling/main amd64 racc all 1.4.14-2 [83.4 kB]
Get:72 http://kali.download/kali kali-rolling/main amd64 ruby-webrobots all 0.1.2-1 [10.9 kB]
Get:73 http://kali.download/kali kali-rolling/main amd64 ruby-mechanize all 2.7.7-1 [81.7 kB]
Get:74 http://kali.download/kali kali-rolling/main amd64 ruby-net-http-pipeline all 1.0.1-3 [7,052 B]
Get:75 http://kali.download/kali kali-rolling/main amd64 ruby-childprocess all 4.0.0-1 [24.9 kB]
Get:76 http://kali.download/kali kali-rolling/main amd64 ruby-selenium-webdriver all 3.142.7+dfsg-2 [742 kB]
Get:77 http://kali.download/kali kali-rolling/main amd64 watobo amd64 1.0.1-0kali1 [689 kB]
Get:78 http://kali.download/kali kali-rolling/main amd64 webscarab all 20120422-001828-1kali2 [13.0 MB]
Get:79 http://kali.download/kali kali-rolling/main amd64 python3-geoip amd64 1.3.2-3+b3 [21.1 kB]
Get:80 http://kali.download/kali kali-rolling/main amd64 xsser all 1.8.3+git20201228-0kali1 [11.5 MB]
Get:81 http://kali.download/kali kali-rolling/main amd64 kali-tools-web amd64 2021.1.10 [13.4 kB]
Get:82 http://kali.download/kali kali-rolling/main amd64 libvariable-magic-perl amd64 0.62-1+b3 [45.7 kB]
Get:83 http://kali.download/kali kali-rolling/main amd64 libb-hooks-endofscope-perl all 0.24-1.1 [18.9 kB]
Get:84 http://kali.download/kali kali-rolling/main amd64 libclass-c3-xs-perl amd64 0.15-1+b1 [17.3 kB]
Get:85 http://kali.download/kali kali-rolling/main amd64 libclass-tiny-perl all 1.008-1 [18.8 kB]
Get:86 http://kali.download/kali kali-rolling/main amd64 libclass-xsaccessor-perl amd64 1.19-3+b7 [38.1 kB]
Get:87 http://kali.download/kali kali-rolling/main amd64 libpadwalker-perl amd64 2.5-1+b1 [20.3 kB]
Get:88 http://kali.download/kali kali-rolling/main amd64 libdevel-caller-perl amd64 2.06-2+b3 [12.1 kB]
Get:89 http://kali.download/kali kali-rolling/main amd64 libdevel-lexalias-perl amd64 0.05-2+b3 [9,064 B]
Get:90 http://kali.download/kali kali-rolling/main amd64 libnamespace-clean-perl all 0.27-1 [17.3 kB]
Get:91 http://kali.download/kali kali-rolling/main amd64 libdevel-partialdump-perl all 0.20-1 [15.3 kB]
Get:92 http://kali.download/kali kali-rolling/main amd64 python3-pygeoip all 0.3.2-5 [18.0 kB]
Get:93 http://kali.download/kali kali-rolling/main amd64 ruby-nfnetlink all 1.0.2-2 [4,532 B]
Get:94 http://kali.download/kali kali-rolling/main amd64 ruby-nfqueue all 1.0.4-2 [6,372 B]
Fetched 86.9 MB in 54s (1,619 kB/s)
Extracting templates from packages: 100%
Selecting previously unselected package libclass-method-modifiers-perl.
(Reading database ... 466464 files and directories currently installed.)
Preparing to unpack .../00-libclass-method-modifiers-perl_2.13-1_all.deb ...
Unpacking libclass-method-modifiers-perl (2.13-1) ...
Selecting previously unselected package libb-hooks-op-check-perl.
Preparing to unpack .../01-libb-hooks-op-check-perl_0.22-1+b3_amd64.deb ...
Unpacking libb-hooks-op-check-perl (0.22-1+b3) ...
Selecting previously unselected package libdynaloader-functions-perl.
Preparing to unpack .../02-libdynaloader-functions-perl_0.003-1.1_all.deb ...
Unpacking libdynaloader-functions-perl (0.003-1.1) ...
Selecting previously unselected package libdevel-callchecker-perl.
Preparing to unpack .../03-libdevel-callchecker-perl_0.008-1+b2_amd64.deb ...
Unpacking libdevel-callchecker-perl (0.008-1+b2) ...
Selecting previously unselected package libparams-classify-perl.
Preparing to unpack .../04-libparams-classify-perl_0.015-1+b3_amd64.deb ...
Unpacking libparams-classify-perl (0.015-1+b3) ...
Selecting previously unselected package libmodule-runtime-perl.
Preparing to unpack .../05-libmodule-runtime-perl_0.016-1_all.deb ...
Unpacking libmodule-runtime-perl (0.016-1) ...
Selecting previously unselected package libimport-into-perl.
Preparing to unpack .../06-libimport-into-perl_1.002005-1_all.deb ...
Unpacking libimport-into-perl (1.002005-1) ...
Selecting previously unselected package librole-tiny-perl.
Preparing to unpack .../07-librole-tiny-perl_2.002004-1_all.deb ...
Unpacking librole-tiny-perl (2.002004-1) ...
Selecting previously unselected package libstrictures-perl.
Preparing to unpack .../08-libstrictures-perl_2.000006-1_all.deb ...
Unpacking libstrictures-perl (2.000006-1) ...
Selecting previously unselected package libsub-quote-perl.
Preparing to unpack .../09-libsub-quote-perl_2.006006-1_all.deb ...
Unpacking libsub-quote-perl (2.006006-1) ...
Selecting previously unselected package libmoo-perl.
Preparing to unpack .../10-libmoo-perl_2.004004-1_all.deb ...
Unpacking libmoo-perl (2.004004-1) ...
Selecting previously unselected package libparallel-forkmanager-perl.
Preparing to unpack .../11-libparallel-forkmanager-perl_2.02-1_all.deb ...
Unpacking libparallel-forkmanager-perl (2.02-1) ...
Selecting previously unselected package libspiffy-perl.
Preparing to unpack .../12-libspiffy-perl_0.46-1_all.deb ...
Unpacking libspiffy-perl (0.46-1) ...
Selecting previously unselected package libio-all-perl.
Preparing to unpack .../13-libio-all-perl_0.87-1_all.deb ...
Unpacking libio-all-perl (0.87-1) ...
Selecting previously unselected package libio-all-lwp-perl.
Preparing to unpack .../14-libio-all-lwp-perl_0.14-2.1_all.deb ...
Unpacking libio-all-lwp-perl (0.14-2.1) ...
Selecting previously unselected package apache-users.
Preparing to unpack .../15-apache-users_2.1-1kali4_amd64.deb ...
Unpacking apache-users (2.1-1kali4) ...
Selecting previously unselected package libnet-tftp-perl.
Preparing to unpack .../16-libnet-tftp-perl_0.1901-1.1_all.deb ...
Unpacking libnet-tftp-perl (0.1901-1.1) ...
Selecting previously unselected package dotdotpwn.
Preparing to unpack .../17-dotdotpwn_3.0.2-0kali2_amd64.deb ...
Unpacking dotdotpwn (3.0.2-0kali2) ...
Selecting previously unselected package python3-levenshtein.
Preparing to unpack .../18-python3-levenshtein_0.12.2-1_amd64.deb ...
Unpacking python3-levenshtein (0.12.2-1) ...
Selecting previously unselected package python3-fuzzywuzzy.
Preparing to unpack .../19-python3-fuzzywuzzy_0.18.0-1_all.deb ...
Unpacking python3-fuzzywuzzy (0.18.0-1) ...
Selecting previously unselected package python3-easyprocess.
Preparing to unpack .../20-python3-easyprocess_0.2.5-2_all.deb ...
Unpacking python3-easyprocess (0.2.5-2) ...
Selecting previously unselected package python3-pyvirtualdisplay.
Preparing to unpack .../21-python3-pyvirtualdisplay_0.2.1-3_all.deb ...
Unpacking python3-pyvirtualdisplay (0.2.1-3) ...
Selecting previously unselected package eyewitness.
Preparing to unpack .../22-eyewitness_20210305.1-0kali1_amd64.deb ...
Unpacking eyewitness (20210305.1-0kali1) ...
Selecting previously unselected package ftester.
Preparing to unpack .../23-ftester_1.0-1kali2_all.deb ...
Unpacking ftester (1.0-1kali2) ...
Preparing to unpack .../24-hamster-sidejack_2.0-1kali4_amd64.deb ...
Unpacking hamster-sidejack (2.0-1kali4) ...
dpkg: error processing archive /tmp/apt-dpkg-install-SIDCag/24-hamster-sidejack_2.0-1kali4_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/hamster', which is also in package hamster-time-tracker 3.0.2-3
Selecting previously unselected package libhttrack2.
Preparing to unpack .../25-libhttrack2_3.49.2-1.1_amd64.deb ...
Unpacking libhttrack2 (3.49.2-1.1) ...
Selecting previously unselected package httrack.
Preparing to unpack .../26-httrack_3.49.2-1.1_amd64.deb ...
Unpacking httrack (3.49.2-1.1) ...
Selecting previously unselected package jboss-autopwn.
Preparing to unpack .../27-jboss-autopwn_0.1-1kali1_all.deb ...
Unpacking jboss-autopwn (0.1-1kali1) ...
Selecting previously unselected package libregexp-common-perl.
Preparing to unpack .../28-libregexp-common-perl_2017060201-1_all.deb ...
Unpacking libregexp-common-perl (2017060201-1) ...
Selecting previously unselected package joomscan.
Preparing to unpack .../29-joomscan_0.0.7-0kali2_all.deb ...
Unpacking joomscan (0.0.7-0kali2) ...
Selecting previously unselected package httprint.
Preparing to unpack .../30-httprint_0.301-0kali3_amd64.deb ...
Unpacking httprint (0.301-0kali3) ...
Selecting previously unselected package owasp-mantra-ff.
Preparing to unpack .../31-owasp-mantra-ff_0.9-1kali2_amd64.deb ...
Unpacking owasp-mantra-ff (0.9-1kali2) ...
Selecting previously unselected package padbuster.
Preparing to unpack .../32-padbuster_0.3.3-1kali3_all.deb ...
Unpacking padbuster (0.3.3-1kali3) ...
Selecting previously unselected package paros.
Preparing to unpack .../33-paros_3.2.13-1kali3_all.deb ...
Unpacking paros (3.2.13-1kali3) ...
Selecting previously unselected package plecost.
Preparing to unpack .../34-plecost_1.1.2-0kali1_all.deb ...
Unpacking plecost (1.1.2-0kali1) ...
Selecting previously unselected package sslsniff.
Preparing to unpack .../35-sslsniff_0.8-9_amd64.deb ...
Unpacking sslsniff (0.8-9) ...
Selecting previously unselected package tlssled.
Preparing to unpack .../36-tlssled_1.3-0kali2_all.deb ...
Unpacking tlssled (1.3-0kali2) ...
Selecting previously unselected package libparams-util-perl.
Preparing to unpack .../37-libparams-util-perl_1.102-1+b1_amd64.deb ...
Unpacking libparams-util-perl (1.102-1+b1) ...
Selecting previously unselected package libsub-install-perl.
Preparing to unpack .../38-libsub-install-perl_0.928-1.1_all.deb ...
Unpacking libsub-install-perl (0.928-1.1) ...
Selecting previously unselected package libdata-optlist-perl.
Preparing to unpack .../39-libdata-optlist-perl_0.110-1.1_all.deb ...
Unpacking libdata-optlist-perl (0.110-1.1) ...
Selecting previously unselected package libmodule-implementation-perl.
Preparing to unpack .../40-libmodule-implementation-perl_0.09-1.1_all.deb ...
Unpacking libmodule-implementation-perl (0.09-1.1) ...
Selecting previously unselected package libpackage-stash-perl.
Preparing to unpack .../41-libpackage-stash-perl_0.39-1_all.deb ...
Unpacking libpackage-stash-perl (0.39-1) ...
Selecting previously unselected package libclass-load-perl.
Preparing to unpack .../42-libclass-load-perl_0.25-1_all.deb ...
Unpacking libclass-load-perl (0.25-1) ...
Selecting previously unselected package libclass-load-xs-perl.
Preparing to unpack .../43-libclass-load-xs-perl_0.10-1+b5_amd64.deb ...
Unpacking libclass-load-xs-perl (0.10-1+b5) ...
Selecting previously unselected package libsub-exporter-progressive-perl.
Preparing to unpack .../44-libsub-exporter-progressive-perl_0.001013-1_all.deb ...
Unpacking libsub-exporter-progressive-perl (0.001013-1) ...
Selecting previously unselected package libdevel-globaldestruction-perl.
Preparing to unpack .../45-libdevel-globaldestruction-perl_0.14-1.1_all.deb ...
Unpacking libdevel-globaldestruction-perl (0.14-1.1) ...
Selecting previously unselected package libalgorithm-c3-perl.
Preparing to unpack .../46-libalgorithm-c3-perl_0.11-1_all.deb ...
Unpacking libalgorithm-c3-perl (0.11-1) ...
Selecting previously unselected package libclass-c3-perl.
Preparing to unpack .../47-libclass-c3-perl_0.35-1_all.deb ...
Unpacking libclass-c3-perl (0.35-1) ...
Selecting previously unselected package libmro-compat-perl.
Preparing to unpack .../48-libmro-compat-perl_0.13-1_all.deb ...
Unpacking libmro-compat-perl (0.13-1) ...
Selecting previously unselected package libsub-identify-perl.
Preparing to unpack .../49-libsub-identify-perl_0.14-1+b3_amd64.deb ...
Unpacking libsub-identify-perl (0.14-1+b3) ...
Selecting previously unselected package libdevel-overloadinfo-perl.
Preparing to unpack .../50-libdevel-overloadinfo-perl_0.005-1_all.deb ...
Unpacking libdevel-overloadinfo-perl (0.005-1) ...
Selecting previously unselected package libdevel-stacktrace-perl.
Preparing to unpack .../51-libdevel-stacktrace-perl_2.0400-1_all.deb ...
Unpacking libdevel-stacktrace-perl (2.0400-1) ...
Selecting previously unselected package libsub-exporter-perl.
Preparing to unpack .../52-libsub-exporter-perl_0.987-1_all.deb ...
Unpacking libsub-exporter-perl (0.987-1) ...
Selecting previously unselected package libeval-closure-perl.
Preparing to unpack .../53-libeval-closure-perl_0.14-1_all.deb ...
Unpacking libeval-closure-perl (0.14-1) ...
Selecting previously unselected package libdist-checkconflicts-perl.
Preparing to unpack .../54-libdist-checkconflicts-perl_0.11-1.1_all.deb ...
Unpacking libdist-checkconflicts-perl (0.11-1.1) ...
Selecting previously unselected package libmodule-runtime-conflicts-perl.
Preparing to unpack .../55-libmodule-runtime-conflicts-perl_0.003-1.1_all.deb ...
Unpacking libmodule-runtime-conflicts-perl (0.003-1.1) ...
Selecting previously unselected package libpackage-deprecationmanager-perl.
Preparing to unpack .../56-libpackage-deprecationmanager-perl_0.17-1.1_all.deb ...
Unpacking libpackage-deprecationmanager-perl (0.17-1.1) ...
Selecting previously unselected package libpackage-stash-xs-perl.
Preparing to unpack .../57-libpackage-stash-xs-perl_0.29-1+b2_amd64.deb ...
Unpacking libpackage-stash-xs-perl (0.29-1+b2) ...
Selecting previously unselected package libmoose-perl.
Preparing to unpack .../58-libmoose-perl_2.2014-2_amd64.deb ...
Unpacking libmoose-perl (2.2014-2) ...
Selecting previously unselected package uniscan.
Preparing to unpack .../59-uniscan_6.3-0kali2_all.deb ...
Unpacking uniscan (6.3-0kali2) ...
Selecting previously unselected package ruby-coderay.
Preparing to unpack .../60-ruby-coderay_1.1.3-3_all.deb ...
Unpacking ruby-coderay (1.1.3-3) ...
Selecting previously unselected package ruby-method-source.
Preparing to unpack .../61-ruby-method-source_1.0.0-2_all.deb ...
Unpacking ruby-method-source (1.0.0-2) ...
Selecting previously unselected package pry.
Preparing to unpack .../62-pry_0.13.1-1_all.deb ...
Unpacking pry (0.13.1-1) ...
Selecting previously unselected package libfox-1.6-0:amd64.
Preparing to unpack .../63-libfox-1.6-0_1.6.57-1_amd64.deb ...
Unpacking libfox-1.6-0:amd64 (1.6.57-1) ...
Selecting previously unselected package libfxscintilla20.
Preparing to unpack .../64-libfxscintilla20_2.28.0-0kali2_amd64.deb ...
Unpacking libfxscintilla20 (2.28.0-0kali2) ...
Selecting previously unselected package ruby-fxruby.
Preparing to unpack .../65-ruby-fxruby_1.6.29-0kali7+b1_amd64.deb ...
Unpacking ruby-fxruby (1.6.29-0kali7+b1) ...
Selecting previously unselected package ruby-jwt.
Preparing to unpack .../66-ruby-jwt_2.2.2-1_all.deb ...
Unpacking ruby-jwt (2.2.2-1) ...
Selecting previously unselected package ruby-connection-pool.
Preparing to unpack .../67-ruby-connection-pool_2.2.2-1_all.deb ...
Unpacking ruby-connection-pool (2.2.2-1) ...
Selecting previously unselected package ruby-net-http-persistent.
Preparing to unpack .../68-ruby-net-http-persistent_3.1.0-2_all.deb ...
Unpacking ruby-net-http-persistent (3.1.0-2) ...
Selecting previously unselected package ruby-ntlm.
Preparing to unpack .../69-ruby-ntlm_0.6.1-2_all.deb ...
Unpacking ruby-ntlm (0.6.1-2) ...
Selecting previously unselected package racc.
Preparing to unpack .../70-racc_1.4.14-2_all.deb ...
Unpacking racc (1.4.14-2) ...
Selecting previously unselected package ruby-webrobots.
Preparing to unpack .../71-ruby-webrobots_0.1.2-1_all.deb ...
Unpacking ruby-webrobots (0.1.2-1) ...
Selecting previously unselected package ruby-mechanize.
Preparing to unpack .../72-ruby-mechanize_2.7.7-1_all.deb ...
Unpacking ruby-mechanize (2.7.7-1) ...
Selecting previously unselected package ruby-net-http-pipeline.
Preparing to unpack .../73-ruby-net-http-pipeline_1.0.1-3_all.deb ...
Unpacking ruby-net-http-pipeline (1.0.1-3) ...
Selecting previously unselected package ruby-childprocess.
Preparing to unpack .../74-ruby-childprocess_4.0.0-1_all.deb ...
Unpacking ruby-childprocess (4.0.0-1) ...
Selecting previously unselected package ruby-selenium-webdriver.
Preparing to unpack .../75-ruby-selenium-webdriver_3.142.7+dfsg-2_all.deb ...
Unpacking ruby-selenium-webdriver (3.142.7+dfsg-2) ...
Selecting previously unselected package watobo.
Preparing to unpack .../76-watobo_1.0.1-0kali1_amd64.deb ...
Unpacking watobo (1.0.1-0kali1) ...
Selecting previously unselected package webscarab.
Preparing to unpack .../77-webscarab_20120422-001828-1kali2_all.deb ...
Unpacking webscarab (20120422-001828-1kali2) ...
Selecting previously unselected package python3-geoip.
Preparing to unpack .../78-python3-geoip_1.3.2-3+b3_amd64.deb ...
Unpacking python3-geoip (1.3.2-3+b3) ...
Selecting previously unselected package xsser.
Preparing to unpack .../79-xsser_1.8.3+git20201228-0kali1_all.deb ...
Unpacking xsser (1.8.3+git20201228-0kali1) ...
Selecting previously unselected package kali-tools-web.
Preparing to unpack .../80-kali-tools-web_2021.1.10_amd64.deb ...
Unpacking kali-tools-web (2021.1.10) ...
Selecting previously unselected package libvariable-magic-perl.
Preparing to unpack .../81-libvariable-magic-perl_0.62-1+b3_amd64.deb ...
Unpacking libvariable-magic-perl (0.62-1+b3) ...
Selecting previously unselected package libb-hooks-endofscope-perl.
Preparing to unpack .../82-libb-hooks-endofscope-perl_0.24-1.1_all.deb ...
Unpacking libb-hooks-endofscope-perl (0.24-1.1) ...
Selecting previously unselected package libclass-c3-xs-perl.
Preparing to unpack .../83-libclass-c3-xs-perl_0.15-1+b1_amd64.deb ...
Unpacking libclass-c3-xs-perl (0.15-1+b1) ...
Selecting previously unselected package libclass-tiny-perl.
Preparing to unpack .../84-libclass-tiny-perl_1.008-1_all.deb ...
Unpacking libclass-tiny-perl (1.008-1) ...
Selecting previously unselected package libclass-xsaccessor-perl.
Preparing to unpack .../85-libclass-xsaccessor-perl_1.19-3+b7_amd64.deb ...
Unpacking libclass-xsaccessor-perl (1.19-3+b7) ...
Selecting previously unselected package libpadwalker-perl.
Preparing to unpack .../86-libpadwalker-perl_2.5-1+b1_amd64.deb ...
Unpacking libpadwalker-perl (2.5-1+b1) ...
Selecting previously unselected package libdevel-caller-perl.
Preparing to unpack .../87-libdevel-caller-perl_2.06-2+b3_amd64.deb ...
Unpacking libdevel-caller-perl (2.06-2+b3) ...
Selecting previously unselected package libdevel-lexalias-perl.
Preparing to unpack .../88-libdevel-lexalias-perl_0.05-2+b3_amd64.deb ...
Unpacking libdevel-lexalias-perl (0.05-2+b3) ...
Selecting previously unselected package libnamespace-clean-perl.
Preparing to unpack .../89-libnamespace-clean-perl_0.27-1_all.deb ...
Unpacking libnamespace-clean-perl (0.27-1) ...
Selecting previously unselected package libdevel-partialdump-perl.
Preparing to unpack .../90-libdevel-partialdump-perl_0.20-1_all.deb ...
Unpacking libdevel-partialdump-perl (0.20-1) ...
Selecting previously unselected package python3-pygeoip.
Preparing to unpack .../91-python3-pygeoip_0.3.2-5_all.deb ...
Unpacking python3-pygeoip (0.3.2-5) ...
Selecting previously unselected package ruby-nfnetlink.
Preparing to unpack .../92-ruby-nfnetlink_1.0.2-2_all.deb ...
Unpacking ruby-nfnetlink (1.0.2-2) ...
Selecting previously unselected package ruby-nfqueue.
Preparing to unpack .../93-ruby-nfqueue_1.0.4-2_all.deb ...
Unpacking ruby-nfqueue (1.0.4-2) ...
Errors were encountered while processing:
 /tmp/apt-dpkg-install-SIDCag/24-hamster-sidejack_2.0-1kali4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
                                                                       
Steps To Reproduceapt install -y kali-tools-web

Relationships

related to 0007106 new Update hamster-sidejack webpage on tools.kali.org 

Activities

tn4417

2021-03-16 09:44

reporter   ~0014357

─# apt-get install -y kali-tools-web 100 ⨯
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
kali-tools-web is already the newest version (2021.1.10).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 kali-tools-web : Depends: hamster-sidejack but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

steev

2021-03-16 20:28

developer   ~0014360

Unpacking hamster-sidejack (2.0-1kali4) ...
dpkg: error processing archive /tmp/apt-dpkg-install-SIDCag/24-hamster-sidejack_2.0-1kali4_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/hamster', which is also in package hamster-time-tracker 3.0.2-3

Looks like we have clashing binary names with the GNOME time tracker.

You could remove hamster-time-tracker as a workaround, if you aren't using it.

tn4417

2021-03-17 03:31

reporter   ~0014361

this problem was fixed.Thanks

steev

2021-03-17 03:54

developer   ~0014363

Do you mean the workaround worked, or do you mean that you're able to install hamster-sidejack while also having hamster-time-tracker installed?

tn4417

2021-03-17 04:03

reporter   ~0014364

I follow your instructions. .I need to remove the hamster-time-tracker package first. I then reinstalled the package kali-tools-web

sbrun

2021-03-18 14:24

manager   ~0014367

to avoid conflict with the Debian package hamster-time-tracker, we renamed the command from hamster to hamster-sidejack in version kali/2.0-1kali5

Issue History

Date Modified Username Field Change
2021-03-16 09:42 tn4417 New Issue
2021-03-16 09:44 tn4417 Note Added: 0014357
2021-03-16 20:28 steev Note Added: 0014360
2021-03-17 03:31 tn4417 Note Added: 0014361
2021-03-17 03:54 steev Note Added: 0014363
2021-03-17 04:03 tn4417 Note Added: 0014364
2021-03-18 08:09 sbrun Assigned To => sbrun
2021-03-18 08:09 sbrun Status new => assigned
2021-03-18 08:22 sbrun Summary error when install package kali-tools-web => hamster-sidejack and hamster-time-tracker conflict
2021-03-18 14:17 sbrun Relationship added related to 0007106
2021-03-18 14:24 sbrun Status assigned => resolved
2021-03-18 14:24 sbrun Resolution open => fixed
2021-03-18 14:24 sbrun Note Added: 0014367