View Issue Details

IDProjectCategoryView StatusLast Update
0007182Kali Linux[All Projects] General Bugpublic2021-05-12 01:06
ReporterGrosbur Assigned Todaniruiz  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version2021.1 
Target VersionFixed in Version2021.2 
Summary0007182: The Kali Light theme is missing images present in the Kali Dark theme
DescriptionIn the package "kali-themes-common_2021.2.1_all.deb" the "/usr/share/themes/Kali-Light/gtk-3.0/assets" subfolder in the Kali-Light theme is empty, missing .png and .svg files present under the Kali-Dark theme. This make the Light theme display a red square in place of the correct symbol like the check box.
Steps To ReproduceUpdate the to the current version of kali-themes-common_2021.2.1_all.deb

Activities

daniruiz

2021-05-10 09:05

developer   ~0014524

I don't have that issue with kali-themes-common 2021.2.1
/usr/share/themes/Kali-Light/gtk-3.0/assets should be a symbolic link to the dark theme assets, so it should have the exact same files
Try reinstalling kali-themes-common and see if it get fixed 'sudo apt reinstall kali-themes-common'

image.png (1,506,749 bytes)

Grosbur

2021-05-10 11:02

reporter   ~0014535

Reinstalling the package indeed do resolve the issue, but I've try on a fresh install on a VM with the last ISO (kali-linux-2021.1) and during the update of the kali-themes-common the /usr/share/themes/Kali-Light/gtk-3.0/assets folder is reported as a regular directory (not as a broken symlink) ( but have a weird size 20k) and is empty. I don't understand what is happening during the update.

daniruiz

2021-05-10 14:56

developer   ~0014536

At some point I do think I broke that link while updating a script. That might be the cause but it is now fixed for this new release
Thanks for reporting ;)

arnaudr

2021-05-11 15:11

manager   ~0014538

Fixed in https://gitlab.com/kalilinux/packages/kali-themes/-/commit/0dff79a46fda1ffe36bc80d41227d254905f9982. Thanks for the report @Grosbur!

Issue History

Date Modified Username Field Change
2021-05-08 14:25 Grosbur New Issue
2021-05-10 09:05 daniruiz File Added: image.png
2021-05-10 09:05 daniruiz Note Added: 0014524
2021-05-10 09:05 daniruiz Assigned To => daniruiz
2021-05-10 09:05 daniruiz Status new => assigned
2021-05-10 11:02 Grosbur Note Added: 0014535
2021-05-10 14:56 daniruiz Note Added: 0014536
2021-05-10 14:57 daniruiz Status assigned => resolved
2021-05-10 14:57 daniruiz Resolution open => fixed
2021-05-10 14:57 daniruiz Fixed in Version => 2021.2
2021-05-11 15:11 arnaudr Note Added: 0014538