View Issue Details

IDProjectCategoryView StatusLast Update
0007203Kali Linux[All Projects] Kali Websites & Docspublic2021-06-30 08:49
Reporterdroidjamil Assigned Torhertzog  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2021.1 
Target VersionFixed in Version 
Summary0007203: Mirror http://kali.mirror.globo.tech/kali/ is 2 years out of date
DescriptionI was introducing a friend to Kali, and she was having trouble installing packages, we traced the problem to fact that the mirror that was being autoselected for her, http://kali.mirror.globo.tech/kali/, has a timestamp of 30-Apr-2019 18:03 on dists/kali-rolling/Release and dists/kali-rolling/Contents-amd64.gz, as well as many of the other files. Many files are older than that, and I could not find a file newer than that. Additionally, the list of versions available in that repo support the theory that it's an out of date repo and not just a timestamp failure.

Given that this repo is priority 100 for Canada, and diagnosing the problem is non-trivial for someone not familiar with debian repo mechanics, this seems moderately high priority to at least remove it from the metalink.

Activities

Michu

2021-05-15 14:46

reporter   ~0014595

try to find at kali.org repositories and copy paste them in /etc/apt/sources.list and save then apt update link to repo's https://www.kali.org/docs/general-use/kali-linux-sources-list-repositories/

securnetic

2021-05-19 02:52

reporter   ~0014596

Yes, commenting out the default kali update link and adding berkeley for example works, but TechyShishy is right, it is very annoying to have to edit all the VMs to reflect this if you're in Canada. This is a major issue I noticed since a few days too, it wasn't doing it a few weeks ago.

Michu

2021-05-19 19:37

reporter   ~0014597

seriously i didn't know about this isue

rhertzog

2021-05-28 15:13

administrator   ~0014598

Thanks for the notice. This was indeed a regression in our script that ensures that mirrors are up-to-date. It has been fixed now. Sorry for the inconvenience.

Issue History

Date Modified Username Field Change
2021-05-28 15:18 droidjamil New Issue
2021-05-28 15:18 droidjamil Issue generated from: 0007189
2021-06-30 08:49 g0tmi1k Priority high => normal