View Issue Details

IDProjectCategoryView StatusLast Update
0007268Kali Linux[All Projects] Kali Package Bugpublic2021-10-02 09:00
ReporterRoseDeSable Assigned Toarnaudr  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target VersionFixed in Version2021.4 
Summary0007268: shellter: cannot start / must do workaround
DescriptionHi,
 after the upgrade yesterday I can't start shellter. My workaround: start it with the command "wineconsole /usr/share/windows-resources/shellter/shellter.exe, and it does its work.

Best Regards
Rose

Activities

Gamb1t

2021-07-28 19:35

developer   ~0014952

Can you please provide some extra information? Before yesterday, when was the last time you upgraded your system, what command did you use to upgrade, and do you happen to know how many packages in total got upgraded? Additionally, what system architecture are you on?

I cant replicate the problem you're describing, and I wonder if it is in relation to how wine is setup on your system rather than something wrong with an upgrade.

RoseDeSable

2021-07-29 08:57

reporter   ~0014953

- the last upgrade was Friday, 23 July 2021

- information about my system "<my-nds > 5.10.0-kali9-amd64 0000001 SMP Debian 5.10.46-1kali1 (2021-06-25) x86_64 GNU/Linux"

- the history.log of apt:

Start-Date: 2021-07-28 06:30:18
Commandline: apt dist-upgrade
Install: libgpac10:amd64 (1.0.1+dfsg1-4, automatic)
Upgrade: console-setup:amd64 (1.203, 1.205), krb5-locales:amd64 (1.18.3-5, 1.18.3-6), libgssapi-krb5-2:amd64 (1.18.3-5, 1.18.3-6), libgssapi-krb5-2:i386 (1.18.3-5, 1.18.3-6), libglx-mesa0:amd64 (20.3.4-1, 20.3.5-1), libglx-mesa0:i386 (20.3.4-1, 20.3.5-1), python3-dateutil:amd64 (2.8.1-5, 2.8.1-6), krb5-user:amd64 (1.18.3-5, 1.18.3-6), pack:amd64 (0.0.4-0kali3, 0.0.4-0kali4), libnftables1:amd64 (0.9.8-3, 0.9.8-3.1), chkrootkit:amd64 (0.54-1+b1, 0.54-1+b2), libx264-160:amd64 (2:0.160.3011+gitcde9a93-2+b2, 2:0.160.3011+gitcde9a93-2.1), libx264-160:i386 (2:0.160.3011+gitcde9a93-2+b2, 2:0.160.3011+gitcde9a93-2.1), libgbm1:amd64 (20.3.4-1, 20.3.5-1), libgbm1:i386 (20.3.4-1, 20.3.5-1), libkadm5srv-mit12:amd64 (1.18.3-5, 1.18.3-6), zsh:amd64 (5.8-6+b1, 5.8-6+b2), os-prober:amd64 (1.78, 1.79), x264:amd64 (2:0.160.3011+gitcde9a93-2+b2, 2:0.160.3011+gitcde9a93-2.1), netdiscover:amd64 (0.7-3, 0.7-4), cdebootstrap:amd64 (0.7.8+b2, 0.7.8+b3), geoipupdate:amd64 (4.6.0-1+b2, 4.6.0-1+b3), exim4-config:amd64 (4.94.2-6, 4.94.2-7), libkrb5support0:amd64 (1.18.3-5, 1.18.3-6), libkrb5support0:i386 (1.18.3-5, 1.18.3-6), libxatracker2:amd64 (20.3.4-1, 20.3.5-1), console-setup-linux:amd64 (1.203, 1.205), mesa-va-drivers:amd64 (20.3.4-1, 20.3.5-1), mesa-va-drivers:i386 (20.3.4-1, 20.3.5-1), exim4-base:amd64 (4.94.2-6, 4.94.2-7), libgl1-mesa-dev:amd64 (20.3.4-1, 20.3.5-1), libgl1-mesa-dri:amd64 (20.3.4-1, 20.3.5-1), libgl1-mesa-dri:i386 (20.3.4-1, 20.3.5-1), libosmesa6:amd64 (20.3.4-1, 20.3.5-1), libosmesa6:i386 (20.3.4-1, 20.3.5-1), libgl1-mesa-glx:amd64 (20.3.4-1, 20.3.5-1), python3-aiosqlite:amd64 (0.16.1-1, 0.16.1-3), kali-defaults-desktop:amd64 (2021.2.5, 2021.2.7), libaspell15:amd64 (0.60.8-2, 0.60.8-3), libkrb5-3:amd64 (1.18.3-5, 1.18.3-6), libkrb5-3:i386 (1.18.3-5, 1.18.3-6), mesa-vulkan-drivers:amd64 (20.3.4-1, 20.3.5-1), mesa-vulkan-drivers:i386 (20.3.4-1, 20.3.5-1), libk5crypto3:amd64 (1.18.3-5, 1.18.3-6), libk5crypto3:i386 (1.18.3-5, 1.18.3-6), libkdb5-10:amd64 (1.18.3-5, 1.18.3-6), python3-pil:amd64 (8.1.2+dfsg-0.2, 8.1.2+dfsg-0.3), theharvester:amd64 (4.0.0-0kali2, 4.0.0-0kali3), libglapi-mesa:amd64 (20.3.4-1, 20.3.5-1), libglapi-mesa:i386 (20.3.4-1, 20.3.5-1), keyboard-configuration:amd64 (1.203, 1.205), exim4-daemon-light:amd64 (4.94.2-6, 4.94.2-7), libegl-mesa0:amd64 (20.3.4-1, 20.3.5-1), mesa-vdpau-drivers:amd64 (20.3.4-1, 20.3.5-1), mesa-vdpau-drivers:i386 (20.3.4-1, 20.3.5-1), libgssrpc4:amd64 (1.18.3-5, 1.18.3-6), libkadm5clnt-mit12:amd64 (1.18.3-5, 1.18.3-6), kali-defaults:amd64 (2021.2.5, 2021.2.7), libdebconfclient0:amd64 (0.259, 0.260), nftables:amd64 (0.9.8-3, 0.9.8-3.1), aspell:amd64 (0.60.8-2, 0.60.8-3)
End-Date: 2021-07-28 06:34:57

cohst

2021-10-02 08:31

reporter   ~0015259

I have the same problem. Out put from console is

┌──(cohst@kali-linux)-[~]
└─$ shellter
wineconsole: Starting program "./ wineconsole /usr/share/windows-resources/shellter/shellter.exe" failed.
The command is invalid.
                                                                                                                  
┌──(cohst@kali-linux)-[~]
└─$

But when I start it with wineconsole /usr/share/windows-resources/shellter/shellter.exe or with wine /usr/share/windows-resources/shellter/shellter.exe it works fine.

arnaudr

2021-10-02 08:58

manager   ~0015260

Last edited: 2021-10-02 08:59

View 2 revisions

Hi, that's an issue with Kali's wrapper script "kali-winexec". This script is provided by the package kali-defaults. It's been fixed in latest version 2021.4.0, that just landed in Kali Rolling.

So what you have to do is just to update your system (assuming you're on Kali rolling):

sudo apt update && sudo apt full-upgrade


After that, check that the package kali-defaults is indeed at latest version:

─$ dpkg -l | grep kali-defaults | awk '{print $2 " " $3 }'
kali-defaults 2021.4.0
kali-defaults-desktop 2021.4.0


From this point, it should work.

I close the issue, but feel free to re-open if ever it didn't solve the problem.

Issue History

Date Modified Username Field Change
2021-07-28 09:10 RoseDeSable New Issue
2021-07-28 19:35 Gamb1t Note Added: 0014952
2021-07-29 08:57 RoseDeSable Note Added: 0014953
2021-10-02 08:31 cohst Note Added: 0015259
2021-10-02 08:58 arnaudr Note Added: 0015260
2021-10-02 08:59 arnaudr Note Edited: 0015260 View Revisions
2021-10-02 09:00 arnaudr Assigned To => arnaudr
2021-10-02 09:00 arnaudr Status new => resolved
2021-10-02 09:00 arnaudr Resolution open => fixed
2021-10-02 09:00 arnaudr Fixed in Version => 2021.4