View Issue Details

IDProjectCategoryView StatusLast Update
0007339Kali Linux[All Projects] General Bugpublic2021-10-22 00:13
Reporter4wi7u4 Assigned Torhertzog  
Status resolvedResolutionfixed 
Product Version2021.3 
Target VersionFixed in Version2021.3 
Summary0007339: Live USB Encrypted Persistence won't work.
DescriptionI've written the Kali 2021.3 image via dd and created the LUKS partition called 'persistence'. Created persistence.conf on it which contains '/ union'. Then I tried to boot up in 'Live USB Encrypted Persistence'. It just started the Live without asking LUKS password.
Steps To Reproduce1) Write the flash drive via dd
2) create a LUKS partition called 'persistence'
3) create persistence.conf which contains '/ union' on it
4) boot up using 'Live USB Encrypted Persistence'
Additional InformationI didn't tried creating encrypted persistence on this version. It definitely worked on 2021.2. So, I think it is a 2021.3 bug.


has duplicate 0007373 closed Cannot create live persistent encrypted USB with kali 2021.3 iso 



2021-09-26 19:27

reporter   ~0015240

I've experienced the same. I spent some time trying multiple combinations of SD Cards, Flash Drives, and writing software - being sure to follow the documentation (and trying my own thing).

As above 2021.2 consistently works fine, and encrypted persistence in 2021.3 just doesn't. Non-encrypted persistence in 2021.3 seems to work though.

I've also tested with "kali-linux-2021-W39-live-everything-amd64.iso" in case there's something updated/extra in there but encrypted persistence doesn't work in that either.


2021-10-15 18:43

manager   ~0015300

Another example


2021-10-18 22:27

reporter   ~0015317

I have the same problem. I discovered it’s because the cryptsetup-initramfs package isn’t included in the live image. I rebuilt the live image with that package and everything worked.


2021-10-19 07:59

manager   ~0015319

I can confirm. I downloaded both the 2021.2 and 2021.3 live images, unpacked the initrd and looked at the content:

$ find initrd-2021.2 -name '*cryptsetup*'

$ find initrd-2021.3 -name '*cryptsetup*'

Indeed, the cryptsetup binary is missing.


2021-10-21 13:51

administrator   ~0015334

Should be fixed in the 2021.3a release ISO that we released:

Issue History

Date Modified Username Field Change
2021-09-22 19:33 4wi7u4 New Issue
2021-09-26 19:27 HelpfulHermit Note Added: 0015240
2021-10-15 18:41 Gamb1t Assigned To => Gamb1t
2021-10-15 18:41 Gamb1t Status new => confirmed
2021-10-15 18:41 Gamb1t Assigned To Gamb1t => rhertzog
2021-10-15 18:43 Gamb1t Note Added: 0015300
2021-10-15 18:44 Gamb1t Relationship added has duplicate 0007373
2021-10-18 22:27 MotherMucca Note Added: 0015317
2021-10-19 07:59 arnaudr Note Added: 0015319
2021-10-21 13:51 rhertzog Status confirmed => resolved
2021-10-21 13:51 rhertzog Resolution open => fixed
2021-10-21 13:51 rhertzog Fixed in Version => 2021.3
2021-10-21 13:51 rhertzog Note Added: 0015334