View Issue Details

IDProjectCategoryView StatusLast Update
0007373Kali Linux[All Projects] General Bugpublic2021-10-15 18:44
ReporterMagicCookie Assigned To 
PriorityurgentSeverityblockReproducibilityalways
Status closedResolutionduplicate 
Product Version2021.3 
Target VersionFixed in Version 
Summary0007373: Cannot create live persistent encrypted USB with kali 2021.3 iso
DescriptionI was trying to create a Live Persistent Encrypted USB with the Kali Live 2021.3 iso. I followed the official guide as well as other guides online but nothing worked.

Upon following all steps exactly when choosing the 'Live Persistent Encryption' option in the grub boot menu the OS boots directly to a live OS - it *does not* prompt me for a password. After being booted the encrypted persistence partition is visible as an unmounted drive on the desktop and is able to be mounted and used as an encrypted persistent drive, but not as it should - i.e no settings are saved, nothing on the desktop is saved, etc.

I followed the exact same steps using the 2021.1 live iso and it worked perfectly! but the 2021.3 iso did not, it does not ask for an encryption password when booting - it boots and operates just as a standard live USB without persistence and/or encryption does.
Steps To ReproduceFollow the steps exactly as laid out in g0tmi1k's official guide to create a persistent encrypted USB using a USB or external SSD (I tried both) and use the latest kali live ISO for 2021.3:

https://www.kali.org/docs/usb/usb-persistence-encryption/
https://www.kali.org/get-kali/#kali-live
Additional InformationI used a Samsung T7 [500gb] and also tried a SanDisk Fit [256gb]. After trying the 2021.1 iso the T7 booted and was persistent and encrypted as it should be, but the 2021.3 iso did not work for either the Flash Drive nor the T7 external SSD.

Relationships

duplicate of 0007339 confirmedrhertzog Live USB Encrypted Persistence won't work. 

Activities

Michu

2021-10-08 14:41

reporter   ~0015269

i think you don't understand the purpose of live usb persistence encrypted because this mode is just live usb with mounting while boot you usb that you use for live usb it can't save anything because this is mode for trying linux distro not to boot and use it as normal os to save info's because after reboot every info that is in ram is deleted and everything returns to beggining

HelpfulHermit

2021-10-08 16:40

reporter   ~0015270

This is a duplicate of https://bugs.kali.org/view.php?id=7339


@Michu: "persistence" is working, which DOES allow saving files and changes which are viewable after a reboot, despite what your comment says. What doesn't work in 2021.3 (but does in 2021.2) is encrypted persistence.

Michu

2021-10-11 15:32

reporter   ~0015271

i always thought that in this mode you can't save anything so in that case i'm sorry my bad maybe he did something wrong in live usb creating process or it is a bug as you pasted link of earlier topic duplicate maybe try on pendrive instead of ssd

Gamb1t

2021-10-15 18:44

developer   ~0015301

Closing as this is a duplicate, but this is now linked in the original.

Issue History

Date Modified Username Field Change
2021-10-07 01:50 MagicCookie New Issue
2021-10-08 14:41 Michu Note Added: 0015269
2021-10-08 16:40 HelpfulHermit Note Added: 0015270
2021-10-11 15:32 Michu Note Added: 0015271
2021-10-15 18:44 Gamb1t Status new => closed
2021-10-15 18:44 Gamb1t Resolution open => duplicate
2021-10-15 18:44 Gamb1t Note Added: 0015301
2021-10-15 18:44 Gamb1t Relationship added duplicate of 0007339