View Issue Details

IDProjectCategoryView StatusLast Update
0007344Kali Linux[All Projects] Kali Package Improvementpublic2021-10-28 10:02
Reporterkindzadza Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
Product Version2021.3 
Target VersionFixed in Version 
Summary0007344: bluetooth manager
Descriptionbluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; disabled; vendor preset: disabled)
     Active: active (running) since Sat 2021-09-25 14:32:25 MDT; 47min ago
       Docs: man:bluetoothd(8)
   Main PID: 1444 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 4467)
     Memory: 2.2M
        CPU: 39ms
     CGroup: /system.slice/bluetooth.service
             └─1444 /usr/libexec/bluetooth/bluetoothd
                                                                                                                                                                        
Sep 25 14:32:25 kalistro systemd[1]: Starting Bluetooth service...
Sep 25 14:32:25 kalistro bluetoothd[1444]: Bluetooth daemon 5.61
Sep 25 14:32:25 kalistro systemd[1]: Started Bluetooth service.
Sep 25 14:32:25 kalistro bluetoothd[1444]: Starting SDP server
Sep 25 14:32:25 kalistro bluetoothd[1444]: Bluetooth management interface 1.18 initialized
Sep 25 14:32:25 kalistro bluetoothd[1444]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
Sep 25 14:32:25 kalistro bluetoothd[1444]: sap-server: Operation not permitted (1)
Sep 25 14:32:25 kalistro bluetoothd[1444]: Endpoint registered: sender=:1.29 path=/MediaEndpoint/A2DPSink/sbc
Sep 25 14:32:25 kalistro bluetoothd[1444]: Endpoint registered: sender=:1.29 path=/MediaEndpoint/A2DPSource/sbc
Steps To Reproducebluetooth did not detect the new equipment, it used to work and connect, and after the update, an error writes.

Activities

arnaudr

2021-09-30 08:36

manager   ~0015247

When you talk about an error, I guess you mean those lines:

Sep 25 14:32:25 kalistro bluetoothd[1444]: profiles/sap/server.c:sap_server_register() Sap driver initialization failed.
Sep 25 14:32:25 kalistro bluetoothd[1444]: sap-server: Operation not permitted (1)


It seem that this error is harmless. I also have this error on my machine. This is not what's causing your problem.

Apart from those two lines, there's no error in your logs.

Did you try to forget/reset the connection with this device, then retry? Bluetooth is a capricious technology.

From your report, there's nothing we can do to help, sorry.

steev

2021-10-21 20:37

manager   ~0015339

As arnaudr said, that error is harmless. If you really want it to go away, you can use a systemd drop-in to start bluetoothd without the sap plugin.

This would create such a drop-in:

sudo mkdir /etc/systemd/system/bluetooth.service.d/
echo '[Service]' | sudo tee /etc/systemd/system/bluetooth.service.d/01-disable-sap-plugin.conf
echo 'ExecStart=' | sudo tee /etc/systemd/system/bluetooth.service.d/01-disable-sap-plugin.conf
echo 'ExecStart=/usr/sbin/bluetoothd --noplugin=sap' | sudo tee /etc/systemd/system/bluetooth.service.d/01-disable-sap-plugin.conf

sudo systemctl daemon-reload
sudo systemctl restart bluetooth.service

However, you haven't provided any actual error, so we can't really assist further.

g0tmi1k

2021-10-28 10:01

administrator   ~0015379

Closing due to lack of response.
Please re-open when ready.

Issue History

Date Modified Username Field Change
2021-09-25 21:28 kindzadza New Issue
2021-09-30 08:36 arnaudr Note Added: 0015247
2021-10-21 20:37 steev Assigned To => steev
2021-10-21 20:37 steev Status new => feedback
2021-10-21 20:37 steev Note Added: 0015339
2021-10-28 09:58 g0tmi1k Severity block => minor
2021-10-28 10:01 g0tmi1k Note Added: 0015379
2021-10-28 10:02 g0tmi1k Assigned To steev =>
2021-10-28 10:02 g0tmi1k Status feedback => closed
2021-10-28 10:02 g0tmi1k Resolution open => suspended