View Issue Details

IDProjectCategoryView StatusLast Update
0007407Kali LinuxGeneral Bugpublic2021-10-22 00:14
ReporterFawkesthephoenix Assigned Todaniruiz  
Status resolvedResolutionfixed 
Product Version2021.3 
Summary0007407: Settings tries to load and crashes after upgrade

When trying to load settings from the gnome interface, it tries loading up and stops.

Loading the control center from the terminal with
gnome-control-center brings the following error.

(gnome-control-center:3555): GLib-GIO-ERROR **: 06:21:29.734: Settings schema 'org.gnome.settings-daemon.plugins.power' does not contain a key named 'power-saver-profile-on-low-battery'
Trace/breakpoint trap

running gnome-control-center as root

Steps To Reproduce

run "gnome-control-center" as user after upgrade

Attached Files


has duplicate 0007376 closeddaniruiz GLib-GIO-ERROR 
has duplicate 0007374 closeddaniruiz No acceso al menú de configuración 
has duplicate 0007414 closeddaniruiz gnome-control-center stops workingn after update 



2021-10-14 13:06


I have the same issue here, when I select Power panel, The control center crash immediately, and keep crashing when trying to open it again.

Although I found a temporary solution to open the control center: "gsettings reset org.gnome.ControlCenter last-panel"

This command will reset the last visited panel. But the problem remains, no one can open the power panel.



2021-10-14 15:49

reporter   ~0015292

Same here and when i use gsettings reset org.gnome.ControlCenter last-panel it lets me bring up setting and use any of it but power settings it just crashes



2021-10-15 09:46

reporter   ~0015294

Have same issue with the Plasma here. Sometimes the control center crash immediately



2021-10-15 14:08

reporter   ~0015295

I have the same issue. If I try to enter on the battery menu, the Control Center crash, but after this, if I try to enter on Wireless settings, Internet settings and any other options, the same issue occurs, and this all since yesterday.



2021-10-15 17:57

reporter   ~0015299

Also seeing the same bug. A good explanation of the cause may be found here:


2021-10-15 18:51


Yeah that's right, gnome-settings-daemon is still 3.38.2-1, gnome-control-center and gsettings-desktop-schemas are both 41.0-1

The thing is, if you force the upgrade of gnome-settings-daemon to 41.0-2 with kali-dev or unstable repo, it will force the upgrade of gnome-shell and mutter to 41.0-1.

Something I never want to, Gnome 40/41 is too buggy. I will try to downgrade both gnome-control-center and gsettings-desktop-schemas to 3.38 in that case.



2021-10-15 19:45

reporter   ~0015304

Even after reinstalling using live instead of offline does the same thing


2021-10-15 19:48


I think you should log-out or kill X first before, it's not effective immediately.

With kali live, it's nearly impossible to do this, unless you have a persistent live partition


2021-10-17 16:26


Ok, so I did it!!! the power panel can be opened normally with eithers operations:

Either you upgrade to gnome 40.4 with kali-dev repo: "apt install -t kali-dev mutter gdm3 gnome-shell gnome-control-center gsettings-desktop-schemas gnome-desktop3-data gnome-session"
You downgrade to gnome 3.38.6 with kali-last-snapshot repo: "apt install --allow-downgrades {mutter,gdm3,gnome-shell,gnome-control-center,gsettings-desktop-schemas,gnome-desktop3-data,gnome-session}/kali-last-snapshot"

I made both tests, and it's WORKING!!!



2021-10-17 20:33

reporter   ~0015310

Same here for the last week. After upgrading kali 2021.3 I'm no longer able to access my settings. I've uninstalled and reinstalled but after upgrade nothing happens.
I finally reinstalled....set my power settings before updating but soon after, now I'm back to square one. Not able to access my settings panel.

Waiting for a patch in the next update until further notice.



2021-10-17 22:39

reporter   ~0015312

I was unable to get j_jito's upgrade/downgrade options to work. Not that this matters, though. I'm using Kali Rolling and want to be careful about upgrading by going to the kali-dev repository. On the other side of the coin, I'm not too keen on downgrading what I've got, either (other than the power panel, it seems to be working well).

Looks like I'm stuck waiting for a patch via normal channels!



2021-10-17 23:16

reporter   ~0015313

I tried upgrading and down grading and it gave me errors because of updated packages being newer then ones being installed there where 2 of them i removed the first package and all i got was a curser i rebooted and it worked fine



2021-10-18 19:39

reporter   ~0015315

After updating this morning 10/18/21 I'm now able to access the settings panel without any issues.

Thank you


2021-10-18 20:33


It should be working now, Kali team just pushed gnome-shell 40.5 to Kali-Rolling channel



2021-10-19 09:14

manager   ~0015322

This is now fixed with the update for gnome 40
If it still gives you any issue feel free to reopen this bug report.

Issue History

Date Modified Username Field Change
2021-10-14 10:42 Fawkesthephoenix New Issue
2021-10-14 10:42 Fawkesthephoenix File Added: Screenshot from 2021-10-14 06-36-15.png
2021-10-14 13:06 user6331 Note Added: 0015290
2021-10-14 15:49 Bleach Note Added: 0015292
2021-10-15 09:46 danielm Note Added: 0015294
2021-10-15 14:08 mztb File Added: Captura de tela de 2021-10-15 10-49-25.png
2021-10-15 14:08 mztb Note Added: 0015295
2021-10-15 17:57 BleepBlorpBlerp Note Added: 0015299
2021-10-15 18:51 user6331 Note Added: 0015303
2021-10-15 19:45 Bleach Note Added: 0015304
2021-10-15 19:48 user6331 Note Added: 0015305
2021-10-17 16:26 user6331 Note Added: 0015309
2021-10-17 20:33 blaqsense Note Added: 0015310
2021-10-17 22:39 BleepBlorpBlerp Note Added: 0015312
2021-10-17 23:16 Bleach Note Added: 0015313
2021-10-18 19:39 blaqsense File Added: Kali Linux-2021-10-18-15-38-52.png
2021-10-18 19:39 blaqsense Note Added: 0015315
2021-10-18 20:33 user6331 Note Added: 0015316
2021-10-19 09:09 daniruiz Relationship added has duplicate 0007376
2021-10-19 09:09 daniruiz Relationship added has duplicate 0007374
2021-10-19 09:10 daniruiz Relationship added has duplicate 0007414
2021-10-19 09:14 daniruiz Note Added: 0015322
2021-10-19 09:14 daniruiz Assigned To => daniruiz
2021-10-19 09:14 daniruiz Status new => resolved
2021-10-19 09:14 daniruiz Resolution open => fixed