View Issue Details

IDProjectCategoryView StatusLast Update
0007524Kali Linux[All Projects] Kali Package Bugpublic2022-01-05 08:03
Reporternaitikjoshi24 Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version2021.4 
Target VersionFixed in Version 
Summary0007524: SSHD not working
Descriptionsshd is broken, it seems to me that the latest sshd package itself is broken and there's no problem with the system itself.
first thing is that you have to execute sshd from its absolute path (it is a feature so no problems with that) but when you execute sshd with absolute path [/usr/sbin/sshd]
when executed with absolute path the following error is presented "sshd: no hostkeys available -- exiting."
so the next thing i did was generate all keys for ssh using the command {ssh-keygen -A} and it did generate all the keys (i checked the concerning directories and the keys were there)
i ran {/usr/sbin/sshd} again but i got the same error "sshd: no hostkeys available -- exiting."
so now i just tried to directly start sshd with "/etc/init.d/ssh start" and it was working when i checked its status
so i tried to connect to my machine from another device using ssh and it did not connect with the right password.... after digging around i found out that setting permitrootlogin to yes was a probable workaround to this but that did not work either
after that i tried the public key method which didn't work either.

after that i stopped ssh and started it with "sudo service ssh start" and checking the status showed that it was working
i tried to connect again but showed that password is wrong.. and the publickey method didn't work either


i so purged ssh and openssh-server and all the files related to it.

i installed an older version of ssh from a debian repo before it required execution with absolute path, it successfully generated the config files and i was able to do everything with ssh and sshd
Steps To Reproducea fresh installation of kali linux (any version)
executing sshd and then executing with absolute path

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2022-01-05 08:03 naitikjoshi24 New Issue