View Issue Details

IDProjectCategoryView StatusLast Update
0007661Kali Linux[All Projects] General Bugpublic2022-04-11 03:31
Reportersoheilkhanalipur Assigned Toarnaudr  
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionnot fixable 
Product Version2022.1 
Target VersionFixed in Version 
Summary0007661: GNOME does not start after authentication
DescriptionGNOME does not work after I did "sudo apt update & sudo apt upgrade" today. [1]

Activities

soheilkhanalipur

2022-04-06 17:33

reporter  

Anonymoushcker

2022-04-06 18:38

reporter   ~0016007

Just use dconf reset -f /
This will make everything default
This is a bug when you try to open HDD this bug cause

Anonymoushcker

2022-04-06 18:40

reporter   ~0016008

Switch to xfce this will not happen again

arnaudr

2022-04-07 04:31

manager   ~0016009

When you're on the Oops screen, you should open a new tty, press <Ctrl+Alt+F1>. Then try again to update and to run FULL UPGRADE:

sudo apt update
sudo apt full-upgrade


There should be no error in the output, if there are errors please take a screenshot and paste here.

soheilkhanalipur

2022-04-07 07:58

reporter   ~0016012

@arnaudr Thanks for your help.
I have tried this command many times but the problem still exists.

soheilkhanalipur

2022-04-07 08:38

reporter   ~0016014

Please help me!!

arnaudr

2022-04-07 08:44

manager   ~0016015

Heya, well from this point, you should look at the logs (with command such as "journalctl -b"), find what's the error, and fix it. If you don't understand what you see in the logs, you can try to get help on https://forums.kali.org.

daniruiz

2022-04-07 09:27

manager   ~0016017

It might be caused by some of the updates for GNOME 42, but I didn't have any so far.
Open a new tty terminal, press <Ctrl+Alt+F1>, and run:

gsettings set org.gnome.shell disable-user-extensions true


Try upgrading the system too, like @arnaudr mentioned

soheilkhanalipur

2022-04-07 10:00

reporter   ~0016018

@daniruiz
I think so, but the command did not solve the problem, and when I entered the command with sudo, it gave an error. [1]

arnaudr

2022-04-08 02:29

manager   ~0016021

Don't use sudo. Here we want to modify settings for your user, so just run "gsettings set org.gnome.shell disable-user-extensions true" without using sudo.

soheilkhanalipur

2022-04-09 07:51

reporter   ~0016026

@arnaudr
I have tried it without sudo before, but the issue is still unresolved.
There seems to be inconsistencies in the update of some packages; For example, in the last update, the "nvidia-modprobe" package has a higher version of "nvidia-driver" (I do not know about Nvidia packaging, this is just a guess)

soheilkhanalipur

2022-04-09 07:57

reporter   ~0016027

I think this is a bug! Because this is an issue without previous action. More attention should be paid to this issue.

soheilkhanalipur

2022-04-09 17:59

reporter   ~0016031

More than two days that this issue has occurred to how many Kali users and no one takes steps to solve the problem?

kali-bugreport

2022-04-10 07:27

reporter   ~0016032

Over the last couple of days various users gave hints / suggestions how to solve this problem. If you're writing "no one takes steps to solve the problem" is quite offensive...

arnaudr

2022-04-11 03:28

manager   ~0016033

Hello again.

Just to make sure: on my side, I just installed Kali 2022.1 with GNOME desktop in a VM, and updated it to latest with "sudo apt update && sudo apt full-upgrade". No problem, everything works.

Just to be sure: we are always thankful when users report issues with Kali in the bugtracker. However not every bug report is something that we can fix. In this case, there's nothing we can do.

How to fix your broken install is on you. It's not super difficult, you need to look at the logs, find out what are the error(s), and fix it one way or another. If you can't do that yourself you can ask for help at https://forums.kali.org, but honestly it doesn't seem to be anything specific to Kali, it's more a general issue of "how to fix broken GNOME" and you might just look for a solution with your favorite search engine. Your first step is to identify the errors, your second step is to paste it in a search engine. Good luck.

I don't know *why* exactly GNOME broke down on your machine. GNOME will transition to version 42 soon, I *think* that some packages from v42 already entered Debian and Kali, maybe things went broken for a short while and you were unlucky to update at this time. But that's just one theory among others. In any case, it doesn't really matter. What matters is that 1) at the moment it's not broken in KALI as far as I can tell, and 2) your system is still broken, you need to fix it, but the Kali bugtracker is not the place for that.

So I'm closing this issue again, and wish you good luck in fixing your system.

Issue History

Date Modified Username Field Change
2022-04-06 17:33 soheilkhanalipur New Issue
2022-04-06 17:33 soheilkhanalipur File Added: IMG_20220406_220316_121.jpg
2022-04-06 18:38 Anonymoushcker Note Added: 0016007
2022-04-06 18:40 Anonymoushcker Note Added: 0016008
2022-04-07 04:31 arnaudr Note Added: 0016009
2022-04-07 07:58 soheilkhanalipur Note Added: 0016012
2022-04-07 08:38 soheilkhanalipur Note Added: 0016014
2022-04-07 08:44 arnaudr Note Added: 0016015
2022-04-07 09:27 daniruiz Note Added: 0016017
2022-04-07 10:00 soheilkhanalipur File Added: IMG_20220407_143028_343.jpg
2022-04-07 10:00 soheilkhanalipur Note Added: 0016018
2022-04-08 02:29 arnaudr Note Added: 0016021
2022-04-09 07:51 soheilkhanalipur Note Added: 0016026
2022-04-09 07:57 soheilkhanalipur Note Added: 0016027
2022-04-09 17:59 soheilkhanalipur Note Added: 0016031
2022-04-10 07:27 kali-bugreport Note Added: 0016032
2022-04-11 03:28 arnaudr Note Added: 0016033
2022-04-11 03:31 arnaudr Assigned To => arnaudr
2022-04-11 03:31 arnaudr Status new => closed
2022-04-11 03:31 arnaudr Resolution open => not fixable