View Issue Details

IDProjectCategoryView StatusLast Update
0007682Kali Linux[All Projects] General Bugpublic2022-05-31 08:40
Reporteralfredjoejr Assigned To 
Status newResolutionopen 
Product Version2022.1 
Target VersionFixed in Version 
Summary0007682: Wireless Keeps Disconnecting & Reconnecting In A Loop
DescriptionRecently, I updated my Kali Linux to the latest version along with the microcodes. Ever since then, the Wifi seems to be dropping. Also, the speed seems to be throttled due to the dropping. However, I checked the adaptor by booting into Windows. It's working fine there. I guess there's no issue with the hardware.

Steps To ReproduceSimply wait and the wifi keeps dropping automatically.

Wifi Info:
Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
    Subsystem: Foxconn International, Inc. QCA9565 / AR9565 Wireless Network Adapter
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 43
    Region 0: Memory at f0a00000 (64-bit, non-prefetchable) [size=512K]
    Expansion ROM at f0a80000 [disabled] [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: ath9k
    Kernel modules: ath9k
Additional InformationI've attached my log screenshot & the logs with this report.


has duplicate 0007723 closeddaniruiz Wireless Keeps Disconnecting & Reconnecting In A Loop 



2022-04-24 17:33


logs.tar.gz (215,563 bytes)
Screenshot from 2022-04-24 22-31-23.png (276,517 bytes)
Screenshot from 2022-04-24 22-31-31.png (295,147 bytes)


2022-04-26 21:47

manager   ~0016066

Could this be power management related? Could you try running `sudo ifconfig wlan0 power off` and see if that fixes it? If it does, you likely need to create a network manager configuration snippet that would disable power saving.


2022-04-27 07:54

reporter   ~0016067

@steev I tried this command but it's showing me an error. I tried, "sudo iwconfig wlan0 power off" .. & it showed that this operation isn't supported.


2022-04-27 21:48

manager   ~0016070

Is this an actual nethunter device, or is this a kali installation?


2022-04-28 06:25

reporter   ~0016071

@steev no no .. I just named it nethunter as the name looks cool.. Its actually a Bare Metal installation of Kali.


2022-05-02 15:12

reporter   ~0016100

UPDATE: I tried re-installing Kali ... And the wifi was working fine until I updated again!
Furthermore, I checked with other Linux Distros on my PC. There seems to be no problem with those.

My current version of Network-Manager is 1.36.4-2. I tried downgrading to a previous version (Bullseye) through the official Debian Package website. Still, I'm having the same issue.

But I'm quite sure this is caused after the upgrade. The download speed is extremely throttled.
When I do a speed test, the speedometer gets stuck for a few seconds and resumes again. I can see the Wifi icon go blank and come back.


2022-05-06 03:04

manager   ~0016118

Hey, I don't think we can help much, we can't really provide support for hardware issues. But if you have time to keep digging into this issue, here are a few recommendations:

> And the wifi was working fine until I updated again!

OK so you're on the right track. Now the question is: what packages were upgraded when you "updated again" ? Did you keep track of that? If not, you can have a look into the various files `/var/log/apt/history*`.

The way you describe the issue, I would bet on either Linux kernel or firmware. I don't think it has anything to do with Network Manager.

When you boot, can you choose to boot different versions of the Linux kernel? If so, try booting other kernels, and check if the issue is present only with some versions of the kernel.

Otherwise, and as usual, check the logs to see if the issue is visible in there. Open a terminal, run `journalctl -f` and leave it open. Check what comes up, and if you think you see your error in there, try to paste that in a search engine. If there was a regression in the kernel for your particular WifI device, chances are that you're not alone having the problem. Kali follows Debian testing/unstable, so Debian folks might have hit the issue already.

Good luck!


2022-05-06 08:36

reporter   ~0016127

UPDATE: I've successfully resolved the issue.

The problem seems to be in the Kernel of Linux.
My current version is 5.16.0-kali3-amd64.
I tried booting to 5.15.0-kali3-amd64 using the Advanced menu during startup. It actually worked.


2022-05-09 01:49

manager   ~0016133

You could also try to upgrade your Kali, at the moment in Kali rolling the Linux kernel is at version 5.16.18-1kali1. I'd be curious to know if your WiFi works with this version, please give it a try if you have a moment. Thanks!


2022-05-10 11:26

reporter   ~0016139

I've upgraded the kernel and the same problem came back.
However, this time I checked the other files which were updated along with another kernel.
I noticed nvidia-modprobe:amd64 was upgraded.
Downgraded the package to the older version and it seems the problem was resolved.

Not sure whether that's it


2022-05-13 15:43

manager   ~0016150

That's surprising, as nvidia-modprobe is for the graphics card... I don't really understand what's wrong here.


2022-05-24 16:37

reporter   ~0016215

It's surprising the CTRL-EVENT-BEACON-LOSS is coming in this Old Kernel too.

Issue History

Date Modified Username Field Change
2022-04-24 17:31 alfredjoejr New Issue
2022-04-24 17:33 alfredjoejr File Added: logs.tar.gz
2022-04-24 17:33 alfredjoejr File Added: Screenshot from 2022-04-24 20-27-42.png
2022-04-24 17:33 alfredjoejr File Added: Screenshot from 2022-04-24 20-27-57.png
2022-04-24 17:33 alfredjoejr File Added: Screenshot from 2022-04-24 22-31-23.png
2022-04-24 17:33 alfredjoejr File Added: Screenshot from 2022-04-24 22-31-31.png
2022-04-26 21:47 steev Note Added: 0016066
2022-04-27 07:54 alfredjoejr File Added: Screenshot from 2022-04-27 13-22-35.png
2022-04-27 07:54 alfredjoejr Note Added: 0016067
2022-04-27 21:48 steev Note Added: 0016070
2022-04-28 06:25 alfredjoejr Note Added: 0016071
2022-05-02 15:12 alfredjoejr Note Added: 0016100
2022-05-06 03:04 arnaudr Note Added: 0016118
2022-05-06 08:36 alfredjoejr Note Added: 0016127
2022-05-09 01:49 arnaudr Note Added: 0016133
2022-05-10 11:26 alfredjoejr Note Added: 0016139
2022-05-13 15:43 arnaudr Note Added: 0016150
2022-05-21 05:35 neyoojhony Issue cloned: 0007723
2022-05-24 16:37 alfredjoejr Note Added: 0016215
2022-05-31 08:40 daniruiz Relationship added has duplicate 0007723