View Issue Details

IDProjectCategoryView StatusLast Update
0007684Kali Linux[All Projects] General Bugpublic2022-06-10 01:33
Reportertempresidence Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version2022.1 
Target VersionFixed in Version 
Summary0007684: The keyboard cannot switch between virtual machines and hosts at the same time
DescriptionWhen kali linux is installed in a wmware virtual machine running the Win11 operating system, the keyboard can only work in one of the virtual machines or the host, but it works fine in Win10 and other Linux distributions,and the mouse works fine
Hardware:
CPU 12700
motherboard ASUS TUF GAMING B660M-PLUS WIFI D4
RAM kingston HyperX Savage DDR4 2133 (runing on XMP 3000 gear2)
software:
windows11 21H2 22000.613
wmware 16.2.3 build-19376536
kali Virtual Machines images Kali Rolling (2022.1) x64 2022-02-10
same problems in https://forums.kali.org/showthread.php?66894-kali-vmware-keyboard&highlight=keyboard

Activities

steev

2022-04-26 21:44

manager   ~0016065

Sorry, I'm not quite understanding what you mean by it only works in one or the other but not both? Unfortunately, I don't know if anyone on the team is running Windows 11 as a host with VMWare installed in order to reproduce this issue.

tempresidence

2022-04-27 08:53

reporter   ~0016068

Normally, when you use Wmware you don't need to consider manually switching (connecting or disconnecting from the host) the keyboard and mouse between the host and the virtual machine, but when you run Kali Linux in the environment I mentioned before you will have to manually assign the keyboard to run in the virtual machine, after doing so the host can no longer use the keyboard until you manually switch it to the host

steev

2022-04-27 17:02

manager   ~0016069

And you have the virtual machine tools installed? open-vm-tools-desktop and so forth? Does this only occur with Kali or with any Linux virtual machines where Windows 11 is the host?

tempresidence

2022-04-28 08:21

reporter   ~0016072

Yes, I have tried both open-vm-tools-desktop and WMtools, but the problem still persists. What's confusing is that the bug goes away when you install open-vm-tools or WMtools and don't restart the system, and then the problem reappears when you restart the system.
 I've tested Ubuntu and Kali so far, but not any OS other than Windows 11.

arnaudr

2022-05-06 03:58

manager   ~0016122

It's still not clear to me if the problem is due to open-vm-tools or not. Can you try to uninstall it from the machine, by running:

sudo apt remove open-vm-tools-desktop open-vm-tools


Then restart the VM.

if the issue is still there, then try re-installing it:

sudo apt update
sudo apt install open-vm-tools-desktop open-vm-tools


Then restart the VM.

If the issue is still there, maybe try to look at the status of services provided by open-vm-tools:

systemctl status open-vm-tools.service
systemctl status vgauth.service


Please paste here anything that seems relevant so that we can investigate the issue. Thanks!

arnaudr

2022-05-09 02:11

manager   ~0016135

Someone reported a similar issue at https://bugs.kali.org/view.php?id=7695, and it seems to be solved with the latest version of open-vm-tools. Please make sure your Kali system is up to date and has the latest version of the package open-vm-tools (should be version 2:12.0.0-1). Please report back here if it solves the issue, that would be much appreciated. Thanks!

tempresidence

2022-05-15 08:25

reporter   ~0016154

I'm very sorry I haven't used kali for a while. i tried to upgrade my open-vm-tools as mentioned in https://bugs.kali.org/view.php?id=7695 but the problem is still there
┌──(kali㉿kali)-[~/Desktop]
└─$ dpkg -l | grep open-vm-tools
ii open-vm-tools 2:12.0.0-2 amd64 Open VMware Tools for virtual machines hosted on VMware (CLI)
ii open-vm-tools-desktop 2:12.0.0-2 amd64 Open VMware Tools for virtual machines hosted on VMware (GUI)

rohitkumarankam

2022-05-17 16:19

reporter   ~0016157

hello, I'm the reporter of Issue https://bugs.kali.org/view.php?id=7695
In my case keyboard working properly on the host system (Windows 11) and the keyboard is not working in VM (kali in VMware workstation pro).
This issue is solved by upgrading my kali vm with "sudo apt update && sudo apt upgrade -y"
so try upgrading the kali.

tempresidence

2022-06-10 01:33

reporter   ~0016250

I'm sorry I haven't used kali Linux for a while

I tried the solution provided by @rohitkumarankam but it still happened Finally I switched my VM platform to virtualbox and it is working fine (but I prefer to use wmware) I hope to switch to wmware again when the problem is completely solved Thank you all for your help

Issue History

Date Modified Username Field Change
2022-04-26 11:41 tempresidence New Issue
2022-04-26 21:44 steev Note Added: 0016065
2022-04-27 08:53 tempresidence Note Added: 0016068
2022-04-27 17:02 steev Note Added: 0016069
2022-04-28 08:21 tempresidence Note Added: 0016072
2022-05-06 03:58 arnaudr Note Added: 0016122
2022-05-09 02:11 arnaudr Note Added: 0016135
2022-05-15 08:25 tempresidence Note Added: 0016154
2022-05-17 16:19 rohitkumarankam Note Added: 0016157
2022-06-10 01:33 tempresidence Note Added: 0016250