View Issue Details

IDProjectCategoryView StatusLast Update
0007725Kali Linux[All Projects] Kali Package Bugpublic2022-05-23 07:09
Reporterneyoojhony Assigned Todaniruiz  
PrioritylowSeveritytrivialReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version2022.2 
Target VersionFixed in Version 
Summary0007725: [Kali Live Latest] - raspi-firmware is installed but I'm not on Raspberry Pi
DescriptionHi !
I installed Kali LIve on a usb stick, and I apt-updated/upgraded all the packages. At the end, there was an error showing that :

Errors were encountered while processing:
 raspi-firmware
E: Sub-process /usr/bin/dpkg returned an error code (1)

Is this a normal behavior of Kali to have Raspi's firmware updater pre-installed ? Kali Live should not interact with the system, or upgrading the Pi's firmware is interacting with the system. I think this shouldn't be there, is this a mistake ?
Steps To ReproduceInstall Kali Live 2022.2 on a USB stick, then upgrade all the packages.

Relationships

duplicate of 0007720 closeddaniruiz [Kali Live Latest] - raspi-firmware is installed but I'm not on Raspberry Pi 

Activities

steev

2022-05-20 17:46

manager   ~0016196

Last edited: 2022-05-20 17:47

What machine are you running this on?

You are correct that raspi-firmware should only be used on a raspberrypi, but we don't use it in kali at all, it's a package from Debian that is in the repositories. I don't see it in the meta packages so I'm not sure why it is installed there. Which live usb are you using?

It's probably erroring out because it can't copy the firmware into /boot/firmware - a workaround would be to create that directory temporarily.

Issue History

Date Modified Username Field Change
2022-05-21 05:35 neyoojhony New Issue
2022-05-21 05:35 neyoojhony Issue generated from: 0007720
2022-05-23 07:09 daniruiz Assigned To => daniruiz
2022-05-23 07:09 daniruiz Status new => closed
2022-05-23 07:09 daniruiz Resolution open => duplicate
2022-05-23 07:09 daniruiz Relationship added duplicate of 0007720