View Issue Details

IDProjectCategoryView StatusLast Update
0007720Kali Linux[All Projects] Kali Package Bugpublic2022-05-23 16:32
Reportertr88hak Assigned Todaniruiz  
PrioritylowSeveritytrivialReproducibilityhave not tried
Status closedResolutionno change required 
Product Version2022.2 
Target VersionFixed in Version 
Summary0007720: [Kali Live Latest] - raspi-firmware is installed but I'm not on Raspberry Pi
DescriptionHi !
I installed Kali LIve on a usb stick, and I apt-updated/upgraded all the packages. At the end, there was an error showing that :

Errors were encountered while processing:
 raspi-firmware
E: Sub-process /usr/bin/dpkg returned an error code (1)

Is this a normal behavior of Kali to have Raspi's firmware updater pre-installed ? Kali Live should not interact with the system, or upgrading the Pi's firmware is interacting with the system. I think this shouldn't be there, is this a mistake ?
Steps To ReproduceInstall Kali Live 2022.2 on a USB stick, then upgrade all the packages.

Relationships

has duplicate 0007725 closeddaniruiz [Kali Live Latest] - raspi-firmware is installed but I'm not on Raspberry Pi 

Activities

steev

2022-05-20 17:46

manager   ~0016182

Last edited: 2022-05-20 17:47

View 2 revisions

What machine are you running this on?

You are correct that raspi-firmware should only be used on a raspberrypi, but we don't use it in kali at all, it's a package from Debian that is in the repositories. I don't see it in the meta packages so I'm not sure why it is installed there. Which live usb are you using?

It's probably erroring out because it can't copy the firmware into /boot/firmware - a workaround would be to create that directory temporarily.

tr88hak

2022-05-22 17:58

reporter   ~0016208

That's Kali Live 2022.2, freshly installed on a 64bit laptop on a USB stick. IDK what metapackages were installed (i don't have the USB key anymore, btw) but that's the main/general release. I just did "sudo apt update" then "sudo apt upgrade", then it showed this error.

daniruiz

2022-05-23 11:31

manager   ~0016212

I've checked the live image and an installed kali I can confirm that raspi-firmware comes preinstalled. I guess it's added by the debian-installer package, as we don't add it in any metapackage

daniruiz

2022-05-23 15:39

manager   ~0016213

Heya.
Yes, we checked it and seems like the live image installs all the available firmware packages for the architecture, as it might be used with all kinds of hardware. The odd part is that raspi-firmware package (which comes from debian) changed from arm only support to "all" (https://tracker.debian.org/pkg/raspi-firmware check "arch: all"), so that's the reason why it gets added to the live image, even in x86 installations.
Then if you install kali from the live image you will get the exact same packages as the ones in the live usb.

Seems weird, but that's a change from Debian, so there might be a good reason.

steev

2022-05-23 16:32

manager   ~0016214

Just a quick follow up, you don't need the package, so you can purge it from your system with `sudo apt purge --autoremove raspi-firmware` - and since we don't actually use that package in kali, we are removing it from being mirrored so that this doesn't happen in the future.

It was added as "arch: all" as it's just firmware data and there is no need to have 3 separate packages that are bit-identical.

Issue History

Date Modified Username Field Change
2022-05-19 19:24 tr88hak New Issue
2022-05-20 17:46 steev Note Added: 0016182
2022-05-20 17:47 steev Note Edited: 0016182 View Revisions
2022-05-21 05:35 neyoojhony Issue cloned: 0007725
2022-05-22 17:58 tr88hak Note Added: 0016208
2022-05-23 07:09 daniruiz Relationship added has duplicate 0007725
2022-05-23 11:31 daniruiz Note Added: 0016212
2022-05-23 15:39 daniruiz Note Added: 0016213
2022-05-23 15:39 daniruiz Assigned To => daniruiz
2022-05-23 15:39 daniruiz Status new => closed
2022-05-23 15:39 daniruiz Resolution open => no change required
2022-05-23 16:32 steev Note Added: 0016214