View Issue Details

IDProjectCategoryView StatusLast Update
0007926Kali Linux[All Projects] Kali Package Bugpublic2022-09-28 20:37
Reporterbaikal.2002 Assigned Tosbrun  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2022.3 
Target VersionFixed in Version 
Summary0007926: Unable to log in to greenbone after full upgrade and reboot
DescriptionPerformed apt-get update && apt-get full-upgrade and rebooted. Was logged in to greenbone prior to reboot. After the reboot all attempts to log in result in failure with message: Login Failed. Invalid password or username.

Changing the password with gvmd does not result in successful login. Attempts to create a new admin user using gvmd fail with message: Failed to create user: Invalid characters in user name. Other gvmd commands to return roles and users work without issue.

Relationships

has duplicate 0007931 closedsbrun GVM installation can't be completed 
has duplicate 0007932 closedsbrun CANNOT LOGIN IN GVM - CANNOT CREATE NEW USER/UPDATE USER 

Activities

ethanb

2022-09-17 17:03

reporter   ~0016729

I am having similar issues here. Tried the following commands unsuccessfully as well
sudo runuser -u gvm –- gvmd --create-user=admin --new-password=“newpasswordhere”
sudo runuser -u gvm –- gvmd --create-user=admin --new-password='newpasswordhere'
sudo runuser -u gvm –- gvmd --create-user=admin --new-password=newpasswordhere
sudo runuser -u gvm –- gvmd --create-user="admin" --new-password=“newpasswordhere”
sudo runuser -u gvm –- gvmd --create-user='admin' --new-password='newpasswordhere'
sudo runuser -u gvm –- gvmd --create-user=admin --new-password=newpasswordhere
even with the single - before gvm ddidn't work at all.

Also the following is not working too
gvmd --user=admin --new-password=newpassword

baikal.2002

2022-09-17 20:45

reporter   ~0016730

When using gvmd to change a user password I can see the value changes in the database but the web UI will not log in with the new password.

ethanb

2022-09-18 15:03

reporter   ~0016735

I've performed a clean fresh install of kali 2022.3. After the fresh installation is complete, I did a sudo apt update && sudo apt full-upgrade. Once the upgrade is finished, I setup gvm again and I noticed at the completion of the setup, there is no password created at all.

baikal.2002

2022-09-19 14:45

reporter   ~0016739

Created new VM, installed 2022.3, update and full-upgrade, installed gvm. Ran gvm-setup. When it attempts to crete the admin user the error "Failed to create user: Invalid characters in user name" is thrown. Attempts to create another admin user fail with the same message. gvmd --get-users shows no users. gvmd --get-roles shows seven roles.

grisutheguru

2022-09-19 16:13

reporter   ~0016740

monitored /var/log/gvm/gsad.log:
gsad main:MESSAGE:[DATE] Starting GSAD version 21.4.4
gsad gap:WARNING: [DATE] Authentication failure fro '' from 127.0.0.1

gsad was not changed during last update of kali, but what was that is causing this error?

cosminidis

2022-09-19 16:22

reporter   ~0016741

I'm having the exact same problem on an old install that’s been running for years, after applying the updates from a couple of days before.
The webgui sends an empty string instead of the username, throwing an “Authentication failure for ‘’ from x.x.x.x” warning in /var/log/gvm/gsad.log. Note the '' in the error (empty string between single quotes).
Trying to create a new user fails with "illegal characters in user name", no matter the username.
Apparently, the strings aren't treated correctly, like double quoting or something.

KDan

2022-09-19 18:28

reporter   ~0016744

same here after update of kali linux and reboot greenbone login do not recognize the right id and password...absurd.
cannot understand how to solve...wtf...I have 80 scann there and need to use it

KDan

2022-09-19 22:23

reporter   ~0016745

maybe this could help it seems the same issue solved with postgresql one year ago I'll try it tomorrow


https://bugs.kali.org/view.php?id=6764

baikal.2002

2022-09-19 23:52

reporter   ~0016746

Does not appear to be related to postgres clusters as a new install fails like an existing upgraded installation,
Output of pg_lsclusters on new and old:

Ver Cluster Port Status Owner Data directory Log file
14 main 5432 online postgres /var/lib/postgresql/14/main /var/log/postgresql/postgresql-14-main.log

baikal.2002

2022-09-20 00:20

reporter   ~0016747

Seting log level to debug for gsad shows that password matches in gvm_validate but username does not.

baikal.2002

2022-09-20 00:31

reporter   ~0016748

Log snippet won't upload regex that attempt to match username from gsad.log
Matching <^[[:alnum:]-_@.]+$> against <admin>:

baikal.2002

2022-09-20 00:40

reporter   ~0016749

gvm-cli is able to log in and retrieve tasks

sudo runuser -u _gvm -- gvm-cli --gmp-username admin --gmp-password itsasecret socket --xml "<get_tasks/>"

grisutheguru

2022-09-20 06:06

reporter   ~0016750

I can support baikal’s notes, tried that myself yesterday with the same results.
The root seems to be in gsad and one of the components.
Assumed find it in microhttpd, but it was updated one month ago and not during the last days.

securitylearner

2022-09-20 06:43

reporter   ~0016751

I did everything to solve the problem all day yesterday and I also asked the stackoverflow with all the details:
https://stackoverflow.com/questions/73771170/no-users-found-openvasgvm-setup-error
Today is the same. I am trying to setup also on ubuntu, there are other tons of problems there.

cosminidis

2022-09-20 06:50

reporter   ~0016753

There is a thread in the Greenbone forum related to this exact issue:
https://forum.greenbone.net/t/kali-cant-create-gvm-user-throws-an-error-failed-to-create-user-invalid-characters-in-user-name/13062/38

Someone suggested the culprit might be in glib, but I would expect a lot more to break down from such a bug, not just GVM.

securitylearner

2022-09-20 06:57

reporter   ~0016754

I also posted in the Greenbone with the detail. They directed to here. It is related to Kali for sure.
https://forum.greenbone.net/t/no-users-found-gvm-setup-on-kali-linux/13073

securitylearner

2022-09-20 07:53

reporter   ~0016755

If you need urgent like me, I think the only solution is to install old releases o kali. http://old.kali.org/kali-images/ They said 2022.2 is ok, try it.

leontiosp

2022-09-20 08:56

reporter   ~0016756

The thing is that we CAN NOT WORK; as simple as that...

securitylearner

2022-09-20 09:27

reporter   ~0016757

I installed 2022.2 on VirtualBox and just did apt-get update -y, not upgrade.
Then apt install openvas, gvm-setup, gvm-feed-update. At this point, I was able to access via browser and in the browser web GUI> Administrator - Feed status should be completed because it is also updating there and then it is good to go!

KDan

2022-09-20 10:29

reporter   ~0016758

but U lost your previous work (tasks etc)?
I need to have access to 80 scanner locked for this absurd issue
tried also from another computer configuring the ip everything goes but the login

KDan

2022-09-20 10:41

reporter   ~0016759

I have reinstalled on kali 22.3 and gvm work login also there but with new install.....how Can I recap my scann...from the other account?

sbrun

2022-09-20 12:18

manager   ~0016760

Thanks the report

I confirm the issue.
It seems to be caused by the package libglib2.0-0 version 2.73.3-3. If I re-installed the previous version 2.72.3-1, it fixes the issue. To re-install the old version is not a valid fix (it removes several packages depending on the latest version and it may create other issues).

I will work on a real fix.

KDan

2022-09-20 12:36

reporter   ~0016761

new issue I have reinstall from zero gvm in wmn kali 22.2 intallation is ok but no scanner in it, same on kali for raspberry pi
check setup tell everything is. ok but in both version thhis problem comes of without a cause wtf hours and hours lost on it

sbrun

2022-09-20 13:56

manager   ~0016762

I was hoping that the new version 2.74.0 (already packaged in Debian Unstable) would fix the issue, but it doesn't.

I reported the issue to upstream:
https://gitlab.gnome.org/GNOME/glib/-/issues/2760

leontiosp

2022-09-20 13:57

reporter   ~0016763

Thanks for your efforts!

sbrun

2022-09-20 17:03

manager   ~0016764

I have just uploaded a fixed version of gvmd (21.4.5-1kali1). It will be available soon.

baikal.2002

2022-09-20 19:20

reporter   ~0016765

@sbrun Awesome. Thanks.

ethanb

2022-09-21 03:40

reporter   ~0016766

@sbrun, thanks! I'll check it out!

grisutheguru

2022-09-21 05:00

reporter   ~0016768

@sbrun Tried it this morning after it was available, I sorry that I have to say, that it did not fix the issue.

sbrun

2022-09-21 06:01

manager   ~0016769

@grisutheguru I tested the new version and I was able to create new users, change passwords without issues.
Can you give me details about the commands you run ?

leontiosp

2022-09-21 06:05

reporter   ~0016770

Hello sbrun and thank you again for your efforts. Does the new version work normally with the existing admin pass?

sbrun

2022-09-21 06:34

manager   ~0016771

I don't have an "old" installation of gvm to test if it works with the existing admin pass but I think it works: the patch only concerns a format check of the username.

sbrun

2022-09-21 06:40

manager   ~0016774

@grisutheguru maybe you should try to restart gvmd.service

payne1988

2022-09-21 07:18

reporter   ~0016775

Hi,

same issue here. i updated the application. I can reset the password and create new users but cannot login to Web.

grisutheguru

2022-09-21 07:30

reporter   ~0016776

@sbrun: I did full reboot to be on the safe side

grisutheguru

2022-09-21 07:39

reporter   ~0016777

What I did:
apt update
apt -y full-upgrade
reboot

gvm-start

tried to log in —> failed
tail -f /var/log/gvm/gsad.log —> showed that error message as it was before with ‘’ as username

sudo -runuser _gvm — gvmd —user=grisu —new-password=************

restarted gvmd

tried to log in: failed, checked logs, same entry as before

mysisteronthebeach

2022-09-21 09:33

reporter   ~0016778

Hi,

same issue here...

sbrun

2022-09-21 11:11

manager   ~0016779

FWIW: the login issue is also caused by the new liglib2.0.

baikal.2002

2022-09-21 13:22

reporter   ~0016782

LIke others I'm still unable to log in through the web UI after update, full-upgrade, and reboot. The same regex + authentication failure appears in the gsad log

matching <^[[:alnum:]-_@.]+$> against <admin>:
gvm_validate: failed to match
Authentication failure for '' from 192.168.168.16

dpkg -l gvm*
ii gvm 21.4.4~kali1 all remote network security auditor - metapackage and useful scripts
ii gvm-tools 22.6.0-1 all Remote control the Greenbone Vulnerability Manager
ii gvmd 21.4.5-1kali1 amd64 Manager Module of Greenbone Vulnerability Manager
ii gvmd-common 21.4.5-1kali1 all architecture independent files for Greenbone Vulnerability Manager

leontiosp

2022-09-21 13:52

reporter   ~0016783

Copying for GVM forum:
- GLib seems to throw a warning / error on such incompatible regex calls after gregex: Use pcre2 error messages if we don't provide a specific one (!2913) · Merge requests · GNOME / GLib · GitLab has been released so that such incompatibilities are more visible.
- In Kali it seems that the regex was now made PCRE2 compatible via a newly published patch: 0007926: Unable to log in to greenbone after full upgrade and reboot - Kali Linux Bug Tracker.

sbrun

2022-09-21 14:01

manager   ~0016784

I uploaded gsad version 21.4.4-1kali1 (same cause and same regex issue as fixed in gvmd)

Please install the latest version of gsad.

payne1988

2022-09-21 14:02

reporter   ~0016785

Hi,
i updated but now web not working :(

ERR_CONNECTION_REFUSED

baikal.2002

2022-09-21 14:10

reporter   ~0016786

@sbrun Ability to login restored with gsad update. Thanks. :fireworks:

leontiosp

2022-09-21 14:17

reporter   ~0016787

So, I just update - upgrade KALI and everything works fine?

baikal.2002

2022-09-21 14:19

reporter   ~0016788

@leontiosp I did
sudo apt-get update && sudo apt-get full-upgrade -y ; sudo systemctl restart gsad.service

payne1988

2022-09-21 14:24

reporter   ~0016789

Thanks! Now Working!

cosminidis

2022-09-21 14:41

reporter   ~0016790

Dude! You rulez! All is working now, thanks for the quick resolution!

leontiosp

2022-09-21 14:55

reporter   ~0016791

Unfortunately, my system doesn't login.
I did sudo apt-get update && sudo apt-get full-upgrade -y
NUT neither the saved Admin password or the new user I created doesn't make it through :(

leontiosp

2022-09-21 15:09

reporter   ~0016792

NOT only my existing Admin password VALIDATES, but also the new user I created won't pass through:

sudo runuser -u _gvm -- gvmd --create-user=PL --new-password=pl1314362021
User created with password '21ce23bf-c071-485a-a472-6b2a0e0365a5'.

sudo runuser -u _gvm -- gvmd --create-user=PL1 --new-password=new_password
User created with password '8805fcf2-f9bf-4fd8-b058-158b2ad8d214'.

For instance:
User: PL1
Pass: 8805fcf2-f9bf-4fd8-b058-158b2ad8d214
NOT WORKING

Any ideas?

Thanks...

sbrun

2022-09-21 15:29

manager   ~0016793

@leontiosp please first check that you have the latest gsad installed:

dpkg -s gsad

You need version 21.4.4-1kali1.

If you have the version 21.4.4-1kali1, please check the log of gsad: /var/log/gvm/gsad.log

If needed, you can have more info in the log by changing the config log /etc/gvm/gsad_log.conf. You can change the level, see /usr/share/doc/gsad/README.md.gz. If you change the "level", I think you will have to restart gsad.service to apply the changes.

leontiosp

2022-09-21 15:41

reporter   ~0016794

First of all, thank you for your response.

My gsad version (although I did full update - upgrade of KALI) is: 21.4.4-0kali4 and NOT 21.4.4-1kali1.

How do I get the right version?

baikal.2002

2022-09-21 16:26

reporter   ~0016795

http.kali.org/kali/pool/main/g/gsad/gsad_21.4.4-1kali1_amd64.deb
dpkg -i gsad_21.4.4-1kali1_amd64.deb

leontiosp

2022-09-21 17:40

reporter   ~0016796

Thank you for your help!
However, the right version came with the latest update - upgrade its self!

The login WORKED eventually.

I managed to get in.

BUT there is problem with gsad service ...

the check setup wrote:
ERROR: gsad service did not start.
        Please check journalctl -xe and /var/log/gvm/gsad.log

grisutheguru

2022-09-21 18:16

reporter   ~0016797

Just a single line from /var/log/gvm/gsad.log as asnwer:

gsad gmp:MESSAGE:2022-09-21 18h12.18 utc:1844: Authentication success for 'grisu' from 127.0.0.1

thanks a lot!

unretired

2022-09-21 19:23

reporter   ~0016798

Thanks so much- i'm in.
"sudo apt update" and "sudo dist-upgrade" grabbed your new file 21.4.4-1kali1 and updated my system perfectly.

gcovain

2022-09-22 09:36

reporter   ~0016800

Thanks for the fix @sbrun !

leontiosp

2022-09-24 06:26

reporter   ~0016820

Thank you!!! Everything is OK now...

securitylearner

2022-09-27 06:51

reporter   ~0016829

I am able to create a user and gvm-check-setup gives no error! Bravo, thank you!

g0tmi1k

2022-09-28 20:37

administrator   ~0016850

Sounds like its all sorted - closing!

Issue History

Date Modified Username Field Change
2022-09-16 21:42 baikal.2002 New Issue
2022-09-17 17:03 ethanb Note Added: 0016729
2022-09-17 20:45 baikal.2002 Note Added: 0016730
2022-09-18 15:03 ethanb Note Added: 0016735
2022-09-19 14:45 baikal.2002 Note Added: 0016739
2022-09-19 16:13 grisutheguru Note Added: 0016740
2022-09-19 16:22 cosminidis Note Added: 0016741
2022-09-19 18:28 KDan Note Added: 0016744
2022-09-19 22:23 KDan Note Added: 0016745
2022-09-19 23:52 baikal.2002 Note Added: 0016746
2022-09-20 00:20 baikal.2002 Note Added: 0016747
2022-09-20 00:31 baikal.2002 Note Added: 0016748
2022-09-20 00:40 baikal.2002 Note Added: 0016749
2022-09-20 06:06 grisutheguru Note Added: 0016750
2022-09-20 06:43 securitylearner Note Added: 0016751
2022-09-20 06:50 cosminidis Note Added: 0016753
2022-09-20 06:57 securitylearner Note Added: 0016754
2022-09-20 07:53 securitylearner Note Added: 0016755
2022-09-20 08:56 leontiosp Note Added: 0016756
2022-09-20 09:27 securitylearner Note Added: 0016757
2022-09-20 10:29 KDan Note Added: 0016758
2022-09-20 10:41 KDan Note Added: 0016759
2022-09-20 12:18 sbrun Note Added: 0016760
2022-09-20 12:36 KDan Note Added: 0016761
2022-09-20 13:56 sbrun Note Added: 0016762
2022-09-20 13:57 leontiosp Note Added: 0016763
2022-09-20 17:03 sbrun Note Added: 0016764
2022-09-20 19:20 baikal.2002 Note Added: 0016765
2022-09-21 03:40 ethanb Note Added: 0016766
2022-09-21 05:00 grisutheguru Note Added: 0016768
2022-09-21 06:01 sbrun Note Added: 0016769
2022-09-21 06:05 leontiosp Note Added: 0016770
2022-09-21 06:29 sbrun Assigned To => sbrun
2022-09-21 06:29 sbrun Status new => assigned
2022-09-21 06:29 sbrun Status assigned => confirmed
2022-09-21 06:34 sbrun Note Added: 0016771
2022-09-21 06:35 sbrun Relationship added has duplicate 0007931
2022-09-21 06:37 sbrun Relationship added has duplicate 0007932
2022-09-21 06:40 sbrun Note Added: 0016774
2022-09-21 07:18 payne1988 Note Added: 0016775
2022-09-21 07:30 grisutheguru Note Added: 0016776
2022-09-21 07:39 grisutheguru Note Added: 0016777
2022-09-21 09:33 mysisteronthebeach Note Added: 0016778
2022-09-21 11:11 sbrun Note Added: 0016779
2022-09-21 13:22 baikal.2002 Note Added: 0016782
2022-09-21 13:52 leontiosp Note Added: 0016783
2022-09-21 14:01 sbrun Note Added: 0016784
2022-09-21 14:02 payne1988 Note Added: 0016785
2022-09-21 14:10 baikal.2002 Note Added: 0016786
2022-09-21 14:17 leontiosp Note Added: 0016787
2022-09-21 14:19 baikal.2002 Note Added: 0016788
2022-09-21 14:24 payne1988 Note Added: 0016789
2022-09-21 14:41 cosminidis Note Added: 0016790
2022-09-21 14:55 leontiosp Note Added: 0016791
2022-09-21 15:09 leontiosp Note Added: 0016792
2022-09-21 15:29 sbrun Note Added: 0016793
2022-09-21 15:41 leontiosp Note Added: 0016794
2022-09-21 16:26 baikal.2002 Note Added: 0016795
2022-09-21 17:40 leontiosp Note Added: 0016796
2022-09-21 18:16 grisutheguru Note Added: 0016797
2022-09-21 19:23 unretired Note Added: 0016798
2022-09-22 09:36 gcovain Note Added: 0016800
2022-09-24 06:26 leontiosp Note Added: 0016820
2022-09-27 06:51 securitylearner Note Added: 0016829
2022-09-28 20:37 g0tmi1k Note Added: 0016850
2022-09-28 20:37 g0tmi1k Status confirmed => closed
2022-09-28 20:37 g0tmi1k Resolution open => fixed