View Issue Details

IDProjectCategoryView StatusLast Update
0008058Kali Linux[All Projects] General Bugpublic2022-11-16 20:58
ReporterRapt0r Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version2022.3 
Target VersionFixed in Version 
Summary0008058: Either I power down my nvidia laptop gpu or i lose the ability to change the brightness of my laptop screen
DescriptionI have an issue on my laptop where i use Bumblebee and bbswitch to power down my Nvidia GPU when not in use and thus saving me more battery power. This took some time and i eventually managed to do it - my main problem was unloading the nvidia module because it was always in in use be xorg but i finally fixed this and made the relevant update to my grub menu (I have attached my grub file for you to view). It works great and the lines that make this possible are "nomodeset i915.modeset=0". - with these nvidia can be unloaded properly and bumblebee works.
However, with these two words i am also unable to change this brightness of my laptop screen - in fact all the display brightness sliders have disappeared and commandline tools like "xranr", "brightnessctrl" and "xbacklight" do not work as they cannot detect anything anymore. Even the laptop keys for adjusting the brightness do not work anymore.


For example if i run xbacklight in a terminal i get:
"No outputs have backlight property"

If i run xrandr:
"Failed to get size of gamma for output default"

On the other hand if i remove the two words nomodeset i915.modeset=0" from my grub then i am able to use all them tools properly and the brightness sliders return to normal and the laptop keys for adjusting the brightness now work again BUT bumblebee will not unload the nvidia module to power down my GPU.

These are the two words i have found after over a week of troubleshooting with bumblebee to make it work, nothing i have tried so far has worked but these did but doing so i lose the ability to change my screen brightness at all

Please help
Steps To ReproduceKeeping and removing nomodeset i915.modeset=0" from my grub menu will either:

Keeping it will = make bumblebee work and completely removes the ability to adjust the brightness of laptop screen

Removing it will = make bumblebee not work as unable to power down gpu and makes all the screen brightness sliders and settings work correctly
Additional InformationI have the latest version of kali (as of 16/11/22) and these are the only issues i am having. Everything worked fine before the kernel upgrade and after the upgrade that's when i had reinstall and now have run into these issue i haven't come across before

Activities

Rapt0r

2022-11-16 20:58

reporter  

grub (1,684 bytes)
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=! acpi_osi='!Windows 2015' pcie_port_pm=off i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 nmi_watchdog=0 acpi_backlight=vendor video.use_native_backlight=1 rd.driver.blacklist=nvidia modprobe.blacklist=nvidia,nvidia,nvidia_drm,nvidia_modeset,nvidia_uvm"
GRUB_CMDLINE_LINUX="modprobe.blacklist=nvidia,nvidia,nvidia_drm,nvidia_modeset,nvidia_uvm nomodeset i915.modeset=0 nouveau.modeset=0"

# Uncomment this to run os-prober to search for and add other OS
# installations to the grub boot menu
#GRUB_DISABLE_OS_PROBER=false

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
grub (1,684 bytes)

Issue History

Date Modified Username Field Change
2022-11-16 20:58 Rapt0r New Issue
2022-11-16 20:58 Rapt0r File Added: grub