View Issue Details

IDProjectCategoryView StatusLast Update
0008068Kali LinuxKali Package Improvementpublic2023-05-31 14:57
Reporterjim5369 Assigned To 
Status closedResolutionopen 
Product Version2022.3 
Summary0008068: can't install postgresql-15 or uninstall postgresql-14

This is to be read in conjunction with error report 0008067

Steps To Reproduce

started Kali 2022.3 and used this update procedure apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y. This took a while to finish but I got the same error message Obsolete major version 14 as shown in error message 0008067. When I tried either installing postgresql-15 or uninstalling postgresql-14. I got a message as per the attached screen image. I run this and it came back with the same error message Obsolete major version 14. The message was. Run dpkg --configure -a I do and it comes back with the Obsolete Major issue problem. I can't install or uninstall any postgresql and I can' even remove from the path

Additional Information

This is quite a significant error and it should have been remedied before the release of 2022.3. I believe the fault is the server.

Attached Files




2022-11-25 08:47

manager   ~0017092

This is not an error but an (unfortunately unclear) informative message to let you know that postgresql 15 has been installed and when an upgrade comes in, it does not upgrade the databases automatically, and you have to do it manually by following the documentation that is mentioned in the message.

Once you’ve upgraded the databases, you can (as the message says), remove the postgresql packages that are version 14 that are left installed.



2022-11-25 10:50

reporter   ~0017093

steev I used dpkg -l | grep postgres and the screen shot it what I get there is no postgresql15 installed



2023-05-31 14:57

administrator   ~0018121

This report has been filed against an old version of Kali. We will be closing this ticket due to inactivity.

Please could you see if you are able to replicate this issue with the latest version of Kali Linux (

If you are still facing the same problem, feel free to re-open the ticket. If you choose to do this, could you provide more information to the issue you are facing, and also give information about your setup?
For more information, please read:

Issue History

Date Modified Username Field Change
2022-11-25 08:43 jim5369 New Issue
2022-11-25 08:47 steev Note Added: 0017092
2022-11-25 10:50 jim5369 File Added: Screenshot_2022-11-25_21-31-23.jpg
2022-11-25 10:50 jim5369 Note Added: 0017093
2023-05-31 14:57 g0tmi1k Note Added: 0018121
2023-05-31 14:57 g0tmi1k Status new => closed